troubleshooting Question

Cisco ASA 5505 Port Forwarding

Avatar of ReedServices
ReedServices asked on
RoutersVPNCisco
11 Comments1 Solution526 ViewsLast Modified:
Hello,

i am trying to simply forward some ports from the external interface to the internal interface and I am not having any luck.  The packet trace in the ASDM software says I have an ACL problem.

Any ideas?

:
ASA Version 7.2(4)
!
hostname xxx
domain-name xxx
enable password .g8Q0eZqgtbvmX83 encrypted
passwd 2KFQnbNIdI.2KYOU encrypted
names
name 100.100.100.50 bs0
name xxx.xxx.xxx.xxx extip
name 100.100.100.55 bs
name 100.100.100.51 bs1
name 100.100.100.52 bs2
name 100.100.100.53 bs4993
name 100.100.100.54 opf
!
interface Vlan1
 nameif inside
 security-level 100
 ip address 100.100.100.1 255.255.255.0
!
interface Vlan2
 nameif outside
 security-level 0
 ip address extip 255.255.255.0
!
interface Vlan3
 no forward interface Vlan1
 nameif dmz
 security-level 50
 ip address 10.10.10.1 255.255.255.0
!
interface Ethernet0/0
 switchport access vlan 2
!
interface Ethernet0/1
!
interface Ethernet0/2
!
interface Ethernet0/3
!
interface Ethernet0/4
!
interface Ethernet0/5
!
interface Ethernet0/6
 switchport access vlan 3
!
interface Ethernet0/7
 switchport access vlan 3
!
ftp mode passive
dns domain-lookup outside
dns server-group DefaultDNS
 name-server xxx.xxx.xxx.xxx
 name-server xxx.xxx.xxx.xxx
 domain-name xxx
same-security-traffic permit inter-interface
access-list testgroup_splitTunnelAcl standard permit 100.100.100.0 255.255.255.0
access-list inside_nat0_outbound extended permit ip 100.100.100.0 255.255.255.0 192.168.5.0 255.255.255.240
access-list inside_nat0_outbound extended permit ip any 192.168.5.0 255.255.255.240
access-list outside_access_in extended permit ip any any
access-list outside_access_in extended permit ip any host bs0
access-list outside_access_in extended permit udp any host bs0
access-list outside_access_in extended permit tcp any host bs0
access-list inside_access_in extended permit ip xxx.xxx.xxx.xxx 255.255.255.0 100.100.100.0 255.255.255.0
access-list inside_access_in extended permit ip 100.100.100.0 255.255.255.0 98.133.230.0 255.255.255.0
pager lines 24
logging enable
logging asdm informational
mtu inside 1500
mtu outside 1500
mtu dmz 1500
ip local pool remotepool 192.168.5.5-192.168.5.10
icmp unreachable rate-limit 1 burst-size 1
icmp permit any inside
icmp permit any outside
icmp permit any dmz
asdm image disk0:/asdm-524.bin
no asdm history enable
arp timeout 14400
global (outside) 1 interface
nat (inside) 0 access-list inside_nat0_outbound
nat (inside) 1 100.100.100.0 255.255.255.0
nat (inside) 1 0.0.0.0 0.0.0.0
nat (dmz) 1 10.10.10.0 255.255.255.0
static (outside,inside) tcp bs0 2222 extip 3333 netmask 255.255.255.255
static (outside,dmz) udp bs0 2222 extip 3334 netmask 255.255.255.255
static (outside,dmz) tcp bs1 2222 extip 3335 netmask 255.255.255.255
static (outside,dmz) udp bs1 2222 extip 3336 netmask 255.255.255.255
static (outside,dmz) tcp bs2 2222 extip 3337 netmask 255.255.255.255
static (outside,dmz) udp bs2 2222 extip 3338 netmask 255.255.255.255
static (outside,dmz) tcp bs4993 2222 extip 3339 netmask 255.255.255.255
static (outside,dmz) udp bs4993 2222 extip 3340 netmask 255.255.255.255
static (outside,dmz) tcp opf 2222 extip 3341 netmask 255.255.255.255
static (outside,dmz) udp opf 2222 extip 3342 netmask 255.255.255.255
static (outside,dmz) tcp bs 2222 extip 3343 netmask 255.255.255.255
static (outside,dmz) udp bs 2222 extip 3344 netmask 255.255.255.255
static (outside,dmz) tcp bs0 44818 extip 3345 netmask 255.255.255.255
static (outside,dmz) udp bs0 44818 extip 3346 netmask 255.255.255.255
static (outside,dmz) tcp bs1 44818 extip 3347 netmask 255.255.255.255
static (outside,dmz) udp bs1 44818 extip 3348 netmask 255.255.255.255
static (outside,dmz) tcp bs2 44818 extip 3349 netmask 255.255.255.255
static (outside,dmz) udp bs2 44818 extip 3350 netmask 255.255.255.255
static (outside,dmz) tcp bs4993 44818 extip 3351 netmask 255.255.255.255
static (outside,dmz) udp bs4993 44818 extip 3352 netmask 255.255.255.255
static (outside,dmz) tcp opf 44818 extip 3353 netmask 255.255.255.255
static (outside,dmz) udp opf 44818 extip 3354 netmask 255.255.255.255
static (outside,dmz) tcp bs 44818 extip 3355 netmask 255.255.255.255
static (outside,dmz) udp bs 44818 extip 3356 netmask 255.255.255.255
static (dmz,dmz) tcp bs0 www extip 81 netmask 255.255.255.255
static (dmz,dmz) tcp bs1 82 extip www netmask 255.255.255.255
access-group inside_access_in in interface inside
access-group outside_access_in in interface outside
route outside 0.0.0.0 0.0.0.0 xxx.xxx.xxx.xxx. 1
timeout xlate 3:00:00
timeout conn 1:00:00 half-closed 0:10:00 udp 0:02:00 icmp 0:00:02
timeout sunrpc 0:10:00 h323 0:05:00 h225 1:00:00 mgcp 0:05:00 mgcp-pat 0:05:00
timeout sip 0:30:00 sip_media 0:02:00 sip-invite 0:03:00 sip-disconnect 0:02:00
timeout sip-provisional-media 0:02:00 uauth 0:05:00 absolute
http server enable
http 192.168.5.0 255.255.255.0 inside
http 0.0.0.0 0.0.0.0 outside
http 100.100.100.0 255.255.255.0 inside
no snmp-server location
no snmp-server contact
snmp-server enable traps snmp authentication linkup linkdown coldstart
crypto ipsec transform-set ESP-3DES-SHA esp-3des esp-sha-hmac
crypto dynamic-map outside_dyn_map 20 set pfs group1
crypto dynamic-map outside_dyn_map 20 set transform-set ESP-3DES-SHA
crypto dynamic-map outside_dyn_map 40 set pfs group1
crypto dynamic-map outside_dyn_map 40 set transform-set ESP-3DES-SHA
crypto map outside_map 65535 ipsec-isakmp dynamic outside_dyn_map
crypto map outside_map interface outside
crypto isakmp enable outside
crypto isakmp policy 10
 authentication pre-share
 encryption 3des
 hash sha
 group 2
 lifetime 86400
crypto isakmp nat-traversal  20
telnet timeout 5
ssh 100.100.100.0 255.255.255.0 inside
ssh timeout 5
console timeout 0
management-access inside
dhcpd auto_config outside
!
dhcpd address 100.100.100.2-100.100.100.33 inside
dhcpd enable inside
!

tftp-server inside 100.100.100.250 /config1
group-policy testgroup internal
group-policy testgroup attributes
 dns-server value xxx.xxx.xxx.xxx. xxx.xxx.xxx.xxx
 vpn-tunnel-protocol IPSec
 split-tunnel-policy tunnelspecified
 split-tunnel-network-list value testgroup_splitTunnelAcl
username tcgas password FaR2xPbmMAE9kP5d encrypted privilege 15
tunnel-group testgroup type ipsec-ra
tunnel-group testgroup general-attributes
 address-pool remotepool
 default-group-policy testgroup
tunnel-group testgroup ipsec-attributes
 pre-shared-key *
tunnel-group Buckshot type ipsec-ra
tunnel-group Buckshot general-attributes
 address-pool remotepool
tunnel-group Buckshot ipsec-attributes
 pre-shared-key *
!
class-map inspection_default
 match default-inspection-traffic
!
!
policy-map type inspect dns preset_dns_map
 parameters
  message-length maximum 512
policy-map global_policy
 class inspection_default
  inspect dns preset_dns_map
  inspect ftp
  inspect h323 h225
  inspect h323 ras
  inspect rsh
  inspect rtsp
  inspect esmtp
  inspect sqlnet
  inspect skinny
  inspect sunrpc
  inspect xdmcp
  inspect sip
  inspect netbios
  inspect tftp
  inspect pptp
!
service-policy global_policy global
prompt hostname context
Cryptochecksum:922f821b5ba4032d96fce619f81a1a92
: end
asdm image disk0:/asdm-524.bin
asdm location extip 255.255.255.255 inside
asdm location bs0 255.255.255.255 inside
no asdm history enable
Join the community to see this answer!
Join our exclusive community to see this answer & millions of others.
Unlock 1 Answer and 11 Comments.
Join the Community
Learn from the best

Network and collaborate with thousands of CTOs, CISOs, and IT Pros rooting for you and your success.

Andrew Hancock - VMware vExpert
See if this solution works for you by signing up for a 7 day free trial.
Unlock 1 Answer and 11 Comments.
Try for 7 days

”The time we save is the biggest benefit of E-E to our team. What could take multiple guys 2 hours or more each to find is accessed in around 15 minutes on Experts Exchange.

-Mike Kapnisakis, Warner Bros