troubleshooting Question

STP Blocking state allowing the traffic

Avatar of imranrft
imranrft asked on
Network Analysis
2 Comments1 Solution726 ViewsLast Modified:
I know it is a lengthy post and it’s bit difficult to read all but I would really appreciate your time and will really be thankful for helping me out.

SW 1 and SW2 are connected back to back through port channel trunk and having HSRP running between them. Both switches’ port no 22 (G0/22) are the members of Vlan 50 (switchport access vlan 50) and are connected to another two dump switches which are also connected back to back . So mean to say, SW1’s port 22 is connected to SW3 and SW2’s port 22 is connected to SW4. SW1 and SW2 are connected back to back having HSRP running between them (SW2 is a standby Switch) and SW3 and SW4 are connected back to back without running HSRP. SW3 and SW4 are layer 2 dump switches and are on network 192.168.50.0/24 and that is why they are individually connected to SW1 and SW2 respectively on their port 22 which is a member of vlan 50

The gateway of all machines which are connected to SW3 and SW 4 is 192.168.50.253 which is a virtual IP. The physical IP of int vlan 50 on SW1 is 192.168.50.251 and  192.168.50.252 on SW2. Ideally, machines should send traffic to SW1 or SW2 only when they need to communicate to the devices outside vlan 50 but that is not the case, I can see the local traffic of vlan 50 going through the trunk between SW1 and SW2 alongwith HSRP hello packets. What does that mean if I disconnect the trunk between SW1 and SW2, will it affect the traffic between SW3 and SW4 which is a local traffic?

Moreover, when I saw the status of STP in each switch (all switches are running default STP), I found that SW3 is a root bridge and both SW1 and SW2 port 22 is a RP port. SW2 port channel which is connected to SW1 is DP and therefore port channel of SW1 is in blocking state which means the trunk between SW1 and SW2 is in a blocking state

Now my question is  if trunk between SW2 and SW1 is in blocking state then how they are sending hello packets to eachother for HSRP and how the local traffic (that is source 192.168.50.x to destination 192.168.50.x) is going through the trunk (which at first place should not be happening) and what if I disconnect the trunk between SW1 and SW2? Will it affect the local traffic??


I would really be grateful If anyone can clarify me confusion.


SW1 Configuration


spanning-tree mode pvst

spanning-tree extend system-id

!

interface Port-channel1

switchport trunk encapsulation dot1q

switchport mode trunk


interface GigabitEthernet0/1

description WAN_Link

no switchport

ip address 2.2.2.2 255.255.255.252


interface GigabitEthernet0/22

switchport access vlan 50

switchport mode access


interface GigabitEthernet0/47

description Connection_A_To_SW2

switchport trunk encapsulation dot1q

switchport mode trunk

channel-group 1 mode on

!

interface GigabitEthernet0/48

description Connection_B_To_SW2

switchport trunk encapsulation dot1q

switchport mode trunk

channel-group 1 mode on


interface Vlan50

ip address 192.168.50.251 255.255.255.0

standby 1 ip 192.168.50.253

standby 1 priority 105

standby 1 preempt

standby 1 track GigabitEthernet0/1




SW 2 Configuration


spanning-tree mode pvst

spanning-tree extend system-id

!

interface Port-channel1

switchport trunk encapsulation dot1q

switchport mode trunk


interface GigabitEthernet0/1

description WAN_Link

no switchport

ip address 1.1.1.1 255.255.255.252



interface GigabitEthernet0/22

switchport access vlan 50

switchport mode access


interface GigabitEthernet0/47

description Connection_A_To_SW1

switchport trunk encapsulation dot1q

switchport mode trunk

channel-group 1 mode on

!

interface GigabitEthernet0/48

description Connection_B_To_SW1

switchport trunk encapsulation dot1q

switchport mode trunk

channel-group 1 mode on


interface Vlan50

ip address 192.168.50.252 255.255.255.0

standby 1 ip 192.168.50.253

standby 1 preempt

standby 1 track GigabitEthernet0/1

STP-query.jpg
Join the community to see this answer!
Join our exclusive community to see this answer & millions of others.
Unlock 1 Answer and 2 Comments.
Join the Community
Learn from the best

Network and collaborate with thousands of CTOs, CISOs, and IT Pros rooting for you and your success.

Andrew Hancock - VMware vExpert
See if this solution works for you by signing up for a 7 day free trial.
Unlock 1 Answer and 2 Comments.
Try for 7 days

”The time we save is the biggest benefit of E-E to our team. What could take multiple guys 2 hours or more each to find is accessed in around 15 minutes on Experts Exchange.

-Mike Kapnisakis, Warner Bros