IBM Laptop Operating System Not Found Error

I have an IBM T40.  I have tried to boot it from three separate HDDs.  In EACH case, I get a screen that includes this message:  "PXE - E61: Media test failure, check cable."

It then says "Operating System Not Found"

I get the EXACT same message when I remove the HDD!

Two of the three HDD's I tried are bootable.

I went into teh BIOS earlier and I think I messed up the boot order.  I'm hoping someone can help me diagnose the problem and, presumably, reconfigure BIOS.

Thank you for your help.

Windows XP Pro, by the way.
ralphwalkerdjAsked:
Who is Participating?
I wear a lot of hats...

"The solutions and answers provided on Experts Exchange have been extremely helpful to me over the last few years. I wear a lot of hats - Developer, Database Administrator, Help Desk, etc., so I know a lot of things but not a lot about one thing. Experts Exchange gives me answers from people who do know a lot about one thing, in a easy to use platform." -Todd S.

gcolquhounCommented:
PXE-E61: Media test failure, check cable - This means that the laptop is trying to boot from lan.

I do not have an IBM T40 to look at, though you need to ensure that HDD0/HDD1/HDD/Harddrive is set to boot first (one of the previous should be there).

It is obviously currently trying to boot from lan, then either CD/DVD drive, or from a USB stick, and isnt finding an operating system.
ralphwalkerdjAuthor Commented:
I know nothing about BIOS, but what you're describing seems to fit.

I have Ultimate Boot CD.  Will this help?

I seem to remember that if you hit F8, F12, F11....??  that you can change the boot order.  I guess I need to know how to do this.
gcolquhounCommented:
You will need to type in F10/11/12 when the laptop is booting to get into the BIOS (this will be displayed on the screen), then you should see where you need to change it, its usually fairly obvious.
Rowby Goren Makes an Impact on Screen and Online

Learn about longtime user Rowby Goren and his great contributions to the site. We explore his method for posing questions that are likely to yield a solution, and take a look at how his career transformed from a Hollywood writer to a website entrepreneur.

ralphwalkerdjAuthor Commented:
I know... But it's this fairly obvious knowledge that seems to be getting me into trouble.  
Iain MacMillanIT Regional Manager - UKCommented:
on a T40 its F1 to enter the BIOS, when the IBM logo is on the screen, then go to the Config Menu and then Boot.  You should be able to use the F5, F6 and X keys to get the system in the right order, normally CD/DVD, then HDD.

if it still doesn't boot, but sees the drive, it could be the HDD in question has not been formatted to IBM's spec and contain the correct Rescue & Recovery software (recovery partition accessed via the BLUE button), plus the OS - you may have to acquire R&R CD media for your model, and given its out of warranty, its going to cost you.  Best bet would be to contact Lenovo tech support, give them the model and serial number and they will get you a quote.

you can try what i like to call a 'cold build', which i have done on a few IBM's over the years, where you have a legal OEM copy of say XP, and install it onto the system, then manually prep a CD on another system, with all the downloaded files you can find on the Lenovo support site, including the System Update app.  Slow tedious work, and sometimes it just doesn't work/get stable - but its an option if your stuck with no recovery partition/discs.
vivigattCommented:
Also, press <Escape> key when the system is in PXE boot (when it displays something similar to what you can see in this image): http://www.deployvista.com/Portals/0/WDS-F11-1.png  . I attached the image to this post)

Pressing Escape key will exit PXE boot rom and start the next boot device, which should be your HDD at one time or another.

If this works, then you need to change the boot device order in BIOS, as IainNIX described above.

I would hope that the first of your previous HDD should work OK

WDS-F11-1.png
Wesley MillerComputer Network AnalystCommented:
After you press F1, and then hight ight XCONFIG with down arrow key and press enter.
Then Press Enter again as Network should be first listing.
DISABLE the Internal Rom as that is what causes the error you are getting.
Press F10 confirm save settings and system should reboot and use drive....
 
ralphwalkerdjAuthor Commented:
I think we may be getting somewhere.  


I did disable teh Internal ROM, and this DID correct the error.  But still not OS found.

In boot order...... here are my choices:

IDE HDD1
IDE HDD0
IDE HDD2 (excluded from boot order)
Legacy Floppy Drives
ATAPI CD0:  xxxxxxxxDVD/CDRW
USB CD
PCI LAN
USB HDD

FYI... I downloaded Ultmate Boot CD, and ran its partition program (What a great package of software, by the way!)  At any rate, it didn't seem to recognize my HDD.  Could that be because the boot order is wrong?   At any rate, all three of my HDDs are not being recognized.  Is this starting to sound like a motherboard issue?
Wesley MillerComputer Network AnalystCommented:
Try using BooyItng ,
http://www.terabyteunlimited.com/downloads-bootit-next-generation.htm
is simialr to Ultimate BOOT CD but uses it's own bootstrap to find drives so it might see them.
When it is booted  it will prompt to create its own boot file , clcik cancel, Ok, it should then scan the drives and show each one. next click partion work then properties.
It should tell you the boot sector is bad and ask do you want to fix it, Click Yes, oK, Close and reboot......that should relink the boot to the O/S.
Wes
ralphwalkerdjAuthor Commented:
Hi Wes-
Thank you. But it seems like something is causing the comptuer to not see the HDD.  

The most obv ious is that the IDE controller is shot.  This is what seems to be the case.

Before doing anything else, I wan to make sure the boot order is correct.  

Am I thinking correctly here?   (I'm not a computer guy!!!)
Wesley MillerComputer Network AnalystCommented:
Strange that the CD Drive works....
Boot order can be any way you want,
 The standard order is:
Legacy Floppy Drives
 USB CD
 USB HDD
ATAPI CD0:  xxxxxxxxDVD/CDRW
IDE HDD0
IDE HDD1

IDE HDD2 (excluded from boot order)



PCI LAN
 
That reminds me in the Bios there is a security screen....
Make sure all are disabled as I beleive one of the settings is to disable the IDE so the machine will only boot from the PCI Lan....
Wes
ralphwalkerdjAuthor Commented:
Thank you, Wes!

I wanted to clarify about the security screen in BIOS....

I typed the following
F1  .... sent me to IBM BIOS Setup Utility
Security
    HEre, there are four choices:
        a) Password ... everything seems to be disabled
        b)  IBM Security Chip  ......  This is disabled
        c)  IBM Predesktop area ...  Current setting is NORMAL.  (It can either be Disabled, normal or secure)
        d)  BIOS Update Option....  Current setting is ENABLED.
I made the changes in teh boot order and still no change... I get the "No OS" message.

Given all this, is your hunch that this is a BIOS issue, or a hardware issue (e.g. motherboard is shot)?
vivigattCommented:
What is the status of HDD controller in BIOS?
Enabled, Disabled?

If HDD controller is disabled, then no HDD can show up.

Also make sure that teh cables are correctly connected from the MB to the HDDs, that you have the correct slave/master jumpers (if need be).

If you are positive about the HDD controller being enabled, I would suggest trying to detect each HDD one after the other. This could help you nailing down the problem.

You can also test the HDDs in some other compatible PC and see if they are recognized.
ralphwalkerdjAuthor Commented:
I think there needs to be some clarification:

This is an IBM T40 Laptop.  There is only one HDD.  I have not disconnected any cables, to my knowledge.

How do I check to see teh status of the HDD in BIOS????????????   Can you tell me exactly where to go?  Thank you!!

I have tested the HDD's on another computer.  It recognizes them.

Consequently....... It appears that there are only two possible solutions:
1) The BIOS is not directing to the HDD
2) There a problem with the IDE controller.

Wesley MillerComputer Network AnalystCommented:

Yes the security settings sound correct, try F9 for Defaults Settings  and then F10 to save the default settings?
To get drive info you would have to use a CD which you already did ,it didn't see the drives you  said.
Also with the IBM Laptop drives if you dont have them in a carrier you might be putting them in wrong....Look in where they slide and make sure the drive is oriented to slide in and mesh with the female connector within.
wes
vivigattCommented:
OK, I was confused because you mentioned several HDDs.

I don't know IBM's T40 laptop BIOS settings.
If it is like my z60m, it could be after pressing F1, go to "Boot", make sure that HDD0 is specified before "PCI LAN" and that all othe HDD (HDD1, HDD2 etc) are excluded. You use X key to exclude/include a device from the boot list
Also, in Config/PCI, make sure that all interrupts are set to "auto select"

I could not find a setting to disable HDD controller on my z60m, maybe there is no such setting on your T40 either. If so, well... It might be that your MB and/or HDD controller is dead.

ralphwalkerdjAuthor Commented:
Thank you for all the advice.  I think I'm about ready to throw in the towel.   I tried all of the above with no luck.
Iain MacMillanIT Regional Manager - UKCommented:
sometimes they just give out, had a T43 last week, function fine for 2 days in a test cabin -- yesterday, it just gave up, after several failed boots -- diagnostics now say there is no drive, and refuses to boot to anything but the CD.  After 5 years faithful service, i can't complain.

if you need to get data off the drives, best bet is to slave them up to another system, but you already know how to do that, when you tested them.
Wesley MillerComputer Network AnalystCommented:
Chcked Lenovo's site and you might try updating the BIOS & Embedded Controller,
See: http://www-307.ibm.com/pc/support/site.wss/document.do?lndocid=MIGR-46258
As the Embedded Controller version 3.04 update says it fixes:
(Fix) After completing the Embedded Controller Program update and the computer is automatically rebooted, the error message, "Operating System not found", may be displayed and reboot stops.

Experts Exchange Solution brought to you by

Your issues matter to us.

Facing a tech roadblock? Get the help and guidance you need from experienced professionals who care. Ask your question anytime, anywhere, with no hassle.

Start your 7-day free trial
It's more than this solution.Get answers and train to solve all your tech problems - anytime, anywhere.Try it for free Edge Out The Competitionfor your dream job with proven skills and certifications.Get started today Stand Outas the employee with proven skills.Start learning today for free Move Your Career Forwardwith certification training in the latest technologies.Start your trial today
Digital Audio

From novice to tech pro — start learning today.