Problem creating Active-sync virtual directory when reinstalling Exchange 2007

We tried to upgrade our exchange 2007 to the newest SP3 and that upgrade went wrong and we couldn't proceed. We manually removed the exchange.

Now when we tried to install the SP3 version we got the error:
Client Access Role
Failed

Error:
An error occurred while creating the IIS virtual directory 'IIS://app1.domain.local/W3SVC/1/ROOT/Microsoft-Server-ActiveSync' on 'app1'.

The network path was not found.

Open in new window


We have reinstalled the iis and the errror is still there.
I think there is anything we missed to delete when we made the manual uninstall of the first exchange but we can't find it.

/Per-Erik Modig
pemodigAsked:
Who is Participating?
I wear a lot of hats...

"The solutions and answers provided on Experts Exchange have been extremely helpful to me over the last few years. I wear a lot of hats - Developer, Database Administrator, Help Desk, etc., so I know a lot of things but not a lot about one thing. Experts Exchange gives me answers from people who do know a lot about one thing, in a easy to use platform." -Todd S.

als315Commented:
Have you opened IIS manager and checked "old" virtual settings?
pemodigAuthor Commented:
The old virtual settings are gone since we reinstall the iis.
I tried to manually create the virtual directory but then i get the message that a virtual directory with the same name exists.

The installation have created the following directories; Autodiscover, Exchange, Exchweb, OAB, owa, public and UnifiedMessaging.

So it looks like it's only the active sync directory thats not generated.

/Per-Erik
OWASP: Forgery and Phishing

Learn the techniques to avoid forgery and phishing attacks and the types of attacks an application or network may face.

pemodigAuthor Commented:
Thanks als315 for trying to help me.

The Remote Regsitry Service is started.

I will try to install the exchange without CAS role an then add that role from shell afterwards.

/Per-Erik
pemodigAuthor Commented:
The last lines in Exchangesetuplog is as follows:
[code]

[2010-10-16 14:38:14] [2] Processing object "app1\Microsoft-Server-ActiveSync".
[2010-10-16 14:38:26] [2] [WARNING] A failure occurred while trying to enable the ISAPI filter.
[2010-10-16 14:38:27] [2] [ERROR] Unexpected Error
[2010-10-16 14:38:27] [2] [ERROR] An error occurred while creating the IIS virtual directory 'IIS://app1.domain.local/W3SVC/1/ROOT/Microsoft-Server-ActiveSync' on 'app1'.
[2010-10-16 14:38:27] [2] [ERROR] The network path was not found.

[2010-10-16 14:38:27] [2] Ending processing.
[2010-10-16 14:38:27] [1] The following 1 error(s) occurred during task execution:
[2010-10-16 14:38:27] [1] 0.  ErrorRecord: An error occurred while creating the IIS virtual directory 'IIS://app1.domain.local/W3SVC/1/ROOT/Microsoft-Server-ActiveSync' on 'app1'.
[2010-10-16 14:38:27] [1] 0.  ErrorRecord: System.InvalidOperationException: An error occurred while creating the IIS virtual directory 'IIS://app1.domain.local/W3SVC/1/ROOT/Microsoft-Server-ActiveSync' on 'app1'. ---> System.IO.IOException: The network path was not found.

   at Microsoft.Win32.RegistryKey.Win32ErrorStatic(Int32 errorCode, String str)
   at Microsoft.Win32.RegistryKey.OpenRemoteBaseKey(RegistryHive hKey, String machineName)
   at Microsoft.Exchange.Management.Metabase.ActiveSyncIsapiFilter.CreateFilter(String adsiWebSitePath, Boolean& filterCreated)
   at Microsoft.Exchange.Management.SystemConfigurationTasks.MobileSyncVirtualDirectoryHelper.InstallIsapiFilter(ADMobileVirtualDirectory vdirObject)
   at Microsoft.Exchange.Management.SystemConfigurationTasks.NewMobileSyncVirtualDirectory.InternalProcessMetabase()
   at Microsoft.Exchange.Management.SystemConfigurationTasks.NewExchangeVirtualDirectory`1.InternalProcessRecord()
   --- End of inner exception stack trace ---
[2010-10-16 14:38:27] [1] [ERROR] An error occurred while creating the IIS virtual directory 'IIS://app1.domain.local/W3SVC/1/ROOT/Microsoft-Server-ActiveSync' on 'app1'.
[2010-10-16 14:38:27] [1] [ERROR] The network path was not found.

[2010-10-16 14:38:27] [1] Setup is halting task execution because of one or more errors in a critical task.
[2010-10-16 14:38:27] [1] Finished executing component tasks.
[2010-10-16 14:38:27] [1] Ending processing.
[2010-10-16 15:14:29] [0] End of Setup
[2010-10-16 15:14:29] [0] **********************************************
[/code]

/Per-Erik
als315Commented:
Have you switched IIS to 6-bit mode, as recommended?
http://social.technet.microsoft.com/forums/en-US/exchangesvrclients/thread/9f23fe1c-ca24-4abf-b880-5517d20b6211/
It is strange, because other virtual directories were created successfully.
pemodigAuthor Commented:
Thanks for your help!

The setup is now completed.

Tha last things i fix was:
1. Run windwos update and fetch some updates
2. Switch iis to 64 bits as you mentioned
3. set Printing an files sharing on the wan nic.

/Per-Erik

Experts Exchange Solution brought to you by

Your issues matter to us.

Facing a tech roadblock? Get the help and guidance you need from experienced professionals who care. Ask your question anytime, anywhere, with no hassle.

Start your 7-day free trial
It's more than this solution.Get answers and train to solve all your tech problems - anytime, anywhere.Try it for free Edge Out The Competitionfor your dream job with proven skills and certifications.Get started today Stand Outas the employee with proven skills.Start learning today for free Move Your Career Forwardwith certification training in the latest technologies.Start your trial today
Exchange

From novice to tech pro — start learning today.