Installing red5 with errors

jnettech
jnettech used Ask the Experts™
on
i am trying to install red5 useing this guide on centos http://www.saifur-rahman.com/2009/12/how-to-install-red5-on-cent-os-54/ and when i do ant pepare i get this error /usr/local/red5/build.xml:4: Class org.apache.tools.ant.taskdefs.ConditionTask doesn't support the nested "antversion" element


the verson on ant is 1.6.5
Comment
Watch Question

Do more with

Expert Office
EXPERT OFFICE® is a registered trademark of EXPERTS EXCHANGE®
Hello! Pls give it a try:

cd /opt
wget http://archive.apache.org/dist/ant/binaries/apache-ant-1.7.1-bin.tar.gz 


tar xzf apache-ant-1.7.1-bin.tar.gz
ln -s apache-ant-1.7.1 ant


vim /etc/profile.d/ant.sh


add the following lines :
export ANT_HOME=/opt/ant
export PATH=/opt/ant/bin:$PATH


save & exit
reboot


then verify with
env |grep ANT


should give :
ANT_HOME=/opt/ant


then
ant -version


should give :
Apache Ant version 1.7.1 compiled on June 27 2008


then back to your red5 folder and then :


ant prepare
ant dist
cp -r dist/conf .


Best regards,

Do more with

Expert Office
Submit tech questions to Ask the Experts™ at any time to receive solutions, advice, and new ideas from leading industry professionals.

Start 7-Day Free Trial