Server 2008 issues expanding volume

I am running server 2008 Standard SP1 (6.0.6001 SP1 build 6001)CPU Intel E5405 with 8GB Ram... System Type x64 on an ASUS MOBO I have a Raid controller, areca-1230. I have 4 Hitachi 2TB drives in a raid  6 connected to the controller which provides ~4TB of useable space. I then expanded this raid and added another 2TB disk. Disk Manager now shows nearly 6TB usable, but windows does not. I have rebooted serveral times, and have looked at several threads however no seems to have identify the cause or the solution.

Another thing I tried was shrinking the volume and expanding it again using diskpart that too did not fix the issue... Now disk manager reports 5.7TB but windows sees 1.8TB. Also when I try using a right click grow or diskpart I get an error saying the volume grew, but there was an error, and to check the system log... when I check the system log I see no events that corralate.

 

I am providing some screen shots as well, and incase my html insert for screen shots do not work please see the following link:

http://s926.photobucket.com/albums/ad110/dcatcha/?action=view¤t=raid_config.jpg

 

I looked at MS http://support.microsoft.com/kb/832316

This KB sounds like my issue, but the HOTFIX is only available for xp & server 2003... and server 2008 has the extend file system command, but that doesn't seem to correct my issue see the diskpart command below...

Installed SP2 for server 2008 and that had no change. Here are more details of what I did after Installed SP2.

 

Microsoft Windows [Version 6.0.6002]
Copyright (c) 2006 Microsoft Corporation.  All rights reserved.

CDISKPART> list disk

  Disk ###  Status      Size     Free     Dyn  Gpt
  --------  ----------  -------  -------  ---  ---
  Disk 0    Online       699 GB  1101 MB
  Disk 1    Online       699 GB  1101 MB
* Disk 2    Online      5588 GB      0 B        *
  Disk 3    Online       466 GB      0 B
  Disk 4    Online      1397 GB      0 B
  Disk 5    Online      1863 GB      0 B

DISKPART> select disk 2

Disk 2 is now the selected disk.

DISKPART> detail disk

Huawei row_1 SCSI Disk Device
Disk ID: {4A3523FD-EE28-439A-83B8-2BFA47AEFA2F}
Type   : SCSI
Bus    : 0
Target : 0
LUN ID : 0
Read-only  : No
Boot Disk  : No
Pagefile Disk  : No
Hibernation File Disk  : No
Crashdump Disk  : No

  Volume ###  Ltr  Label        Fs     Type        Size     Status     Info
  ----------  ---  -----------  -----  ----------  -------  ---------  --------
  Volume 4     F   New Volume   NTFS   Partition   5588 GB  Healthy

DISKPART> select volume 4

Volume 4 is the selected volume.

DISKPART> detail volume

  Disk ###  Status      Size     Free     Dyn  Gpt
  --------  ----------  -------  -------  ---  ---
* Disk 2    Online      5588 GB      0 B        *

Read-only              : No
Hidden                 : No
No Default Drive Letter: No
Shadow Copy            : No
Dismounted             : No
BitLocker Encrypted    : No

Volume Capacity        : 1887 GB -------> I see here the size and capacity differ
Volume Free Space      :   82 GB

DISKPART> list partition

  Partition ###  Type              Size     Offset
  -------------  ----------------  -------  -------
  Partition 1    Reserved           128 MB    17 KB
* Partition 2    Primary           5588 GB   129 MB

DISKPART>

n_t_schultzAsked:
Who is Participating?
I wear a lot of hats...

"The solutions and answers provided on Experts Exchange have been extremely helpful to me over the last few years. I wear a lot of hats - Developer, Database Administrator, Help Desk, etc., so I know a lot of things but not a lot about one thing. Experts Exchange gives me answers from people who do know a lot about one thing, in a easy to use platform." -Todd S.

noxchoIT Product ManagerCommented:
Looks like your drive is MBR formatted. Can you enter Windows Disk Management and take a screen shot of it?
Right click on My Computer - Manage - Disk Management.
MBR disks have limit of 2TB and only GPT drives enable you using the space that exceeds this size.
n_t_schultzAuthor Commented:
Here is the screen shot you asked for
raid-config1.JPG
n_t_schultzAuthor Commented:
I don't think it is an MBR disk if you look at the data from diskpart it shows up as a GPT volume.
Introduction to Web Design

Develop a strong foundation and understanding of web design by learning HTML, CSS, and additional tools to help you develop your own website.

noxchoIT Product ManagerCommented:
Yes, you are correct. I just noticed it. Do you have backup of this drive?
Try to shrink it and then extend using Windows shrink tool. Right click on volume - shrink - try to shrink it for 50MB. Then if this does not fix the problem extend the partition back to 50MB.
n_t_schultzAuthor Commented:
I ran the the following command:
shrink desired=50
it came back and said it shrunk 3700GB

Now I tried to expand the volume, and I get:

DISKPART> extend size=3788800 disk=2

The selected volume cannot be extended because the filesytem on the volume does
not support extending.
For more information type: HELP EXTEND.

Here is the latest screen shot from Disk Manager...


raid-config2.JPG
n_t_schultzAuthor Commented:
one last note... when I ran the following command from diskpart it definately appears there is an issue with the attribute of the volume....
DISKPART> detail partition

Partition 2
Type    : ebd0a0a2-b9e5-4433-87c0-68b6b72699c7
Hidden  : No
Required: No
Attrib  : 0000000000000000

  Volume ###  Ltr  Label        Fs     Type        Size     Status     Info
  ----------  ---  -----------  -----  ----------  -------  ---------  --------
* Volume 4     F   New Volume   NTFS   Partition   1887 GB  Healthy
noxchoIT Product ManagerCommented:
Just for check, are you able to create additional partition of that 3700GB block of space?
n_t_schultzAuthor Commented:
Yes... below is the screen shot(s)

raid-config3.JPG
noxchoIT Product ManagerCommented:
Interesting case. Delete 3700GB drive. Then try extending the volume via Windows Disk Management not Diskpart. Right click on F: - Extend. Is there such option?
n_t_schultzAuthor Commented:
I rebooted the server, and then tried extending the volume, and now I get an error that says the volume does not support it. Below are the screen shots.
raid-config4.JPG
n_t_schultzAuthor Commented:
I also tried shrking hte volume by 1 MB which worked, then tried extending it the full amount and it fails with the same error as above. I have seen several posts with wndows server having similar issues and the only solution I have seen is to back up the data and re-do the raid volume... which I hope to avoid.
andyalderCommented:
Well, if diskpart won't do it you can always try an offline program instead like paragon partition manager and see what that says.
noxchoIT Product ManagerCommented:
Looks like I missed one important fact in your original post.
 Disk ###  Status      Size     Free     Dyn  Gpt - This line shows us that you are using dynamic GPT disk and you cannot extend dynamic drive. The easiest way you can do it - copy out data from F: volume (you have much data there huh) to another volume or disk. Then delete F:, then convert the drive from dynamic to Basic GPT. Then create on this dsk 5TB volume and copy the data back.

noxchoIT Product ManagerCommented:
Ok, now on screen shot I noticed it that you have Basic GPT. Can you run CHKDSK on F: partition in command line and see what cluster size you have there?
Also my suggestion of partition recreation should work in any case. Even if you do not convert the drive to any state.
n_t_schultzAuthor Commented:
NOXCHO, I think my cut and paste did not line correctly... I assure you it is not a dynamic GPT volume.... Attached is a screen shot from my laptop of the diskpart detail volume, as you can see it DYN is a column tht is always is listed. Additionaly as stated & shown prior the volume did let me grow it to the  5.7TB but after running the shrink & reboots SP2 etc it started giving me the error about not being able to expand the volume.

Is it possible that the issue could stem from my raid controller? When I setup the raid volume I am using LBA addressing with 128KB stripe.

In  the end I did what I was hoping to avoid, and that was back \ rebuild raid with the 5th disk\ Setup a new simple GPT volume.... currently I am restoring data, which should be completed by the end of the day.


diskpart.jpg
n_t_schultzAuthor Commented:
Also if you look at the following link I do have  screen shot of the volume detail
http://s926.photobucket.com/albums/ad110/dcatcha/?action=view¤t=raid_config.jpg

which lines up with what I stated about the cut and paste.
noxchoIT Product ManagerCommented:
I think RAID level cluster size does not control it. Disk you run CHKDSK as suggested? If not please run it again on 1800GB drive and send me report of the CHKDSK. We will see what size of cluster is used by your file system.
512 byte - max NTFS Size = 2TB
1024 byte - max NTFS Size = 4TB
2048 byte - max NTFS Size = 8TB

Experts Exchange Solution brought to you by

Your issues matter to us.

Facing a tech roadblock? Get the help and guidance you need from experienced professionals who care. Ask your question anytime, anywhere, with no hassle.

Start your 7-day free trial
noxchoIT Product ManagerCommented:
Typo in my question. Should be read DID you run CHKDSK as suggested?
n_t_schultzAuthor Commented:
I did not run the chkdsk... I guess I missed that part. But now that you mention it when I formated the disk the first time I am pretty sure I used 1024 block size.

My raid rebuild completed early this AM and I was able to setup the volume using a block size of 2048.
noxchoIT Product ManagerCommented:
So now it does see the whole 5TB?
n_t_schultzAuthor Commented:
Yes everything is operational. I am guessing that windows saw the volume do the fact raid was setup for LBA, but then when I formated the intial 4 disks it was set to 1024 and should have been 2048... thus the reason disk manager could see it, but the OS wouldn't fully recognize it.
n_t_schultzAuthor Commented:
It was a combination of things that lead the solution and the solution provided was not the fix but was the reason for the issue.
It's more than this solution.Get answers and train to solve all your tech problems - anytime, anywhere.Try it for free Edge Out The Competitionfor your dream job with proven skills and certifications.Get started today Stand Outas the employee with proven skills.Start learning today for free Move Your Career Forwardwith certification training in the latest technologies.Start your trial today
Windows Server 2008

From novice to tech pro — start learning today.