I recieve error "Task ‘Microsoft Exchange’ reported error (0x8004010F): ‘The operation failed. An object cannot be found.’" when send/recieve in Outlook 2007.

jso1227
jso1227 used Ask the Experts™
on
I have a fairly generic default installation of SBS 2008 and Exchange 2007. I only recieve this error outside the network. I have an (A) Record pointing "remote" to my ISP static IP. and an MX record of "@ remote.mydomain.com". I'm under the impression from what I've read that this error has to do with an Autodiscover (A) record needing to be added do to it's relationship to Offline Address Book (OAB). Does this look familiar to anyone? And what additions do I need to make to Exchange and DNS settings? My mail gets delivered no problem but I would like to get rid of the error message.
Comment
Watch Question

Do more with

Expert Office
EXPERT OFFICE® is a registered trademark of EXPERTS EXCHANGE®
Shreedhar EtteTechnical Manager
Top Expert 2010

Commented:
Hi,

Refer this:
http://support.microsoft.com/kb/905813

Hope this helps,
Shree
Shreedhar EtteTechnical Manager
Top Expert 2010

Commented:
Should you be charging more for IT Services?

Do you wonder if your IT business is truly profitable or if you should raise your prices? Learn how to calculate your overhead burden using our free interactive tool and use it to determine the right price for your IT services. Start calculating Now!

AkhaterSolutions Architect

Commented:
it is an OAB issue that's for sure how is your sbs published to the internet ?do you have ISA or just a firewall ?

no autodiscover has nothing to do in this.

what do  you get if you run a get-oabvirtualdirectory | fl *url* ?

Author

Commented:

khater,

This is what I get:

Get-OabVirtualDirectory : Unable to create Internet Information Services (IIS)
directory entry. Error message is: Access is denied.
. HResult = -2147024891.
At line:1 char:24
+ get-oabvirtualdirectory  <<<< | fl *url*

Author

Commented:


Also, the "Copy Status" of the First Storage Group is "Disabled". Does it matter that in Outlook, the OAB filename in Send/Recieve is "\Global Address List" but in Exchange under First Storage Group ---->Properties -----> Client Settings-------->Offline Adress Book, the file name is "\Default Offline Address Book"?
AkhaterSolutions Architect

Commented:
run powershell as administrator and try again
AkhaterSolutions Architect

Commented:
well this seems fine

how is your sbs published to the internet ?do you have ISA or just a firewall ?

Author

Commented:
Just a Firewall (ASA 5505)

Author

Commented:
Could this have anything to do with permisions on the OAB folder?
AkhaterSolutions Architect

Commented:
a permission issue would create the problem from both inside and outside...

can you please run get-oabvirtualdirectory | set-oabvirtualdirectory -BasicAuthentication $true

and see if it works?

Author

Commented:

[PS] C:\Windows\System32>get-oabvirtualdirectory | set-oabvirtualdirectory -Basi
cAuthentication $true
Set-OabVirtualDirectory : A parameter cannot be found that matches parameter na
me 'BasicAuthentication'.
At line:1 char:71
+ get-oabvirtualdirectory | set-oabvirtualdirectory -BasicAuthentication  <<<<
$true
[PS] C:\Windows\System32>
AkhaterSolutions Architect

Commented:
get-oabvirtualdirectory | set-oabvirtualdirectory -BasicAuthentication:$true

Author

Commented:
[PS] C:\Windows\System32>get-oabvirtualdirectory

Server              Name                Internal Url        External Url
------              ----                ------------        ------------
INTEGRASERVER       OAB (SBS Web App... https://remote.i... https://remote.i...


[PS] C:\Windows\System32>set-oabvirtualdirectory -BasicAuthentication:$true
Set-OabVirtualDirectory : A parameter cannot be found that matches parameter na
me 'BasicAuthentication'.
At line:1 char:46
+ set-oabvirtualdirectory -BasicAuthentication:$ <<<< true
[PS] C:\Windows\System32>
AkhaterSolutions Architect

Commented:
please don't copy paste try typing it


get-oabv(tab) | set-oabv(tab) -bas(tab) $true

Author

Commented:
Do you mean (tab) or (space)?

Author

Commented:
It doesn't like -bas

It's as if BasicAuthentication is not an accepted parameter.
AkhaterSolutions Architect

Commented:
well something is wrong ... I use it all the time check it

http://technet.microsoft.com/en-us/library/bb123515(EXCHG.80).aspx


what if you shoot

get-oabvirtualdirecotry | fl *auth*

Author

Commented:

[PS] C:\Windows\System32>Get-OabVirtualDirectory | fl *auth*


InternalAuthenticationMethods : {WindowsIntegrated}
ExternalAuthenticationMethods : {WindowsIntegrated}



[PS] C:\Windows\System32>
AkhaterSolutions Architect

Commented:
what exchange SP are you running ?

Author

Commented:
Exchange Server 2007

Microsoft Corporation

Version: 08.01.0240.006
AkhaterSolutions Architect

Commented:
yes I thought so, this was a bug there was a workaround around it but I dont remember it...

can you upgrade to sp2 ?
http://support.microsoft.com/default.aspx?scid=kb;EN-US;973862
AkhaterSolutions Architect

Commented:
oh boy .............................................................

I was re-reading and I did a mistake you DO need autodiscover.domain.com i am really sorry
AkhaterSolutions Architect

Commented:
or, allternatively, you can just point domain.com to the same ip of remote.domain.com

Author

Commented:
Given:

Total DNS: (Available)
ARecord @ 64.202.165.28
ARecord remote 67.200.221.178
CNAME www @
CNAME ftp @
MX @ remote.integranettx.com

What should the Autodiscover entry look like? Are you under the impression that this would correct the issue? Or does SP 2 need to be installed as well. I know that there issues with installing SP2 on SBS 2008 but MS has a work-around.
AkhaterSolutions Architect

Commented:
i would propose you upgrade to SP2 in all cases but not now.

your DNS host give you srv records?
AkhaterSolutions Architect

Commented:
ok i will leave to get a few hours sleep

if your DNS provider supports srv records create one as follows

Service: _autodiscover
Protocol: _tcp
Port Number: 443
Host: remote.domain.com

for weight and priority leave them empty or put them 0 it doesn't matter

leave it to replicate and test after a couple of hours

Author

Commented:

I setup the following SRV Record:

Name: @
Service: _autodiscover
Protocol: _tcp
Port Number: 443
Server: remote.integranettx.com

Still no change.

AkhaterSolutions Architect

Commented:
your srv record is set correctly

do u mind giving me a test username pass to know more waht is happening ?

Author

Commented:
On to the domain?
AkhaterSolutions Architect

Commented:
yes of course with a mailbox

all shd be fine now since the srv record is created

Author

Commented:
User Name: jsmith

Password: Password!
AkhaterSolutions Architect

Commented:
that would be jsmith@integranettx.com ??

Author

Commented:
Yes.
AkhaterSolutions Architect

Commented:
well this giving me wrong username password ....

is your ActieDirectory domain also integranettx.com ?

Author

Commented:
https://remote.integranettx.com/Remote/

User Name: jsmith

Password: Password! (Exclamation Point at the end)
AkhaterSolutions Architect

Commented:
what is your ad domain name ?

Author

Commented:
Integranet
AkhaterSolutions Architect

Commented:
OAB looks to be working just fine ...

one silly question you did add the root certificate to your clients computers right ?

Author

Commented:
Your not getting the Error at the bottom?

"Task ‘Microsoft Exchange’ reported error (0x8004010F): ‘The operation failed. An object cannot be found.’"

And  . . . . no I didn't add any certificate, did you?

Author

Commented:
And how did you do that remotely?
AkhaterSolutions Architect

Commented:
the computers you are trying from are joined to the domain right ?

Author

Commented:
The machine getting the error is not joined to the domain during testing - But is my productivity unit during the week - so connected to in the office I don't have any problems but at home on the weekends connected to the Exchange Server via Outlook, I get the error. Now, I don't get a certificate error on or off the domain.
AkhaterSolutions Architect

Commented:
if you don't get a certificate error then you are good certificate wise

can you email me the root certificate by email on jsmith@integranettx.com ?

I couldn't configure outlook yet since i don't have the root ca certificate
Solutions Architect
Commented:
everything worked perfectly

I suggest you delete the profile and test again.

also note that you have now autodiscover active so no need to create the profile manually. just enter email and password outlooks should configure itself

Author

Commented:
I'll test this on a different machine as well and update you with the results.

Author

Commented:
The problem was the self-signed certificate. Once I installed a 3rd party Class 2 Cert. (in this case GoDaddy) the OAB started downloading with no errors. Problem solved.
AkhaterSolutions Architect

Commented:
If the solution works you should assign full grade 500 points not only 250

Author

Commented:
Ok . . . here's another twist. The solution seemed to work in the office. I disconnected the network cable and used my Verizon Wireless device to simulate downloading the OAB off the network. I did not close down Outlook or shut down the machine and log back in. I entered my login credentials in the pop-up box in outlook after it detected the disconnect and then tried the OAB download again. It worked. Went to Send/Recieve --> Download OAB ---> got the window showing download progress. Success. At that point I assumed the issue was resolved. But when I got home and got back on the same computer and same Verizon Wireless device I connected and got my mail but again saw that the OAB was erroring out. Obviously I shut down to go home from work. Does this make any since at all???

Do more with

Expert Office
Submit tech questions to Ask the Experts™ at any time to receive solutions, advice, and new ideas from leading industry professionals.

Start 7-Day Free Trial