Page File Issue

I have a win 7 enterprise computer. When I login I recieve a pop up - see attachment screenshot. When I click the change button on the performance options tab, I notice that my page file is set to zero. I have tried setting the page file to "auto manage" or custom size. However the changes don't stick. As soon as I reboot and login I recieve the same pop up window and the page file is always reset to zero.

Not sure what else to do. My only thought is perhaps to repair windows with the install cd.

Any thoughts or suggestions?

Thanks
win-7-page-file-error---Copy.docx
richeydAsked:
Who is Participating?
I wear a lot of hats...

"The solutions and answers provided on Experts Exchange have been extremely helpful to me over the last few years. I wear a lot of hats - Developer, Database Administrator, Help Desk, etc., so I know a lot of things but not a lot about one thing. Experts Exchange gives me answers from people who do know a lot about one thing, in a easy to use platform." -Todd S.

DBrookfieldCommented:
When you change to system memory do you get the tick box for automatically manage page file for all drives?
richeydAuthor Commented:
I don't think your read my description. I changed to auto manage. That does not stick.
Kenneth BrownResearch AssociateCommented:
Not sure why its got to zero in the first place, but try a defrag and then change it in safe mode?
OWASP: Threats Fundamentals

Learn the top ten threats that are present in modern web-application development and how to protect your business from them.

richeydAuthor Commented:
no, it's an ssd drive and don't see how that is relevant anyway. doubt making the change in safe mode will make a difference but i guess it's worth a try.
crash2000Commented:
Hi Richeyd,

Try setting the pageing file to zero and then reboot. If it still doesn't stay checked, boot up from recovery partition or DVD and delete c:\pagefile.sys. Then reboot and try and set it.

I prefer to set my pagefile manually and have the Initial size and Maximum size both set to 1 and a half times the amount of memory installed in the computer. This allows for potential dumps and saves using resources to constantly change file size.
eg:- for 1Gb - Set to 1536Mb in both boxes.

Hope that helps
Mark
John GriffithConsultantCommented:
Hi -
Delete and reallocate the page file and set it to system managed -

1.  Boot into safemode and delete the page file =
START | type cmd.exe  | RIGHT-click on cmd.exe | Select "Run as Administrator" - then paste each line 1 at a time -
cd\
attrib -s -h pagefile.sys
del pagefile.sys

2. Turn pagefile back on - system managed settings
3. Re-boot into normal Windows
 

cd\ 
attrib -s -h pagefile.sys 
del pagefile.sys

Open in new window

richeydAuthor Commented:
Interesting. So step one has me deleting the file. Your second step tells me to "turn pagefile back on" I'm assuming that the steps for doing that is as follows on a Win7 computer:

1. In the "system properties" menu click on the Advanced tab
2. Click the "performance>settings button
3. Advanced tab>change button
4. select the "automatically manage paging file size for all drives" option
5. click ok and reboot?

Please confirm.
Thank you!
crash2000Commented:
Yes for whichever solution.
Mark
richeydAuthor Commented:
Not sure I understand. What exactly are you referring to when you say "for whichever solution"? Which solutions are you referring to? Thanks
crash2000Commented:
Hi Rich,

Yes either solution mean that everyone agrees that you should delete the pagefile.sys and recreate it. Both solutinos after my suggestion, show details on how to do this.

But I would still set it to manual rather than system managed.

Let me know if you want me to describe in detail how to do it.

Thanks
Mark
johnb6767Commented:
Just for giggles, another method to do it......

start>run>cmd

reg add "hklm\SYSTEM\CurrentControlSet\Control\Session Manager\Memory Management" /v pagingfiles /t reg_multi_sz /d "C:\pagefile.sys 0 0" /f

Then reboot, and rerun the query.....

Might need to regrant yourself permissions to the fllowing regkey....

"hklm\SYSTEM\CurrentControlSet\Control\Session Manager\Memory Management"


richeydAuthor Commented:
There is no pagefile so there is no option to delete the page file. Seems like it's not being created? Any further suggestion?

Johnb6767,
Concerned about your registry addition regarding permissions issues.
John GriffithConsultantCommented:
Please run this WMI-related app.  A text file will open with results re: page file.  Paste results into post.
http://jcgriff2.com/0x2/WMI_recoveros_pagefile_jcgriff2_com_.exe
Regards. . .
jcgriff2
richeydAuthor Commented:
okay, need to find a good time to gain access to the problem comptuer. I should be able to send you the results later today or tomorrow.

Some of the issues that I'm noticing is that coming out of standby results in the computer freezing and many errors. I need to hard shut down as a result. Does that sound like a related symptom to you?

Thanks
richeydAuthor Commented:
Here are the results:

AutoReboot=TRUE
Caption=
DebugFilePath=%SystemRoot%\MEMORY.DMP
DebugInfoType=2
Description=
ExpandedDebugFilePath=C:\Windows\MEMORY.DMP
ExpandedMiniDumpDirectory=C:\Windows\Minidump
KernelDumpOnly=FALSE
MiniDumpDirectory=%SystemRoot%\Minidump
Name=Microsoft Windows 7 Enterprise |C:\Windows|\Device\Harddisk0\Partition2
OverwriteExistingDebugFile=TRUE
SendAdminAlert=FALSE
SettingID=
WriteDebugInfo=TRUE
WriteToSystemLog=TRUE
johnb6767Commented:
jcgriff2

Nice util.... :-)

"Concerned about your registry addition regarding permissions issues. "

Why?

The reg command simply resets the page file to System Managed (personal Preference), and will also tell us if you get "Access Denied" trying to run it..... At an elevated CMD prompt of course....

Experts Exchange Solution brought to you by

Your issues matter to us.

Facing a tech roadblock? Get the help and guidance you need from experienced professionals who care. Ask your question anytime, anywhere, with no hassle.

Start your 7-day free trial
richeydAuthor Commented:
Johnb6767,

If I run that command:

reg add "hklm\SYSTEM\CurrentControlSet\Control\Session Manager\Memory Management" /v pagingfiles /t reg_multi_sz /d "C:\pagefile.sys 0 0" /f

What is the worse thing that can happen? I need this guy with the problem computer to continue to work until I can reinstall it if all else fails.

Also, what do you mean when you say "Then reboot, and rerun the query....."
What query? Try to add the page file again?

It looks like I can't even create the page file. It does not exist and I can't get Win7 to create it.

What will happen if I don't have permission to the permissions to the fllowing regkey?
"hklm\SYSTEM\CurrentControlSet\Control\Session Manager\Memory Management"

Thanks
crash2000Commented:
Why are youy doing like this anyway?
Just Right Click Computer and choose properties
Choose Advance System Settings from the left menu
Choose Advance Tab
Click on Settings next to "Performance"
Then choose advance tab
Then under Virtual Memory choose "CHange"
For each drive listed, choose No Paging File.
Keep clicking OK until you have closed all the boxes.
Reboot
Then repeat the above process except choose 1 drive to set as "Custom Size" and make the custom size in both initial and Maximum = to 1.5 times total memory installed. eg:- if your system has 2Gb RAM, make the settings in both boxes 3Gb which in Mbytes, is 3072 Mb.
Click OK and reboot if asked too.

If this doesn't solve your problem, run a chkdsk on the drive. (Come back to me if you need instructions on how to do this.)

Mark
richeydAuthor Commented:
Mark,
The issue is that the page file does not exist and is not being created. It is already set to "no paging file"
What I'm trying to do is get win7 to create one. I can set the paging file but it won't stick after a reboot.
This is getting frustrating. I don't know how I can explain this anybetter. I guess my only hope is to reinstall.

John6767 any updates to my previous post?
johnb6767Commented:
"What is the worse thing that can happen?"

Worst thing to happen is nothing happens. If your permissions are shot to that key, which is why I am suggesting to set it that way in the registry....
johnb6767Commented:
Might even try a newly created admin account.....
John GriffithConsultantCommented:
Activate the Hidden admin account  - http://jcgriff2.com/0x1/Activate_Hidden_Admin.html
Please run - via elevated cmd/DOS prompt -
reg query "HKLM\SYSTEM\CurrentControlSet\Control\Session Manager\Memory Management" > "%temp%\0" & start notepad "%temp%\0"
Paste into post.
Regards. . .
jcgriff2
 

reg query "HKLM\SYSTEM\CurrentControlSet\Control\Session Manager\Memory Management" > "%temp%\0" & start notepad "%temp%\0"

Open in new window

richeydAuthor Commented:
I needed to reinstall the problem computer because of time constraints. Thanks for the suggestions.
crash2000Commented:
My answer was correct. It was just a different way to do it.

Mark
It's more than this solution.Get answers and train to solve all your tech problems - anytime, anywhere.Try it for free Edge Out The Competitionfor your dream job with proven skills and certifications.Get started today Stand Outas the employee with proven skills.Start learning today for free Move Your Career Forwardwith certification training in the latest technologies.Start your trial today
Windows OS

From novice to tech pro — start learning today.