SharePoint 2010 Search does not work

Hello,

I am trying to get into SharePoint Server 2010 and I have a problem with the Search Service which I am not able to figure out. I am running Sharepont Server 2010 Std and SQL Server 2008 x64 on two Windows Server 2008 machines. I created a Web Application called 'Intranet' with a site collection which is the root and a site collection for the Search Center site. On the web application I configured an alternative mapping for intranet.domain.com. I also use SSL. so in order to get to the Intranet Site Collection you have to use https://intranet.domain.com

I also setup the Search Service and it is successfully crawling the URL https://intranet.domain.com. When I now access the search center page and search for the term 'cisco' - the it finds results. If I use the "search" on the main page then I only see this:

"We did not find any results for cisco."

That does not make any sense to me at all.

Can someone please help me and tell me what I am doing wrong because oviously the crawling process works fine.

Thank you
Mc2102

Mc2102Asked:
Who is Participating?
I wear a lot of hats...

"The solutions and answers provided on Experts Exchange have been extremely helpful to me over the last few years. I wear a lot of hats - Developer, Database Administrator, Help Desk, etc., so I know a lot of things but not a lot about one thing. Experts Exchange gives me answers from people who do know a lot about one thing, in a easy to use platform." -Todd S.

Mc2102Author Commented:
The solution is pretty simple. All I had to do to fix this issue is to go to the Central Administration tool --> General Application Settings --> Farm Search Administration --> Search Service Application and then in the left menu click on Index Reset.
After I deleted the Content Index I ran a full crawl again and the issue like disappeared.

I believe that the issue is related to Alternative Access Mappings because in a test envriroment I repoduced the issue by changing the URLs in the Alternative Access Mappings for a Web Application. Again after I reset the index the issue was gone. Not sure why that is but it seemed to work.

Experts Exchange Solution brought to you by

Your issues matter to us.

Facing a tech roadblock? Get the help and guidance you need from experienced professionals who care. Ask your question anytime, anywhere, with no hassle.

Start your 7-day free trial
Mc2102Author Commented:
Resetting the Content Index solved my problem.
It's more than this solution.Get answers and train to solve all your tech problems - anytime, anywhere.Try it for free Edge Out The Competitionfor your dream job with proven skills and certifications.Get started today Stand Outas the employee with proven skills.Start learning today for free Move Your Career Forwardwith certification training in the latest technologies.Start your trial today
Microsoft SharePoint

From novice to tech pro — start learning today.