CEs cannot communicate (MPLS VPN)

orus
orus used Ask the Experts™
on
I setup an MPLS VPN in a lab, with 5 routers (two cEs, two PEs and one P).  

The P and PEs are running OSPF between themselves
The PEs are running iBGP between themselves (AS 209)
The CE are peering eBGP to their respective PE's
Both CEs use the same vrf name (site1), is this ok?

The routes the CEs are advertising, are indeed showing up in the routing table of the other CE. However, none of the routes can be pinged, from CE to CE. What could cause this? As stated, routing tables look good, but nothing pinged. Trace route from the CE hits the respective PE and then nothing.

 na
Comment
Watch Question

Do more with

Expert Office
EXPERT OFFICE® is a registered trademark of EXPERTS EXCHANGE®
WissamSenior Network Engineer

Commented:
you need to check your route targets import/export, do not use same route distinguisher (this should be different), we need to see some configs

Author

Commented:
This is what is on one PE:

ip vrf site1
rd1:1
route-target export 1:1
route-target import 1:1

what should the other PE use for rd and route-target?
WissamSenior Network Engineer
Commented:
second site

ip vrf site1
rd 2:2
route-target export 1:1
route-target import 1:1

i used site1 name based on your requirements
Should you be charging more for IT Services?

Do you wonder if your IT business is truly profitable or if you should raise your prices? Learn how to calculate your overhead burden using our free interactive tool and use it to determine the right price for your IT services. Start calculating Now!

Author

Commented:
Here are some configs copied and pasted from the devices
PE, left in diagram

Sl-mpls-pe(config)# ip cef
Sl-mpls-pe (config)#mpls label protocol ldp
Sl-mpls-pe (config)# ip vrf site1
Sl-mpls-pe (config-vrf)#rd 1:1
Sl-mpls-pe (config-vrf)#route-target export 1:1
Sl-mpls-pe (config-vrf)#route-target import 1:1

Sl-mpls-pe (config)#interface Loopback0
Sl-mpls-pe (config)#ip address 20.1.1.1 255.255.255.255

Sl-mpls-pe (config)#interface ethernet0/0 faces customer
Sl-mpls-pe (config)# ip vrf forwarding site1
Sl-mpls-pe (config)#ip address 63.238.101.221 255.255.255.252

Sl-mpls-pe (config)#interface ethernet0/1  faces P
Sl-mpls-pe (config)# mpls ip
Sl-mpls-pe (config)#ip address 68.1.1.2 255.255.255.252

Router ospf 2
Network 20.1.1.1 0.0.0.0 area 0
Network 68.1.1.0 0.0.0.3 area 0

Router bgp 209
No synch
Neighbor  40.1.1.1 remote-as 209
Neighbor 40.1.1.1 update-source loopback0

Address-family vpnv4
Neighbor 40.1.1.1 activate
Neighbor 40.1.1.1 send-community both
Neighbor 40.1.1.1 next-hop-self
Exit-address-family



Address-family ipv4 vrf site1
Redistribute connected
Neighbor 63.238.101.222 remote-as 65100
Neighbor 63.238.101.222 activate
Neighbor 63.238.101.222 as-override
No synch
#############################################
Core router

Mpls-core(config)# ip cef
Mpls-core (config)#mpls label protocol ldp
Mpls-core (config)#interface ethernet0/0
Mpls-core (config)# mpls ip
Mpls-core (config)#ip address 68.1.1.1 255.255.255.252
Mpls-core (config)#interface ethernet0/1
Mpls-core (config)# mpls ip
Mpls-core (config)#ip address 88.1.1.1 255.255.255.252
Mpls-core (config)# router ospf 2
Mpls-core (config-router)# network 68.1.1.0 0.0.0.3 area 0
 Mpls-core (config-router)# network 88.1.1.0 0.0.0.3 area 0
Mpls-core (config-router) #end
##################################################

PE on right



Colo-mpls-pe(config)# ip cef
Colo-mpls-pe (config)#mpls label protocol ldp
Colo-mpls-pe (config)# ip vrf site1
Colo-mpls-pe (config-vrf)#rd 1:1
Colo-mpls-pe (config-vrf)#route-target export 1:1
Colo-mpls-pe (config-vrf)#route-target import 1:1

Colo-mpls-pe (config)#interface Loopback0
Colo-mpls-pe (config)#ip address 40.1.1.1 255.255.255.255

Colo-mpls-pe (config)#interface ethernet0/0 ***connects to customer***
Colo-mpls-pe (config)# ip vrf forwarding site1
Colo-mpls-pe (config)#ip address 65.115.131.181 255.255.255.252

Colo-mpls-pe (config)#interface ethernet0/1 ***connects to P***
Colo-mpls-pe (config)# mpls ip
Colo-mpls-pe (config)#ip address 88.1.1.2 255.255.255.252

Router ospf 2
Network 40.1.1.1 0.0.0.0 area 0
Network 88.1.1.0 0.0.0.3 area 0

Router bgp 209.
No synch
Neighbor  20.1.1.1 remote-as 209
Neighbor 20.1.1.1 update-source loopback0

****sends customer info to other pe***
Address-family vpnv4
Neighbor 20.1.1.1 activate
Neighbor 20.1.1.1 send-community both
Neighbor 20.1.1.1 next-hop-self
Exit-address-family
*****for ebgp to customer***

Address-family ipv4 vrf site1
Redistribute connected
Neighbor 65.115.131.182 remote-as 65102
Neighbor 65.115.131.182 as-override
Neighbor 65.115.131.182 activate

No synch

Open in new window

Author

Commented:
Ok, I made the changes noted and I still cannot ping from CE to CE. Can you please check my config?

Author

Commented:
I am beginning to think this is a labeling issue. I found this and it is the exact issue I'm having
https://learningnetwork.cisco.com/message/77203

Author

Commented:
from PE on left, in diagram
sl-mpls-pe#sh mpls forwarding-table
Local  Outgoing    Prefix            Bytes tag  Outgoing   Next Hop
tag    tag or VC   or Tunnel Id      switched   interface
16     Untagged    88.1.1.0/30       0          Et0/1      68.1.1.1
17     Untagged    40.1.1.1/32       0          Et0/1      68.1.1.1
18     Untagged    10.10.50.0/24[V]  0          Et0/0      63.238.101.222
19     Untagged    10.80.8.0/23[V]   0          Et0/0      63.238.101.222
20     Aggregate   63.238.101.220/30[V]   \
                                     0
21     Untagged    172.16.1.0/24[V]  0          Et0/0      63.238.101.222
22     Untagged    172.16.2.0/24[V]  0          Et0/0      63.238.101.222
23     Untagged    172.16.3.0/24[V]  0          Et0/0      63.238.101.222
24     Untagged    172.16.10.0/24[V] 0          Et0/0      63.238.101.222
25     Untagged    172.16.11.0/24[V] 0          Et0/0      63.238.101.222
26     Untagged    172.16.12.0/24[V] 0          Et0/0      63.238.101.222
27     Untagged    172.16.13.0/24[V] 0          Et0/0      63.238.101.222
28     Untagged    172.16.14.0/24[V] 0          Et0/0      63.238.101.222
29     Untagged    172.16.15.0/24[V] 0          Et0/0      63.238.101.222
30     Untagged    172.16.16.0/24[V] 0          Et0/0      63.238.101.222
31     Untagged    172.16.31.0/24[V] 0          Et0/0      63.238.101.222
32     Untagged    172.16.36.0/24[V] 0          Et0/0      63.238.101.222
33     Untagged    172.16.37.0/24[V] 0          Et0/0      63.238.101.222
34     Untagged    172.16.60.0/24[V] 0          Et0/0      63.238.101.222
35     Untagged    172.16.65.0/24[V] 0          Et0/0      63.238.101.222
Local  Outgoing    Prefix            Bytes tag  Outgoing   Next Hop
tag    tag or VC   or Tunnel Id      switched   interface
36     Untagged    172.16.70.0/24[V] 0          Et0/0      63.238.101.222
37     Untagged    172.16.71.0/24[V] 0          Et0/0      63.238.101.222
38     Untagged    172.16.101.0/24[V]   \
                                     0          Et0/0      63.238.101.222
39     Untagged    172.16.200.0/24[V]   \
                                     0          Et0/0      63.238.101.222
40     Untagged    172.16.202.0/24[V]   \
                                     0          Et0/0      63.238.101.222
41     Untagged    172.17.1.1/32[V]  0          Et0/0      63.238.101.222
42     Untagged    172.17.1.31/32[V] 0          Et0/0      63.238.101.222
43     Untagged    172.17.1.101/32[V]   \
                                     0          Et0/0      63.238.101.222
sl-mpls-pe#

Open in new window

Commented:
Can you post a "sh ip route" from each CE for the interface on the opposite CE? Also a "show ip bgp neighbor" from each?

Author

Commented:
sh ip route and sh ip bgp neighbor attached from both ces
coloce.txt
slce.txt

I have not looked at the configs, but, when you try to ping or telnet are you specifying the vrf? If you are testing a L3VPN then teh CEs should use the same VRF name.

ping vrf XYZ 1.1.1.1
telnet 1.1.1.1 /vrf XYZ

harbor235 ;}

Author

Commented:
Harbor
The ces are not running mpls, so the ping vrf wouldnt be necessary.  The issue im having is trying to ping ce to ce

Ce Route tables look great, but pinging does not work


I see now, where and what are you trying to ping? I assume CE to CE but which router is the source and what IP is the destination?

harbor235 ;}

Author

Commented:
I am on the ce on the left in the diagram. (63.238.101.222)

I am trying to ping a loopback on  the other ce (172.16.102.1)

It fails, trace route also fails

The PE I looked at is not advertising any routes to the CE? I did not see the CE config but without the proper advertisements.


I do not see teh 172.16.102.0/? route in your PE route table dump? Did you include that IP in your advertisements?

harbor235 ;}

Author

Commented:
Here is the show ip route from the CE on the left in the diagram

sl-mpls-ce#sh ip route
Codes: C - connected, S - static, R - RIP, M - mobile, B - BGP
       D - EIGRP, EX - EIGRP external, O - OSPF, IA - OSPF inter area
       N1 - OSPF NSSA external type 1, N2 - OSPF NSSA external type 2
       E1 - OSPF external type 1, E2 - OSPF external type 2
       i - IS-IS, su - IS-IS summary, L1 - IS-IS level-1, L2 - IS-IS level-2
       ia - IS-IS inter area, * - candidate default, U - per-user static route
       o - ODR, P - periodic downloaded static route

Gateway of last resort is 0.0.0.0 to network 0.0.0.0

     65.0.0.0/30 is subnetted, 1 subnets
B       65.115.131.180 [20/0] via 63.238.101.221, 23:58:12
     172.17.0.0/32 is subnetted, 3 subnets
O IA    172.17.1.31 [110/2] via 172.16.1.1, 1d10h, FastEthernet0/1
O IA    172.17.1.1 [110/1] via 172.16.1.1, 1d10h, FastEthernet0/1
O IA    172.17.1.101 [110/21] via 172.16.1.1, 1d10h, FastEthernet0/1
     172.16.0.0/24 is subnetted, 22 subnets
O E1    172.16.200.0 [110/101] via 172.16.1.254, 1d10h, FastEthernet0/1
O E1    172.16.202.0 [110/101] via 172.16.1.215, 1d10h, FastEthernet0/1
O E1    172.16.60.0 [110/101] via 172.16.1.254, 1d10h, FastEthernet0/1
O E1    172.16.36.0 [110/101] via 172.16.1.215, 1d10h, FastEthernet0/1
O E1    172.16.37.0 [110/101] via 172.16.1.254, 1d10h, FastEthernet0/1
O IA    172.16.31.0 [110/12] via 172.16.1.1, 1d10h, FastEthernet0/1
O       172.16.16.0 [110/2] via 172.16.1.1, 1d10h, FastEthernet0/1
O       172.16.12.0 [110/2] via 172.16.1.1, 1d10h, FastEthernet0/1
O       172.16.13.0 [110/2] via 172.16.1.1, 1d10h, FastEthernet0/1
O       172.16.14.0 [110/2] via 172.16.1.1, 1d10h, FastEthernet0/1
O       172.16.15.0 [110/2] via 172.16.1.1, 1d10h, FastEthernet0/1
O       172.16.10.0 [110/2] via 172.16.1.1, 1d10h, FastEthernet0/1
O       172.16.11.0 [110/2] via 172.16.1.1, 1d10h, FastEthernet0/1
C       172.16.1.0 is directly connected, FastEthernet0/1
O       172.16.2.0 [110/2] via 172.16.1.1, 1d10h, FastEthernet0/1
O       172.16.3.0 [110/2] via 172.16.1.1, 1d10h, FastEthernet0/1
B       172.16.100.0 [20/0] via 63.238.101.221, 00:32:00
O IA    172.16.101.0 [110/22] via 172.16.1.1, 1d10h, FastEthernet0/1
B       172.16.102.0 [20/0] via 63.238.101.221, 23:58:14
O E1    172.16.70.0 [110/101] via 172.16.1.215, 1d10h, FastEthernet0/1
O E1    172.16.71.0 [110/101] via 172.16.1.254, 1d10h, FastEthernet0/1
O E1    172.16.65.0 [110/101] via 172.16.1.215, 1d10h, FastEthernet0/1
     10.0.0.0/8 is variably subnetted, 2 subnets, 2 masks
O E1    10.10.50.0/24 [110/101] via 172.16.1.215, 1d10h, FastEthernet0/1
O E1    10.80.8.0/23 [110/101] via 172.16.1.215, 1d10h, FastEthernet0/1
     63.0.0.0/30 is subnetted, 1 subnets
C       63.238.101.220 is directly connected, FastEthernet0/0
S*   0.0.0.0/0 is directly connected, FastEthernet0/0
sl-mpls-ce#

Author

Commented:
show ip route from PE

sl-mpls-pe# sh ip route vrf site1

Routing Table: site1
Codes: C - connected, S - static, R - RIP, M - mobile, B - BGP
       D - EIGRP, EX - EIGRP external, O - OSPF, IA - OSPF inter area
       N1 - OSPF NSSA external type 1, N2 - OSPF NSSA external type 2
       E1 - OSPF external type 1, E2 - OSPF external type 2
       i - IS-IS, su - IS-IS summary, L1 - IS-IS level-1, L2 - IS-IS level-2
       ia - IS-IS inter area, * - candidate default, U - per-user static route
       o - ODR, P - periodic downloaded static route

Gateway of last resort is not set

     65.0.0.0/30 is subnetted, 1 subnets
B       65.115.131.180 [200/0] via 40.1.1.1, 1d00h
     172.17.0.0/32 is subnetted, 3 subnets
B       172.17.1.31 [20/2] via 63.238.101.222, 1d00h
B       172.17.1.1 [20/1] via 63.238.101.222, 1d00h
B       172.17.1.101 [20/21] via 63.238.101.222, 1d00h
     172.16.0.0/24 is subnetted, 22 subnets
B       172.16.200.0 [20/101] via 63.238.101.222, 1d00h
B       172.16.202.0 [20/101] via 63.238.101.222, 1d00h
B       172.16.60.0 [20/101] via 63.238.101.222, 1d00h
B       172.16.36.0 [20/101] via 63.238.101.222, 1d00h
B       172.16.37.0 [20/101] via 63.238.101.222, 1d00h
B       172.16.31.0 [20/12] via 63.238.101.222, 1d00h
B       172.16.16.0 [20/2] via 63.238.101.222, 1d00h
B       172.16.12.0 [20/2] via 63.238.101.222, 1d00h
B       172.16.13.0 [20/2] via 63.238.101.222, 1d00h
B       172.16.14.0 [20/2] via 63.238.101.222, 1d00h
B       172.16.15.0 [20/2] via 63.238.101.222, 1d00h
B       172.16.10.0 [20/2] via 63.238.101.222, 1d00h
B       172.16.11.0 [20/2] via 63.238.101.222, 1d00h
B       172.16.1.0 [20/0] via 63.238.101.222, 1d00h
B       172.16.2.0 [20/2] via 63.238.101.222, 1d00h
B       172.16.3.0 [20/2] via 63.238.101.222, 1d00h
B       172.16.100.0 [200/0] via 40.1.1.1, 00:34:23
B       172.16.101.0 [20/22] via 63.238.101.222, 1d00h
B       172.16.102.0 [200/0] via 40.1.1.1, 1d00h
B       172.16.70.0 [20/101] via 63.238.101.222, 1d00h
B       172.16.71.0 [20/101] via 63.238.101.222, 1d00h
B       172.16.65.0 [20/101] via 63.238.101.222, 1d00h
     10.0.0.0/8 is variably subnetted, 2 subnets, 2 masks
B       10.10.50.0/24 [20/101] via 63.238.101.222, 1d00h
B       10.80.8.0/23 [20/101] via 63.238.101.222, 1d00h
     63.0.0.0/30 is subnetted, 1 subnets
C       63.238.101.220 is directly connected, Ethernet0/0
sl-mpls-pe#

Author

Commented:
sh run from same PE router
sl-mpls-pe#sh run
Building configuration...

Current configuration : 1456 bytes
!
version 12.4
service timestamps debug datetime msec
service timestamps log datetime msec
no service password-encryption
!
hostname sl-mpls-pe
!
boot-start-marker
boot-end-marker
!
!
no aaa new-model
!
resource policy
!
!
!
ip cef
!
!
ip vrf site1
 rd 1:1
 route-target export 1:1
 route-target import 1:1
!
!
mpls label protocol ldp
!
!
!
!
!
!
!
!
!
!
!
!
!
!
!
!
!
!
!
!
interface Loopback0
 ip address 20.1.1.1 255.255.255.255
!
interface Ethernet0/0
 ip vrf forwarding site1
 ip address 63.238.101.221 255.255.255.252
 half-duplex
!
interface Serial0/0
 no ip address
 shutdown
 no dce-terminal-timing-enable
!
interface Ethernet0/1
 ip address 68.1.1.2 255.255.255.252
 half-duplex
 mpls ip
!
router ospf 2
 log-adjacency-changes
 network 20.1.1.1 0.0.0.0 area 0
 network 68.1.1.0 0.0.0.3 area 0
!
router bgp 209
 no synchronization
 bgp log-neighbor-changes
 neighbor 40.1.1.1 remote-as 209
 neighbor 40.1.1.1 update-source Loopback0
 no auto-summary
 !
 address-family vpnv4
 neighbor 40.1.1.1 activate
 neighbor 40.1.1.1 send-community both
 neighbor 40.1.1.1 next-hop-self
 exit-address-family
 !
 address-family ipv4 vrf site1
 redistribute connected
 neighbor 63.238.101.222 remote-as 65100
 neighbor 63.238.101.222 activate
 neighbor 63.238.101.222 as-override
 no synchronization
 exit-address-family
!
ip http server
no ip http secure-server
!
!
!
!
!
!
control-plane
!
!
!
!
!
!
!
!
!
!
line con 0
line aux 0

Open in new window

Author

Commented:
sh run from core router
Current configuration : 995 bytes
!
version 12.4
service timestamps debug datetime msec
service timestamps log datetime msec
no service password-encryption
!
hostname MPLS-CORE
!
boot-start-marker
boot-end-marker
!
!
no aaa new-model
!
resource policy
!
!
!
ip cef
!
!
!
mpls label protocol ldp
!
!
!
!
!
!
!
!
!
!
!
!
!
!
!
!
!
!
!
!
interface Loopback0
 ip address 30.1.1.1 255.255.255.255
!
interface Ethernet0/0
 description ***connected to SL_PE***
 ip address 68.1.1.1 255.255.255.252
 half-duplex
 mpls ip
!
interface Serial0/0
 description ***Connected to WPB***
 ip address 99.1.1.1 255.255.255.252
 shutdown
 mpls ip
 no dce-terminal-timing-enable
!
interface Ethernet0/1
 description ***Connected to Colo-PE***
 ip address 88.1.1.1 255.255.255.252
 half-duplex
 mpls ip
!
router ospf 2
 log-adjacency-changes
 network 68.1.1.0 0.0.0.3 area 0
 network 88.1.1.0 0.0.0.3 area 0
!
no ip http server
no ip http secure-server
!
!
!
!
!
!
control-plane
!
!
!
!
!
!
!
!
!
!
line con 0

Open in new window

Author

Commented:
sh run from other PE
Current configuration : 1473 bytes
!
version 12.4
service timestamps debug datetime msec
service timestamps log datetime msec
no service password-encryption
!
hostname colo-mpls-pe
!
boot-start-marker
boot-end-marker
!
!
no aaa new-model
!
resource policy
!
!
!
ip cef
!
!
ip vrf site1
 rd 2:2
 route-target export 1:1
 route-target import 1:1
!
!
mpls label protocol ldp
!
!
!
!
!
!
!
!
!
!
!
!
!
!
!
!
!
!
!
!
interface Loopback0
 ip address 40.1.1.1 255.255.255.255
!
interface Ethernet0/0
 ip vrf forwarding site1
 ip address 65.115.131.181 255.255.255.252
 half-duplex
!
interface Serial0/0
 no ip address
 shutdown
 no dce-terminal-timing-enable
 no fair-queue
!
interface Ethernet0/1
 ip address 88.1.1.2 255.255.255.252
 half-duplex
 mpls ip
!
router ospf 2
 log-adjacency-changes
 network 40.1.1.1 0.0.0.0 area 0
 network 88.1.1.0 0.0.0.3 area 0
!
router bgp 209
 no synchronization
 bgp log-neighbor-changes
 neighbor 20.1.1.1 remote-as 209
 neighbor 20.1.1.1 update-source Loopback0
 no auto-summary
 !
 address-family vpnv4
 neighbor 20.1.1.1 activate
 neighbor 20.1.1.1 send-community both
 neighbor 20.1.1.1 next-hop-self
 exit-address-family
 !
 address-family ipv4 vrf site1
 redistribute connected
 neighbor 65.115.131.182 remote-as 65102
 neighbor 65.115.131.182 activate
 neighbor 65.115.131.182 as-override
 no synchronization
 exit-address-family
!
ip http server
no ip http secure-server
!
!
!
!
!
!
control-plane
!
!
!
!
!
!
!

Open in new window

Author

Commented:
show ip route from CE on the right in the diagram

Author

Commented:

colo-ce-mpls#sh ip route
Codes: C - connected, S - static, R - RIP, M - mobile, B - BGP
       D - EIGRP, EX - EIGRP external, O - OSPF, IA - OSPF inter area
       N1 - OSPF NSSA external type 1, N2 - OSPF NSSA external type 2
       E1 - OSPF external type 1, E2 - OSPF external type 2
       i - IS-IS, su - IS-IS summary, L1 - IS-IS level-1, L2 - IS-IS level-2
       ia - IS-IS inter area, * - candidate default, U - per-user static route
       o - ODR, P - periodic downloaded static route

Gateway of last resort is not set

     65.0.0.0/30 is subnetted, 1 subnets
C       65.115.131.180 is directly connected, FastEthernet0/0
     172.17.0.0/32 is subnetted, 3 subnets
B       172.17.1.31 [20/0] via 65.115.131.181, 00:04:12
B       172.17.1.1 [20/0] via 65.115.131.181, 00:04:12
B       172.17.1.101 [20/0] via 65.115.131.181, 00:04:12
     172.16.0.0/24 is subnetted, 22 subnets
B       172.16.200.0 [20/0] via 65.115.131.181, 00:04:12
B       172.16.202.0 [20/0] via 65.115.131.181, 00:04:12
B       172.16.60.0 [20/0] via 65.115.131.181, 00:04:13
B       172.16.36.0 [20/0] via 65.115.131.181, 00:04:13
B       172.16.37.0 [20/0] via 65.115.131.181, 00:04:13
B       172.16.31.0 [20/0] via 65.115.131.181, 00:04:13
B       172.16.16.0 [20/0] via 65.115.131.181, 00:04:13
B       172.16.12.0 [20/0] via 65.115.131.181, 00:04:13
B       172.16.13.0 [20/0] via 65.115.131.181, 00:04:13
B       172.16.14.0 [20/0] via 65.115.131.181, 00:04:13
B       172.16.15.0 [20/0] via 65.115.131.181, 00:04:13
B       172.16.10.0 [20/0] via 65.115.131.181, 00:04:13
B       172.16.11.0 [20/0] via 65.115.131.181, 00:04:13
B       172.16.1.0 [20/0] via 65.115.131.181, 00:04:13
B       172.16.2.0 [20/0] via 65.115.131.181, 00:04:13
B       172.16.3.0 [20/0] via 65.115.131.181, 00:04:13
C       172.16.100.0 is directly connected, FastEthernet0/1
B       172.16.101.0 [20/0] via 65.115.131.181, 00:04:13
C       172.16.102.0 is directly connected, Loopback102
B       172.16.70.0 [20/0] via 65.115.131.181, 00:04:14
B       172.16.71.0 [20/0] via 65.115.131.181, 00:04:14
B       172.16.65.0 [20/0] via 65.115.131.181, 00:04:14
     10.0.0.0/8 is variably subnetted, 2 subnets, 2 masks
B       10.10.50.0/24 [20/0] via 65.115.131.181, 00:04:14
B       10.80.8.0/23 [20/0] via 65.115.131.181, 00:04:14
     63.0.0.0/30 is subnetted, 1 subnets
B       63.238.101.220 [20/0] via 65.115.131.181, 00:04:14
colo-ce-mpls#

Open in new window


Add CE facing interface network into OSPF on both PEs (PE-left 63.238.101.221, same for other). When a labeled packet is received at teh PE P interface (PE side) there is no infrastructure route in place, it exists in the vrf table but the PE does not forward to the proper vrf until it has the proper destination ID'd.

See if that helps, else I will keep looking at it.

harbor235 ;}

Author

Commented:
Hi Harbor,

I added the CE facing interface, into the OSPF process, on both PEs.   Same result. Cannot ping from either CE. Trace route still the same (stops at first PE)


from CE on left:


sl-mpls-ce#ping 172.16.102.1

Type escape sequence to abort.
Sending 5, 100-byte ICMP Echos to 172.16.102.1, timeout is 2 seconds:
.....
Success rate is 0 percent (0/5)
sl-mpls-ce#trace 172.16.102.1

Type escape sequence to abort.
Tracing the route to 172.16.102.1

  1 63.238.101.221 0 msec 0 msec 0 msec
  2  *  *  *
  3  *  *  *
  4  *  *  *
  5  *  *  *
  6  *  *  *
  7  *  *  *
  8  *  *  *

Author

Commented:
found the issue.  The P router did not have its loopback interface in the OSPF process. As soon as I added it, the LDP neighbors came up and everything works. Thanks for everyones assistance!!

Author

Commented:
mod: Please split points between harbor725 and wpharaon:

thanks


hmm, I had not got to the P router yet, just the left PE, little disappointed since looking at the networks in OSPF is something I was definiteley advocating. oh well,

harbor235 ;}

Do more with

Expert Office
Submit tech questions to Ask the Experts™ at any time to receive solutions, advice, and new ideas from leading industry professionals.

Start 7-Day Free Trial