Blackberry Express Device activation

JohnSchneider
JohnSchneider used Ask the Experts™
on
I have installed BESX 5.0.2.29 on SBS2003.
3 Vodafone 9000's on BIS.
For the sake of it I tried the wireless Activation because it was still an option on the frist device.
It worked first time straight through as though it was on BES.

Which of course it is not supposed to be able to - but it did. ( wireless on BIS is not supposed to work ).

2nd device did the same and once again it worked fine. Once again this phone is on BIS.
But .. then I noticed a Java problem on the handset itself which the user had complained about.
I decided it would be best just to wipe and start again. So i did that.

When the device rebooted it got a Service book from Vodafone/Blackberry . But now the option for Enterprise Activation has gone. Which is "allegedly" what it it supposed to be like. So that you are forced to connect it up to a PC and activate that way.

So ok fine.  Only 3 phones so if Blackberry/providers want to be "small minded" about activating handsets then so be it.  Although it is another nail in the coffin for Blackberry amongst small businesses in my opinion.

Here is the real problem... can I get the remaining 2 handsets to activate? no I can't!!
I can associate user  device in the webconsole. It says device is activated. So when I look at users the PIN is linked to user. But there is no wireless communications???
The last time contact made is emtpy so it indicates no communications via wireless.

BESX does not activate via email as far as I can see.  There is no wizard to run on the hadnsets.  The activation from the Webconsole with the device attached is all that should be required as far as I can see.

The fact the one phone - the first one - is working would seem to indicate that the basic setup is working on the BESX.  It is just that the USB activation method is not working???
 
Comment
Watch Question

Do more with

Expert Office
EXPERT OFFICE® is a registered trademark of EXPERTS EXCHANGE®
Networks need to activate a tagging on a service to let it know that it is to carry Blackberry Data.  The Data Service is the part the network wants to lock you into.  So, there is a particular coding, at the network level, that needs to be present on each handset for it to get BB data.

Author

Commented:
Ok but I am doing exactly was I should be which is wiping the handset and creating a new BB user from Active directory. Then assigning the attached device to the user via webconsole.
It then does say it is activated on screen.
A new icon appears on the handset called Dekstop.
But nothing syncs into this  and if you look at the user it does not state any contact has been made.

Are you saying this is a network issue with Vodafone?
The handset can use a mobileemail account so data is working.

What step do I need to take to get this handset to activate fully???
Call you phone company and say, hey, i need to have a blackberry data service added to the existing mobile service.

A lot of terms do change. but this is the thought pattern.  When I sold Blackberry Devices and the BES, you needed to get a SIM card to add voice and data to the device, you then had to pay for the blackberry data service.

Vodaphone will want to be paid to PUSH the information out to your handsets.  Its not just the handset.  Its the voice, the data (internet) and perhaps a need to pay for the blackberry data service/carriage.

Voda will have invested $$$ in network equipment that will take your BB data and send it thru the BB network (Usually all via Canada).  This is what you will be paying for.  The push and the pull.
CompTIA Security+

Learn the essential functions of CompTIA Security+, which establishes the core knowledge required of any cybersecurity role and leads professionals into intermediate-level cybersecurity jobs.

Author

Commented:
BIS is activated as both phones can use mobileemail.vodafone.net accounts.

It is simply the BIs activation that is not completing?

BESX activation methods:
1. Wireless - not an option
2. Desktop software - not in office network
3. HTTPS :// webconsole (besadmin ) adssign device - DONE
4. User version of 3.

Option 3 should just work on its own without any thing else being done?
I going to just press you here, incase it leads to your answer. http://mobileemail.vodafone.net/ is a URL,  This is a WEB data service.  This is not the Blackberry Wireless Data.  Just make sure you are not confusing internet access and blackberry as the same thing.  It might be in your example, but just make sure that just because you can web surf to the address. may not mean the bb data is forthcoming.  

The paring of the devices with the BES and the the interactions of the BES with the BB network are different.

I just take you back to your own words: But there is no wireless communications.  Who provides your wireless communication.?


If you want to take my advice, then consider someone like this in your local country. http://www.velocityhost.com.au/index.php/blackberry.html  Pay someone to host both the BES and the Exchange seats its needs.  This can keep the cost down, you pay for what you use, and avoid the ongoing fees to update.

Getting the BES out of your business will save you.  I was the first person in Australia to sell a BES with a Novell Groupwise mail system, and looked at ways. from the start. to keep small scale deployments of BB affordable and functional.  Their approach is close to what I envisioned.


hi
i have waisted too much time between BIS and BES what you have to do is connect the mobile via wire and than through administrator interface delete all the data on the device and than assign device to the user it will work fine
you do not connect to the pc you must connect this to server usb port

connect device to server load administrator portal from the menu
login to the interface
manage current device
delete all the data
than it will reboot once its rebooted
manage current device
then assign device to the user here you assign to the appropriate user and once its done it will work find
also make sure all the ports required by BES are open if any port is blocked by the firewall you will get problem
please post back your results

Author

Commented:
The admin console will not come up on the server web browser which i suspect is just an Internet Explorer issue. I have the same issue on some other PC's in the office that they will not access the webconsole.

I have tried to resolve that but with not luck - it just wont access the webpage.  if I use fireefox on the server it will access the page but does not run the activex controls which it needs to see the devices.
It does this on all pc's in the office so I am guessing it is just incompatible.

I was not aware that the webconsole" had to be run on the server" to assign a device?
Which ports are needed to complete a successful activation.

Also when I assign the device remotely it does say it has been successful???

can you please allow to run if your admin console is not running than you might have a problem with your configuration tell me what happen when you select the administrator open from blackberry menu what do you get in IE does it say page cant be displayed what error message you are getting
you need to add the page in safe sites from IE and see what happen

Author

Commented:
Internet Explorer cannot display the webpage

Although as I said - Firefox and Google browser will access the page so I think that issue is just Internet Explorer itself not the server install.

Unfortunately Firefox/Google Browsers do not rrun the active x control.  but they give you a login which does work but you dont get to see the device attached.
you need to run through IE i tell you what go onto one of your computer on the LAN and copy the address of BB administrator and paste it in the client computer and than it will run hopefully often server IE is setup with the highest possible security please try to login from one of the client computer within your LAN and tell me how it went

Author

Commented:
I am not within my lan at this time, but conected remotely with port SSL port open so the login works fine and activex content works fine. Port 3443 is forwarded through firewall.

However I was on the office network Friday and it did exactly the same thing - no different.
If there are ports that are required other than 3443 what are they??

This is on Windows 7 IE8

why dont you try to do that straight into the sbs 2003 connect using remote desktop and than open the administrator interface
ssl port is 443 i believe if you log in straight to your sbs 2003 box using remote desktop after connecting through vpn and see what happens

Author

Commented:
Have now tried that - makes no difference.

The Webconsole says the device is enabled and activated for the user.
However it does not have any carrier information etc.

From what I can see everything works except it does not communicate through Vodaphone network.
Basic BIS data is enabled as I can use a Mobileemail account.

I have now spoken to Vodafone about 15 times.  Everytime i speak to them I get a slightly different story.
They confirm it is BIs enabled. Some of them say it wont work without a £16 a month BES plan.
Some say it will. Most of them end up saying they dont really know anything about BESX.

Business customer service say ring tech - tech say ring Business Customer services.
It is a complete joke.

I cannot see any errors in the logs.  There are messages queuing up to deliver to the device ....
I will call them back tomorrow when the monkey enclosure at the zoo is open again ( vodafone ).

One solution I have considered is to switch the plan to BES - wireless activate the device - then ring back back up and say actually can you put it back to BIS ....

The only thing I have realized from ringing Vodafone is they are not happy with people using BIS instead of BES - the loss of revenue seems to be hurting....

they are lying i am telling you i was put in this cirlce for 2 months seriously believe i have been there
my question to you is the following
which admin interface you are trying to login to their are two interfaces
one is desktop the other one is administration condole where you login to your exchange domain can you please tell me where are you logging in

on the note of BIS or BES can you tell me whether you can go online with the device or not
send me email mattibutt @hotmail.com let me sort this out
if i am correct two of your devices work fine its the third one which doesnt work

Author

Commented:
I have logged into both at times.

If i login user admin console I can do all as I have said before.
If I login with user console it says this is the device assigned etc and says there are 41 messages waiting for delivery to device.

All looks to be as I would imagine it should,

Author

Commented:
1 device works 100% - it activated wirelessly even though it was on a BIS plan.
It probably had a old service book in it.

1 did them same but I has to wipe it because of a Java problem with an app on phone.
When wiped it would not activate wireless any more.
Then tried USB activation and does not work as now.

3 rd device never worked wirless and wiped and same situation as second device.
if you only have three devices i suggest you to reinstall the whole BES by removing it completely but this should be your last resort it happened to me when i installed on sbs 2003 once the installation was successful also you have to remember Send As and Receive As permission must be given to the account who will be BES Admin instead of creating new user i have just assigned it to one of my existing user and it worked so i dont think you should have any problem at all uninstalling will take an hour than you need to reboot also install a fresh copy but make sure the accounts have the permission once you install again make sure all the ports open their one port i dont know by heart 3001 or something which is used by blackberry server to provide the functionality also make sure sql server connectivity is correct as well so these are the options you can take its upto you which one you want to persue first

Author

Commented:
OK the phone is not the issue.

I have tested it on another installation done last week on a 2008 server with BESX and it worked  without any problems.

I will do a quick check of permissions but then if that doesnt show anything obvious an uninstall/reinstall.
See what happens then....

I see we are back at the Wireless Operator here.

The Blackberry Data Service, which is a priced overlay on top of a normal carrier data service, is the component that delivers the push aspect of the Blackberry Service.

A device that talks to your BES, or a device that talks to a BIS, both rely on carrier push for delivery.

Unless you know that you are paying for the Blackberry Data on the phones not working, then again, I suggest you talk to them and have the tagging added to the service.

BIS takes the BES out of the office, so the rentals/monthly fees are the carriers revenue.

I doesn't matter where you buy you BB enabled phone, but the carrier will want their subscriptions for BB data before they will push anything out to your device.

Author

Commented:
Update ...

Once I realized that the phone was working on another install of BESX it could only be the install on the original server. Uninstalled again but this time the installer has "issues".

Uninstalled again and this time painstakingly went through and tried to remove any traces of BESX prior to third reinstall. But no luck. Still had other issues - that were not present in the first install.
Encryption problems/ SRP problems. Which was annoying as it would appear my attempt to do a clean re-install is nowhere near as clean as it should be!!!

To get the solution going I have now loaded a spare PC up with Win2k3 Std as a member server and installed BESX on that. Worked first time no problems. Activations through USB work first time without any issues.

The SBS2003 has had numerous bits of software loaded onto it in the past as it is the only server in their office.  The chances of getting it working 100% I think are slim now without risking the server's stability.  I have seen other EE articles about why it started working and then stopped due to updates in SBS2003 server. Tried numerous things to resolve - checked and double checked.

As it happens all this has triggered the debate to replace the ageing SBS2003 server with SBS2008.
So no fix on the original server ... but at least 3 phones are now all working on BESX/BIS.

Author

Commented:
Although original problem not completely resolved a few comments pointed me in the right direction to get a solution.
you could fix sbs 2003 problem is if you are to load everything on the main server this BES is very resource consuming application

Do more with

Expert Office
Submit tech questions to Ask the Experts™ at any time to receive solutions, advice, and new ideas from leading industry professionals.

Start 7-Day Free Trial