Why is my Exchange 2010 Server sending from the wrong IP address?

Pantz
Pantz used Ask the Experts™
on
Hello.

I have an Exchange Server 2010 environment.  

I'd like it to send messages from x.x.x.111 but it's sending from x.x.x.112.

How can I change this?

The outbound emails go through a smart host at MXLogic.

Thanks in advance!
Comment
Watch Question

Do more with

Expert Office
EXPERT OFFICE® is a registered trademark of EXPERTS EXCHANGE®
AkhaterSolutions Architect

Commented:
I am afraid we need more information to help

are x.x.x.111 and x.x.x.112 IP addresses on your exchange servers or your firewall?

Author

Commented:
They are IP addresses on the Exchange Server.
AkhaterSolutions Architect

Commented:
get-sendconnector

and check the name of your send connector

set-sendconnector connectorname -SourceIPAddress x.x.x.111

Should you be charging more for IT Services?

Do you wonder if your IT business is truly profitable or if you should raise your prices? Learn how to calculate your overhead burden using our free interactive tool and use it to determine the right price for your IT services. Start calculating Now!

Author

Commented:
I ran the command.  I restarted the Microsoft Exchange Transport Service.

I sent a new message and looked at the SMTP logging information.  It still shows x.x.x.112.

I found this clip in researching the "set-sendconnector" command at http://technet.microsoft.com/en-us/library/aa998294.aspx

"The SourceIPAddress parameter specifies the local IP address to use as the endpoint for an SMTP connection to a remote messaging server. The default IP address is 0.0.0.0. This value means that the server can use any available local IP address. This parameter is only valid for Send connectors configured on Edge Transport servers."

This is not an Edge Transport server.  It's a Hub Transport server.  I believe the command was ignored.

Any new ideas?
BusbarSolutions Architect

Commented:
are this IP internal or External, if it is external then it is it is controlled by the firewall
AkhaterSolutions Architect

Commented:
yes you are right I overlooked that sorry.

In windows 2003 it was as easy as putting the one you want on top. this behavior was changed in 2008

Author

Commented:
There is no hardware-based firewall/appliance between the Exchange Server and the Internet.  Only the software-based firewall that is included with Windows Server 2008 R2 is deployed.  Maybe a rule in there has set the IP address as x.x.x.112?
AkhaterSolutions Architect

Commented:
again,  if you have more than 1 IP on a nic in windows 2008 there is no way to specify which will be used (at least not yet) in windows 2003 it was always the first one in you NIC settings
BusbarSolutions Architect

Commented:
@Akhater
+1

Author

Commented:
Sorry.  That doesn't make sense.  It's currently using the 3rd physical NIC card.
Solutions Architect
Commented:
sorry but this is the way it is

from http://technet.microsoft.com/en-us/library/bb125239.aspx

"If you configure an Internet-facing Hub Transport server, you can't configure a Send connector to attach a particular IP address to messages that are sent from the Hub Transport server. For example, if more than one IP address is assigned to the Hub Transport server, you can't select which IP address is used by a Send connector to relay e-mail to the Internet. If you use an SMTP relay, such as an Edge Transport server, the IP address of that computer is affixed as the message source."

and as I just said, the concept of a primary IP address does not exist in Windows Vista or in Windows Server 2008

Do more with

Expert Office
Submit tech questions to Ask the Experts™ at any time to receive solutions, advice, and new ideas from leading industry professionals.

Start 7-Day Free Trial