Perl on WAMP SERVER. Not working. what am I dooing wrong?

Hi
I am trying to install Perl on our webserver
We use apache 2.0.53

I have downoladed perl and installed it using this guide:
http://guides.jlbn.net/setcgi/setcgi1.html


I get to the last point and want to test by writing:
http://localhost/cgi-bin/printenv.pl it does not give me the expected test page, but instead it opens a box asking if I want to save or open the file.
If i choose "open" a dos window flashes up for a split secound but I cant see what it says.

Does this mean Per is not working?
Anyone know what the problem is?
Is there another way to test it?

morten444Asked:
Who is Participating?
I wear a lot of hats...

"The solutions and answers provided on Experts Exchange have been extremely helpful to me over the last few years. I wear a lot of hats - Developer, Database Administrator, Help Desk, etc., so I know a lot of things but not a lot about one thing. Experts Exchange gives me answers from people who do know a lot about one thing, in a easy to use platform." -Todd S.

Dave BaldwinFixer of ProblemsCommented:
There are several things you may have to do to get PERL to work.  http://httpd.apache.org/docs/2.0/howto/cgi.html

You definitely have to define the handler.

Experts Exchange Solution brought to you by

Your issues matter to us.

Facing a tech roadblock? Get the help and guidance you need from experienced professionals who care. Ask your question anytime, anywhere, with no hassle.

Start your 7-day free trial
morten444Author Commented:
Hi
As pr point 27 in my instruction, I have added this handeler:
AddHandler cgi-script .cgi .pl

I have also added: #!C:/wamp/apps/Perl/bin/perl.exe to the "printenv.pl

It act in the same way as my previus IIS Server when opening .php files. I then had to add .php extention to ISS and then it worked. Wonder if its the same here with .pl extention. If it is, I have no idea where to amend that.

Any other suggestion?

Dave BaldwinFixer of ProblemsCommented:
"AddHandler cgi-script .cgi .pl" should have added PERL to the programs the server will run.  You do have restart Apache for any new directives to take effect.

I just downloaded and installed Perl from that site and http://localhost/cgi-bin/printenv.pl worked fine.  I did end up using the default C:\Perl as the install directory After trying to get it in the right place in c:\wamp.
Why Diversity in Tech Matters

Kesha Williams, certified professional and software developer, explores the imbalance of diversity in the world of technology -- especially when it comes to hiring women. She showcases ways she's making a difference through the Colors of STEM program.

kaskhedikar_tusharTechnical ManagerCommented:
arober11Commented:
Per the URL in DaveBaldwin post, do you have a "+ExecCGI" in the options directive of either  Directory />  or specific  <Directory /xxx/yyy/zzz/ > blocks?

Again per the man page, this is required in addition to the:

AddHandler cgi-script .cgi .pl
morten444Author Commented:
Hi Arober11 / DaveBaldwin
I have read the link.

<Directory /usr/local/apache2/htdocs/somedir>
Options +ExecCGI
</Directory>

I can see I HAVE to add something like this,but not sure how to customize that path line to my system.
"somedir" referes to what folder?

morten444Author Commented:
Hi Again
I managed to create a scriptalias
http://www.eadvice.dk/cgi-bin/printenv.pl
With the result i get there, i assume everying is working. Is that correct?
Dave BaldwinFixer of ProblemsCommented:
Yes, that's the correct display for 'printenv.pl'.
It's more than this solution.Get answers and train to solve all your tech problems - anytime, anywhere.Try it for free Edge Out The Competitionfor your dream job with proven skills and certifications.Get started today Stand Outas the employee with proven skills.Start learning today for free Move Your Career Forwardwith certification training in the latest technologies.Start your trial today
Scripting Languages

From novice to tech pro — start learning today.