Exchange 2010 Mail Attachment Limit

PlatinumITS
PlatinumITS used Ask the Experts™
on
I have 2 exchange 2010 servers running and I read a bunch of articles on how to extend the mail attachment limit, its at 10meg now, but so far no luck.  Can someone run down the possible places to check to raise this limit?
Frustrated!
Comment
Watch Question

Do more with

Expert Office
EXPERT OFFICE® is a registered trademark of EXPERTS EXCHANGE®

Commented:
Do you have anything in front of your exchange server like antivirus or spam scanner?

Author

Commented:
nada

Commented:
I am not sure what docuement you followed to set the limits but take a look at this one to see if there is anything you missed.


https://exchangepedia.com/2007/09/exchange-server-2007-setting-message-size-limits.html
http://technet.microsoft.com/en-us/library/bb124345%28EXCHG.80%29.aspx
Should you be charging more for IT Services?

Do you wonder if your IT business is truly profitable or if you should raise your prices? Learn how to calculate your overhead burden using our free interactive tool and use it to determine the right price for your IT services. Start calculating Now!

Author

Commented:
Holy crap, ok, give me some time to chew through those and test.

Author

Commented:
#550 5.3.4 ROUTING.SizeLimit; message size exceeds fixed maximum size for route ##

Checked over the first article which was very nice and complete.  Still got this error.  Most of my settings are set at 40 gig and I sent a 12 meg email to the user from the outside.  I checked ADSIEdit as well, two values not set and the other set at 40 gig.  Any other ideas????

Commented:
Ususally with that error you need change the send connector size. Try this

set-sendconnector -maxsendsize ####

Author

Commented:
You mean set-sendconnector -maxMESSAGEsize    not send size, my argument was
set-sendconnector -maxmessagesize unlimited
then it asked for the send connector name which i gave it with NO quotes (asked for IDENTITY), and it took it...test sending now.  why would a send connector reject an incoming message though?

Author

Commented:
failed again.  same error .... do i need to restart any service ?
Commented:
Sorry, I read your post wrong. I though you were sending the mail.

try

set-receiveConnector -Identity NAMEOF CONNECTOR -maxmessagesize ##


Author

Commented:
set-receiveConnector -Identity "Default HCMMail" -maxmessagesize 40mb

#550 5.3.4 ROUTING.SizeLimit; message size exceeds fixed maximum size for route ##

Any other ideas?

Commented:
Can you try to restart the the msexchangetransport service

Author

Commented:
Same error after restarting the service.  

Commented:
Run this command

get-ReceiveConnector | ft Identity, MaxMessageSize

Author

Commented:
The server in question is HCMMail, would the other server HNMail cause this problem.  The MX record points at HCMMail, not HNMail.
vv.JPG

Commented:
I would change them both and test.

Author

Commented:
Changed, and output reflected all are set at 40 meg.  Same error.  gotta love exchange....now what?

Author

Commented:
The problem was a limit on my sending exchange server.  I increased the send size on my send connector and voila.  Sorry about this, I should have played with my sending box earlier.  Thanks for all the help.

Commented:
Glad it is working

Author

Commented:
Figured it out myself...

Do more with

Expert Office
Submit tech questions to Ask the Experts™ at any time to receive solutions, advice, and new ideas from leading industry professionals.

Start 7-Day Free Trial