Remote Desktop issue

zolf
zolf used Ask the Experts™
on

Hello there,

I have win 7 Pro OS on my laptop. when i remote desktop the server 2003.it works very slow. i mean when i click on an icon,it responses very slow. i am on a LAN. before it used to work very smoothly.yesterday i restalled my OS and i have started getting this problem.what coul dbe wrong.please help.

cheers
Zolf
Comment
Watch Question

Do more with

Expert Office
EXPERT OFFICE® is a registered trademark of EXPERTS EXCHANGE®
Do you have any firewall application installed on the laptop? If so try disabling it and try again.

Author

Commented:

>>Do you have any firewall application installed on the laptop? If so try disabling it and try again.
i do not have any firewall application on my machine
Auto-tunning may be causing the problem. Run this command using elevated rights:

netsh interface tcp set global autotuninglevel=highlyrestricted
Why Diversity in Tech Matters

Kesha Williams, certified professional and software developer, explores the imbalance of diversity in the world of technology -- especially when it comes to hiring women. She showcases ways she's making a difference through the Colors of STEM program.

Commented:
If you still have the problem in getting the remote desktop then try installing Teamviewer in both the system while installing choose option as personal use then it is free or you need to get the license version.

After installing get the Session ID: from the remote system and add that in client system give the password which you see there in the remote system and use the same you can use it without any issues because I'm using this for the past 1 and half year till now I don't face any issues in accessing my remote desktop.

Try this and let me know download it from here http://www.teamviewer.com/download/msi.aspx

Author

Commented:

>>Auto-tunning may be causing the problem. Run this command using elevated rights:
what does this do??

Author

Commented:

khbasha:

you see i am using RDP for my Java application. my application runs on Terminal Service

Author

Commented:

gbarrientos:

were do i run this command.i mean in cmd prompt
Iain MacMillanIT Regional Manager - UK
Commented:
yes you run the command from the command prompt - with admin rights.

also see this thread - http://www.experts-exchange.com/OS/Microsoft_Operating_Systems/Windows/Windows_7/Q_26545883.html?cid=1572#a33919457
In the start menu where it says "Search for program and files" type CMD, wait a sec and it will show cmd.exe. Right click on cmd.exe and select Run with admin rights. then enter the command.
You stated that the issue started after you reinstalled the OS. You could be having an intermittent issue with the LAN drivers. Have you tried updating the drivers for your NIC (network interface card) aka LAN card?

You also stated that you have no firewall application installed on the computer. Windows has a built in firewall have you checked to see if it was disabled?
http://windows.microsoft.com/en-US/windows-vista/Turn-Windows-Firewall-on-or-off
could it be the OS is simply downloading updates? if its a fresh install there could be a lot of data to download...

Author

Commented:


some of you'll mentioned about updates and downloads.how do i be sure that this is the reason.
please help.

Author

Commented:

i disabled my win firewall and it connected fast and clicking on icons it would open fast.then i again enabled the firewall expecting to again slow the process BUT it worked as normal.i mean it was fast.what is wrong
Commented:
It seems that windows 7 enables TCP Window Scaling by default (disabled on XP by default).  To disable this *feature* run these from an Administrative Command Prompt:

netsh interface tcp set global rss=disabled
netsh interface tcp set global autotuninglevel=disabled
Perhaps the firewall was attempting to block a protocol and when you turned it off and back on again it quit. i am not a big fan of the windows built in firewall and tend to quickly replace it with 3rd party software.
Did you try this command?


netsh interface tcp set global autotuninglevel=highlyrestricted

Author

Commented:
cheers

Do more with

Expert Office
Submit tech questions to Ask the Experts™ at any time to receive solutions, advice, and new ideas from leading industry professionals.

Start 7-Day Free Trial