Configure a Cisco 3650g to use a DHCP Server?

Locoo6
Locoo6 used Ask the Experts™
on
I have a ghostcast server setup to use DHCP.

If I have a dumb switch connected to it and connect computers to the dumb switch it will assign ips to all the computers.

My problem is i started using the cisco switch and it will only assign to one computer and the other one will time out.

What are the exact configuration i should put into my cisco switch?



COMPUTER  -> CISCO SWITCH - >  computers
push out an image to all computers using ghostcast
Comment
Watch Question

Do more with

Expert Office
EXPERT OFFICE® is a registered trademark of EXPERTS EXCHANGE®
Could you post the configuration of the switch perhaps that could help narrow down any issues that may be switch related.
Top Expert 2014

Commented:
Do you want the 3650

    1) to be a DHCP server

     2) get it's address from a DHCP server

     3) Relay DHCP requests from the PC's to a DHCP server


Fundamentals of JavaScript

Learn the fundamentals of the popular programming language JavaScript so that you can explore the realm of web development.

Author

Commented:
relay DHCP requests from the PC's to a DHCP server.
Top Expert 2014

Commented:
O.K.  Then on the VLAN interface definition for the VLAN   that the PC reside on you want to code:

     ip helper-address a.b.c.d

where a.b.c.d is the IP address of your DHCP server.

Author

Commented:
What i have setup is a tftp/dhcp server on the computer and the ghostcast server.

When all the computers try to access the ghost server they dont find it and i have to restart it.  i have to do it one by one..

i put ip helper-address into VLAN1 INTERFACE

and doesnt look like it did nothing

what should i put as the router on my dhcp server?
Do i need to put any more configs into my switch? to make it more reliable?

thanks.
Top Expert 2014

Commented:
Are these computers on VLAN1?

What VLAN is your DHCP server on?

Author

Commented:
VLAN1 THE DHCP SERVER AND THE COMPUTER.

the dhcp server need to be connected to the switch with a crossover right?



Also the DHCP takes about a minute to give IPs to the computers. is there a way to expediate the process?

Is there a way for the computers to automatically boot into the ghostcast session without me having to click ok and then ghostcast -> multicast?????
computer/server ----> switch  =  straight through cable.
Top Expert 2014

Commented:
If both are on VLAN1 then you do not need the ip helper-address.  That is only needed when the DHCP client is on a different VLAN from the DHCP server.

All computers should use straight through cables when connected to a switch.

Author

Commented:
its takes forever for the computer to register???

the light is yellow for like a minute

and if you go and choose ghostcast adn multicast to fast it says it ccant connect if to slow it timeout and it still cant connect.

assigin the dhcp addres takes forever to.

on the tftp32 do i put the swich as the router address?  do i give the switch an ip? how do i do dat if i should?

Thanks.
No need for helper-address in your case here.
I could only think of local proxy
Could you please do this:

"interface range fa1/0/1 - fa1/0/48 (or whatever the ports are named, include all ports from 1 to 48)
no ip local-proxy-arp
switchport mode access
switchport access vlan 1
interface vlan 1
no ip local-proxy-arp"
Top Expert 2014
Commented:
Ah, yellow light for 30 seconds.

In addition to the config commands that pgstephan provide you need to use:

     spanning-tree portfast

and it probably won't hurt to also use:

     spanning-tree bpduguard enable

The 30 seconds is the switch port going through the spanning tree process.  With portfast and bdpduguard you should be O.K.

If it's a single switch, I would advise to shut down the spanning-tree completely (Syntax# no spanning-tree vlan 1).

If the problem still persists, here you go an easy way to troubleshoot it further via SPAN (Switch Port Analyzer), which is one of the built-in functions in the 3560.

Hook yourself to port X in the switch, and install wireshark on your laptop.
Then:
monitor session 1 source port interface Y both (where Y is the DHCP server port)
monitor session 1 destination interface X (where X is the port where your laptop is connected)

If you are still facing the same problem, please post back the output of wireshark after turning on the second host on the switch.
HTH.
Locoo6,
  In your previouse comment you stated that

"the dhcp server need to be connected to the switch with a crossover right?"

are you suing a crossover cable or a straight through cable? Some switches will auto negotiate this, but I think you may be using the wrong cable.

Author

Commented:
i am using a straight through cable.

I will try out the commands as soon as I get a chance and get back with you [pgstephen] thanks alot
Honestly speaking, I don't expect this problem to be caused by cabling.. Most of nowadays ports handle the pin assignement automatically

Author

Commented:
"interface range fa1/0/1 - fa1/0/48 (or whatever the ports are named, include all ports from 1 to 48)
no ip local-proxy-arp
switchport mode access
switchport access vlan 1
interface vlan 1
no ip local-proxy-arp"
spanning-tree portfast
spanning-tree bpduguard enable

Do more with

Expert Office
Submit tech questions to Ask the Experts™ at any time to receive solutions, advice, and new ideas from leading industry professionals.

Start 7-Day Free Trial