Exchange 2010 - allow authenticated users to send as they want

sibliege
sibliege used Ask the Experts™
on
Hello Experts,

I have an exchange 2010 server running for the company very well.
Some of my users have also a "private home" account configured as POP3 in Outlook.
These account are external from the company, I mean the company is domain.com and the home account is theirisp.com
I would like to be able to allow them to send email with their home account using the smtp connector from exchange.
I have naturally setup the POP/SMTP account to use exchange host and use the port 587 using SSL. Anyway when I send a mail from the home account, exchange give me this error:
5.7.1 Client does not have permissions to send as this sender
I have googled and not find anything to setup the receive connector to allow that.

Does anyone know how to do?

Thanks
Comment
Watch Question

Do more with

Expert Office
EXPERT OFFICE® is a registered trademark of EXPERTS EXCHANGE®
AkhaterSolutions Architect

Commented:
in outlook have you check the "my outgoing server requires authentication" ?

on the client receive connector authentication tab did you UNCHECK the "offer basic authentication only after starting TLS"?

Author

Commented:
Yes, both settings are as you say...

Author

Commented:
It really seems that exchange don't like my "from address" since it is ouside the accepted domain...
Exploring ASP.NET Core: Fundamentals

Learn to build web apps and services, IoT apps, and mobile backends by covering the fundamentals of ASP.NET Core and  exploring the core foundations for app libraries.

AkhaterSolutions Architect

Commented:
you are sure that "offer basic authentication only after starting TLS" is UNCHECKED?

also in the pop3 did you enable plain text logon ?

are they able to retreive their emails ?
AkhaterSolutions Architect

Commented:
ah well it change it all, the from address should be the same as the primary address of the user in ActiveDirectory
AkhaterSolutions Architect
Commented:
if you want to change this run the following command, restart the transport service and try

Get-ReceiveConnector “Receive Connector Name” | Add-ADPermission -User “NT AUTHORITY\Authenticated Users” -ExtendedRights “Ms-Exch-SMTP-Accept-Any-Sender”

Author

Commented:
@Akhater

It say that it doesn't found the group "NT AUTHORITY\Authenticated Users"
Commented:
MMMhhhhh sorry, french exchange => "AUTORITE NT\Utilisateurs authentifiés"

Author

Commented:
@Akhater

It works thanks!
AkhaterSolutions Architect

Commented:
ah bon.... je me mords les doigts chaque fois que j'ai un implementation a faire en France :) J'ai toujours du mal avec c'est changement

Author

Commented:
Bien le merci mon cher :)

Do more with

Expert Office
Submit tech questions to Ask the Experts™ at any time to receive solutions, advice, and new ideas from leading industry professionals.

Start 7-Day Free Trial