Cant ping boxes on either side of ASA

I am unable to ping a PC on the .104 network from the .105 network and vice versa. I can ping them from withing the ASA. Can someone take a glance at this configuration and see if there is sometime missing by any chance? Thank you

: Saved
:
ASA Version 8.2(1)
!
hostname ciscoasa
enable password 8Ry2YjIyt7RRXU24 encrypted
passwd 2KFQnbNIdI.2KYOU encrypted
names
!
interface Vlan100
 nameif outside
 security-level 0
 ip address 192.168.104.1 255.255.255.0
!
interface Vlan200
 nameif inside
 security-level 0
 ip address 192.168.105.1 255.255.255.0
!
interface Ethernet0/0
 switchport access vlan 100
!
interface Ethernet0/1
 shutdown
!
interface Ethernet0/2
 shutdown
!
interface Ethernet0/3
 shutdown
!
interface Ethernet0/4
 switchport access vlan 200
!
interface Ethernet0/5
 shutdown
!
interface Ethernet0/6
 shutdown
!
interface Ethernet0/7
 shutdown
!
ftp mode passive
access-list 101 extended permit icmp any any echo-reply log debugging
access-list 101 extended permit icmp any any source-quench log debugging
access-list 101 extended permit icmp any any unreachable log debugging
access-list 101 extended permit tcp any any log debugging
access-list 101 extended permit icmp any any time-exceeded log debugging
access-list 102 extended permit icmp any any source-quench log debugging
access-list 102 extended permit icmp any any unreachable log debugging
access-list 102 extended permit icmp any any echo-reply log debugging
access-list 102 extended permit icmp any any time-exceeded log debugging
access-list 102 extended permit tcp any any log debugging
pager lines 24
logging enable
logging asdm informational
mtu outside 1500
mtu inside 1500
no failover
icmp unreachable rate-limit 1 burst-size 1
asdm image disk0:/asdm-625.bin
no asdm history enable
arp timeout 14400
access-group 102 in interface outside
access-group 101 out interface outside
access-group 102 in interface inside
!
router rip
 network 192.168.104.0
 network 192.168.105.0
!
route inside 0.0.0.0 0.0.0.0 192.168.104.1 1
timeout xlate 3:00:00
timeout conn 1:00:00 half-closed 0:10:00 udp 0:02:00 icmp 0:00:02
timeout sunrpc 0:10:00 h323 0:05:00 h225 1:00:00 mgcp 0:05:00 mgcp-pat 0:05:00
timeout sip 0:30:00 sip_media 0:02:00 sip-invite 0:03:00 sip-disconnect 0:02:00
timeout sip-provisional-media 0:02:00 uauth 0:05:00 absolute
timeout tcp-proxy-reassembly 0:01:00
dynamic-access-policy-record DfltAccessPolicy
http server enable
http 192.168.105.0 255.255.255.0 inside
no snmp-server location
no snmp-server contact
snmp-server enable traps snmp authentication linkup linkdown coldstart
crypto ipsec security-association lifetime seconds 28800
crypto ipsec security-association lifetime kilobytes 4608000
telnet timeout 5
ssh timeout 5
console timeout 0

threat-detection basic-threat
threat-detection statistics access-list
no threat-detection statistics tcp-intercept
webvpn
!
!
prompt hostname context
Cryptochecksum:1d3a6d212d0c981a5cd58d9753710381
: end
asdm image disk0:/asdm-625.bin
no asdm history enable

LVL 1
progjmAsked:
Who is Participating?
I wear a lot of hats...

"The solutions and answers provided on Experts Exchange have been extremely helpful to me over the last few years. I wear a lot of hats - Developer, Database Administrator, Help Desk, etc., so I know a lot of things but not a lot about one thing. Experts Exchange gives me answers from people who do know a lot about one thing, in a easy to use platform." -Todd S.

usslindstromCommented:
Dunno on that ASA - but could it be that you don't have

"ip routing"

configured there?

I see you're running a routing protocol - but didn't see that line.  Not sure though - don't have an ASA.
progjmAuthor Commented:
I believe this command takes care of that if it was needed
router rip
 network 192.168.104.0
 network 192.168.105.0
usslindstromCommented:
Yeah - not sure with ASA - but don't see why it'd be any different than any other Cisco device.

IP Routing is enabled on routers by default.

On switches it must be enabled.  Not sure about the ASA.

But here's a link.  Check out 3.3 from what the gentleman is saying...

http://www.joshgentry.com/cisco/cisco.htm
CompTIA Cloud+

The CompTIA Cloud+ Basic training course will teach you about cloud concepts and models, data storage, networking, and network infrastructure.

progjmAuthor Commented:
I have a static route setup to outside
route outside 0.0.0.0 0.0.0.0 192.168.104.1 (it did say inside and I fixed that) Still cant pint the box at 192.168.104.33 from 192.168.105.33.
progjmAuthor Commented:
Both boxes are connect to the ASA BTW, no other devices in between
AngloCommented:
You have all the replies in the access list but not the initial echo
Cheever000Commented:
In this case there shouldn't be any need for routing excluding the default gateway.  Both networks are considered connected, and it will not require a routing protocol to reach either network.  This may have more to do with the NAT rules ASAs follow then routing.  If you can launch the ASDM try using the packet tracer tool that is built in to see if it can shed some light on what is happening with the packets.  It may required a no nat rule or some type of identity NAT.
progjmAuthor Commented:
Added this to above, still cant ping. When I attempt a tracert from one of the XP machine to the other I cant even hit the first hop. I can successfully run a tracert from the XP machine to its Gateway

access-list 101 extended permit icmp any any echo
access-list 102 extended permit icmp any any echo
access-list inside_nat0_outbound extended permit ip any any
access-list inside_nat0_outbound_1 extended permit ip any any
access-list outside_nat0_outbound extended permit ip any any
access-list outside_nat0_outbound_1 extended permit ip any any
nat (outside) 0 access-list outside_nat0_outbound
nat (outside) 0 access-list outside_nat0_outbound_1 outside
nat (inside) 0 access-list inside_nat0_outbound
nat (inside) 0 access-list inside_nat0_outbound_1 outside
access-group 102 in interface outside
access-group 101 out interface outside
access-group 102 in interface inside
access-group 102 out interface inside
AngloCommented:
Yes agree - the packet tracer is very useful.  This will tell you in what area it fails.  Probably also need to add NAT exempt rules to route across between the 2 subnets.  The tool will also highlight any access rules you have missed (like the echo).
shubhanshu_jaiswalCommented:
Just add the below mentioned command:

same-security-traffic permit intra-interface

I hope your issue will be solved...
Cheever000Commented:
I just noticed something I believe is important, you have the interfaces at the same security level, by default ASAs don't let traffic through same security level interfaces.

check out the very last section of this article, you are looking for the same-security-traffic permit inter-interface command and explanation.

http://www.cisco.com/en/US/products/ps6120/products_configuration_example09186a00807fc191.shtml

Experts Exchange Solution brought to you by

Your issues matter to us.

Facing a tech roadblock? Get the help and guidance you need from experienced professionals who care. Ask your question anytime, anywhere, with no hassle.

Start your 7-day free trial
progjmAuthor Commented:
It was the issue shubhanshu_jaiswal and Cheever000. I wasnt allowing the same-security-traffic permit inter-interface command
progjmAuthor Commented:
Thanks for the help guys, really appreciate it
It's more than this solution.Get answers and train to solve all your tech problems - anytime, anywhere.Try it for free Edge Out The Competitionfor your dream job with proven skills and certifications.Get started today Stand Outas the employee with proven skills.Start learning today for free Move Your Career Forwardwith certification training in the latest technologies.Start your trial today
Software Firewalls

From novice to tech pro — start learning today.