Why is the global address list missing users names?

Over the weekend, I installed (with the help of Dell) Exchange 2010 and Windows Server 2008-R2 and Outlook 2010 (on all client computers).

In Outlook 2010, when I log on and want to create a mail message and click the "to:" button, I only see 5 users.  

When another user tries to do the same thing, they see all users in the global address list.

The global address list seems to be the problem.  I don't know how to correct it.

Note:  When I started adding the first 5 mailboxes, I did not state the scope.  I did state the scope for the remaning 15 users.  Its the first 5 users who are having the problem.

Thanks for your help.
WeThePeopleAsked:
Who is Participating?
I wear a lot of hats...

"The solutions and answers provided on Experts Exchange have been extremely helpful to me over the last few years. I wear a lot of hats - Developer, Database Administrator, Help Desk, etc., so I know a lot of things but not a lot about one thing. Experts Exchange gives me answers from people who do know a lot about one thing, in a easy to use platform." -Todd S.

JdtuckCommented:
The computer that can't see all the account names, is it using cached exchange mode?  Have you tried downloading the full GAL?
WeThePeopleAuthor Commented:
You are correct.  I unchecked the box "cache mode" and now I am able to see all the other users.  I thought I would have to delete the 5 mailbox accounts and recreate them.

I thought the problem was, when I set up the first 5 users, I did not check the box "Specify the organizational usit rather than the default one".  so the first 5 when into the default one.  I moved them to the right organizational unit.  Users 6 thru 20 did have that box checked.

Do I have to do anything else, other than unchecking cache mode.
JdtuckCommented:
1.  Go to Send / Receive - Send/receive Groups - Download Address Book.
 2. In the new window, click on OK.
 3. When the Outlook Send/Receive Progress window disappears, the address book will be done downloading.
JuusoConnectaCommented:
1. Make your MailboxDatabase is set to use your active OAB (EMC -> Organization Configuration -> Mailbox -> Your MailBoxDatabase -> Properties -> set OAB

2.Check that your OAB has the following properties:
- General = Update schedule is set to run daily at 5:00 A.M
-Address Lists = Include the default Global Address List, Include the following address lists:
All Contacts
All Groups
All Rooms
All Users
Public Folders
-Distribution = Distribution Points: Enable web-based distribution (marked)
OAB (Default Web Site) needs to be added and Enable public folder distribution should be marked  

3. Go to exchange management Shell and type in the following:
Update-GlobalAddressList "Default Global Address List"
And then
update-offlineaddresslist "name of your offline address list"

Give it 30 - 60 mins and see if you see a difference

cheers

Experts Exchange Solution brought to you by

Your issues matter to us.

Facing a tech roadblock? Get the help and guidance you need from experienced professionals who care. Ask your question anytime, anywhere, with no hassle.

Start your 7-day free trial
It's more than this solution.Get answers and train to solve all your tech problems - anytime, anywhere.Try it for free Edge Out The Competitionfor your dream job with proven skills and certifications.Get started today Stand Outas the employee with proven skills.Start learning today for free Move Your Career Forwardwith certification training in the latest technologies.Start your trial today
Exchange

From novice to tech pro — start learning today.