I am getting error ASMCMD-08103 failed to connect to ASM. How do I rectify this error?

ramadassh
ramadassh used Ask the Experts™
on
I am unable to connect to ASMCMD in Oracle Database 11g. I am using linux as the Operating system. I have set the ORACLE_SID to +ASM and ORACLE_HOME base to /u01/app/oracle.

When I enter asmcmd, I get an error ASMCMD-08103 failed to connect to ASM.

Please help me resolve this issue. Thanks
Comment
Watch Question

Do more with

Expert Office
EXPERT OFFICE® is a registered trademark of EXPERTS EXCHANGE®
Hi
You will have to start ASM first.
The problem can be  been solved by setting the ORACLE_HOME variable to Oracle DB Home
instead of ASM Home and ORACLE_SID to ASM SID as below:

$export ORACLE_HOME=/u01/app/oracle/db11g
$export ORACLE_SID=+ASM1
$asmcmd
ASMCMD>
Richard OlutolaConsultant

Commented:
Do you still require help with this question?
Please honor helpers with a feedback.

R.

Author

Commented:
I could resolve the issue.

Do more with

Expert Office
Submit tech questions to Ask the Experts™ at any time to receive solutions, advice, and new ideas from leading industry professionals.

Start 7-Day Free Trial