MaxOutboundConnectionsPerEndpoint quota (10) has been reached, so the connection was closed and not reused by the listener

Hi all!

We have strange issue with WCF services hosted on IIS7.
Services are using net.tcp bindings, with port sharing enabled.
There are 8 different services in total, and some of them have large number of calls simultaneously and some have long running queries that return large number of rows (1+ length, which I cant reduce in any way, due to business requirements).

After period of time when services were working perfectly fine, some strange things started to happen, such as getting error - MaxOutboundConnectionsPerEndpoint quota (10) limit reached. Although I have set this value(s) to 50 in web config file, we still get the same error.
Occasionally we have serious slowdowns on service response, although server is not under stress at all, and somehow those match in times with occurrence of the error.

Please do you have any ideas or recommendations (what or at least, where to look).

Thank you in advance!
'Config code

 <net.tcp listenBacklog="100"
          maxPendingAccepts="100"
          maxPendingConnections="1000"
          receiveTimeout="00:00:10"
          teredoEnabled="false"
          maxOutboundConnectionsPerEndpoint="50"
          maxConnections ="250">
    </net.tcp>

Open in new window

LVL 1
kahvedzicAsked:
Who is Participating?
I wear a lot of hats...

"The solutions and answers provided on Experts Exchange have been extremely helpful to me over the last few years. I wear a lot of hats - Developer, Database Administrator, Help Desk, etc., so I know a lot of things but not a lot about one thing. Experts Exchange gives me answers from people who do know a lot about one thing, in a easy to use platform." -Todd S.

grayeCommented:
I presume this is running on a true "server" version of WIndows... and not on a workstation version of Windows?   Recall that workstation versions have a upper limit on the number in inbound connections.
kahvedzicAuthor Commented:
@Graye
Yes, services are running on Windows Server 2008 R2, IIS7.

kahvedzicAuthor Commented:
It seems that I have managed to solve problem by increasing maxConnections value. I have set it to 100, and everything works fine.

Note that this property needs to be set on specific net.tcp binding if there is one, not on the global net.tcp settings, as specific binding settings seem to override it, and use default in it, if it is not set by user.

Experts Exchange Solution brought to you by

Your issues matter to us.

Facing a tech roadblock? Get the help and guidance you need from experienced professionals who care. Ask your question anytime, anywhere, with no hassle.

Start your 7-day free trial
kahvedzicAuthor Commented:
I have changed properties, tested it on our system and it works perfectly fine right now.
It's more than this solution.Get answers and train to solve all your tech problems - anytime, anywhere.Try it for free Edge Out The Competitionfor your dream job with proven skills and certifications.Get started today Stand Outas the employee with proven skills.Start learning today for free Move Your Career Forwardwith certification training in the latest technologies.Start your trial today
.NET Programming

From novice to tech pro — start learning today.