Remote Desktop Connect no longer works

sfsdtc
sfsdtc used Ask the Experts™
on
I have four Windows Server 2008 64-bit servers that I use as virtual hosts (via Hyper-V).  Over the weekend I did MS Update to apply latests updates and restarted them.  Now, for some reason, I can no longer access two of the servers via Remote Desktop Connection.

I used RDC from my Windows 7 laptop and from another Windows Server 2008 64-bit server to access these other two servers before I updated and restarted them so it did work previously.  I verified that Remote access is enabled on the two servers and that the correct username / group is specified to access those servers.

When I try to access I get: "Remote Desktop cannot connect to the remote computer for one of these reasons 1) Remote access to the server is not enabled, 2) The remote computer is turned off, 3) The remote computer is not available on the network".  Note that I get this message before being prompted for username and password.

One of the servers I can ping via both its DNS name and its IP address.  The other server I can't ping with its DNS name or IP Address (get "request timed out").  However, all virtual machines on those servers are working and accessible.

I'm using the /admin switch on the mstsc program though I've tried without it but no luck.

Thoughts?
Comment
Watch Question

Do more with

Expert Office
EXPERT OFFICE® is a registered trademark of EXPERTS EXCHANGE®
Commented:
Did you check to make sure that the Terminal Services service is starting/running?

Commented:
Disable and enable terminal services in your advanced computer properties. Might be a problem with the firewall so doing this will make sure the firewall rule enabling RDP is activated.

Author

Commented:
Where is "advanced computer properties"?
OWASP Proactive Controls

Learn the most important control and control categories that every architect and developer should include in their projects.

Author

Commented:
Yes, I did verify Terminal Services is running on those servers.

Author

Commented:
FYI - I fixed the issue with not being able to ping the one server.  It appears that Network and File sharing was turned off on it.  Once I enabled that, I can now ping it, use the net view command, etc.  However, still cannot access via RDC.
Commented:
Right click on "My Computer" and choose "properties". You get a new window where you can choose "advanced system properties". Under the tab "remote" you'll see the remote desktop settings and you'll will have the option to enable / disable remote desktop. Disable it, click ok until all forms are closed and repeat to enable.

Author

Commented:
Well folks, for some reason it decided to start working today.  Maybe after restarting the servers there was something that took a while to start, who knows.  At any rate it's now working.  I'll leave this open for one day in case someone wishes to add something.  Thanks for the help/suggestions.

Do more with

Expert Office
Submit tech questions to Ask the Experts™ at any time to receive solutions, advice, and new ideas from leading industry professionals.

Start 7-Day Free Trial