Error 8202 when upgrading from Exchange 2007 SP2 to SP3

FreeRangers
FreeRangers used Ask the Experts™
on
I am trying to upgrade Exchange 2007 to service pack 3. I get to organization preparation and I get the following error:

An error occurred when executing 'ldifde.exe' to import schema file 'C:\Temp\Microsoft\Exchange2007SP3\Setup\ServerRoles\Common\Setup\Data\PostExchange2003_schema3.ldf'. Error code: 8202. More details can be found in the error file 'C:\Documents and Settings\Administrator.MPE\Local Settings\Temp\1\ldif.err'.

I looked up error code 8202 and found the following Microsoft KB article:

http://support.microsoft.com/kb/948214

However, I go into adsiedit.msc and click on the schema partition but there is no CN=ms-Exch-Resource-Schema, CN=Schema, CN=Configuration, DC=Domain, DC=COM under the schema partition, or no mayContain attribute. The only thing under the schema partition is CN=Schema,CN=Configuration,DC=domain name,DC=ca and still no mayContain attribute.

My question is why is there no mayContain attribute and how can I get the mayContain attribute?
Comment
Watch Question

Do more with

Expert Office
EXPERT OFFICE® is a registered trademark of EXPERTS EXCHANGE®
Have you ensured the user you logged into the Exchange server with is a member of the Schema Admins group?

Author

Commented:
I'm logged on as the built in administrator, and I have verified that the administrator is part of the schema admins. The link still didn't help as any suggestions posted in the link always gave me the same error (the same error from my opening post). I checked the idif.err fil and here is the error:

Entry DN: CN=ms-Exch-Resource-Schema,CN=Schema,CN=Configuration,DC=domain name,DC=ca
Add error on line 180: No Such Attribute

The server side error is "The parameter is incorrect."

An error has occurred in the program


 
Should you be charging more for IT Services?

Do you wonder if your IT business is truly profitable or if you should raise your prices? Learn how to calculate your overhead burden using our free interactive tool and use it to determine the right price for your IT services. Start calculating Now!

Any errors on the domain controller that holds the schema FSMO role?

Author

Commented:
Do you mean like in the event viewer or something?
Yes, in the event viewer.  Check all the event logs for the time that your error occured to see if there is any additional information available for troubleshooting.

Author

Commented:
This was the only error around the time I tried to update exchange, but I'm pretty sure it's unrelated.

Source: MXExchangeTransport
Category: TransportService
Type: Error   Event ID: 12014

Description:
Microsoft Exchange couldn't find a certificate that contains the domain name mail.domain name.ca in the personal store on the local computer. Therefore, it is unable to support the STARTTLS SMTP verb for the connector name of exchange server with a FQDN parameter ofmail.domain name.ca. If the connector's FQDN is not specified, the computer's FQDN is used. Verify the connector configuration and the installed certificates to make sure that there is a certificate with a domain name for that FQDN. If this certificate exists, run Enable-ExchangeCertificate -Services SMTP to make sure that the Microsoft Exchange Transport service has access to the certificate key.
Yeah, that error is either you do not have any certificate set for the SMTP service or the self-signed certificate being used for SMTP is expired.

What is dumbfounding me is that the schema attribute you are looking for isn't event modified by Exchange 2007 SP3 according to this:

http://technet.microsoft.com/en-us/library/ff607224(EXCHG.80).aspx
Are you upgraded to SP3 from an RTM version of Exchange 2007?  That attribute is first added by Ex 2007 SP1.

Author

Commented:
No, I already have service pack one installed.
Never mind I got it, and now I feel like a total idiot too. In the ADSI Edit window I was looking for CN=ms-Exch-Resource-Schema, CN=Schema, CN=Configuration, DC=Domain, DC=COM directly under the Schema partition in the left side of the window. The only thing there was CN=Schema,CN=Configuration,DC=domain name,DC=ca, so I was clicking on the properties for that. But what I really had to do was click on CN=Schema,CN=Configuration,DC=domain name,DC=ca and find the CN=ms-Exch-Resource-Schema on the right side of the window.

Anyway this linked tipped me off as to what I was doing wrong:

http://fixbyproximity.wordpress.com/2010/08/18/fixing-error-code-8202-when-installing-exchange-2007/

Author

Commented:
I solved my own problem. I found a link that helped me fix the issue I have been having.

Do more with

Expert Office
Submit tech questions to Ask the Experts™ at any time to receive solutions, advice, and new ideas from leading industry professionals.

Start 7-Day Free Trial