application cannot be published on local websphere 6.1 test environment

ly_uwo
ly_uwo used Ask the Experts™
on
I am trying to run applications on my RAD7.5 local test websphere 6.1 environment. However, I got publish errors below. Any thoughts? If running on unix websphere server, it has no problem. My local OS is windows.

Thx, mike


Publishing failed
  The publish encountered some problems and the application may not have been installed or it may have been successfully installed but was unable to start.
    The application contains validation errors. Correct the errors in the Problems view before publishing the application on the server.
    If you want to allow applications containing errors to be published on the server, enable the Allow applications containing errors to be published on a server check box (Windows > Preferences > Servers > WebSphere).
   
    XSD: Type reference 'http://ws.rcservice.com#EscalatedType' is unresolved
  The publish encountered some problems and the application may not have been installed or it may have been successfully installed but was unable to start.
    The application contains validation errors. Correct the errors in the Problems view before publishing the application on the server.
    If you want to allow applications containing errors to be published on the server, enable the Allow applications containing errors to be published on a server check box (Windows > Preferences > Servers > WebSphere).
    Start tag (<ILECCustomerInfo>) not closed.
  The publish encountered some problems and the application may not have been installed or it may have been successfully installed but was unable to start.
    The application contains validation errors. Correct the errors in the Problems view before publishing the application on the server.
    If you want to allow applications containing errors to be published on the server, enable the Allow applications containing errors to be published on a server check box (Windows > Preferences > Servers > WebSphere).
    cvc-complex-type.2.4.a: Invalid content was found starting with element 'CircuitNumber'. One of '{"http://mycompany.com/ns":CircuitId, "http://mycompany.com/ns":ProviderCircuitNumber, "http://mycompany.com/ns":CircuitDescription, "http://mycompany.com/ns":CircuitRemarks}' is expected.
Comment
Watch Question

Do more with

Expert Office
EXPERT OFFICE® is a registered trademark of EXPERTS EXCHANGE®
Commented:
I found the answer. I need to set the validation as true for the saxparser factory
HonorGodSoftware Engineer

Commented:
I'm glad to hear that you've identified the source of your problem.

Might I suggest that you change the zone to "IBM WebSphere", and then select your update as the solution?

This would keep the solution around for people to find.

Author

Commented:
how to change?
HonorGodSoftware Engineer

Commented:
Click on the "Request Attention" link in the bottom right corner of the question.
Kevin CrossChief Technology Officer
Most Valuable Expert 2011

Commented:
This question has been classified as abandoned and is closed as part of the Cleanup Program. See the recommendation for more details.

Do more with

Expert Office
Submit tech questions to Ask the Experts™ at any time to receive solutions, advice, and new ideas from leading industry professionals.

Start 7-Day Free Trial