How to install TclOO in Linux/Ubuntu?

nvs_victor
nvs_victor used Ask the Experts™
on
Good morning.

I have an important project due today, and I've been struggling to getting TclOO installed (object oriented extension).
Website: http://wiki.tcl.tk/18152
Download: http://sf.net/project/showfiles.php?group_id=10894&package_id=247402

When I follow TclOO's README.txt file in the extracted folder,
(found online: http://sourceforge.net/project/shownotes.php?release_id=633147)
 
they say to run configure shell script, and use --with-tcl option to tell where to find Tcl's build descriptor. Where is that? And how do I run the configure script with that file?

I tried running (in TclOO's directory), ./configure --wtih-tcl "/usr/include/tcl8.5"   but it doesn't work. It spits out an error.

If I run ./configure by itself, it goes thru, then stops with this:

checking for Tcl private include files... configure: error: Cannot find private header tclInt.h in /home/andreask/dbn/lba/GlobalBuildArena/builds/linux-ix86/tcl.ins



I'm not allowed to use ActiveTcl 8.6, which would get me OO extension automatically.

Thanks a lot!
Comment
Watch Question

Do more with

Expert Office
EXPERT OFFICE® is a registered trademark of EXPERTS EXCHANGE®
Commented:
I am pretty sure you are only missing the development files, try to install tcl-dev.

(apt-get install tcl-dev, or aptitude install tcl-dev).

If this does not work post the output of:

dpkg -l | grep tcl

so I can see what you have already installed.

best
Ray

Commented:
as you seem to use tcl8.5, apt-get install tcl8.5-dev as well (if this is not the default), here is the file included:

tcl8.5-dev: /usr/include/tcl8.5/tcl-private/generic/tclInt.h


try as well first the command:
 ./configure --wtih-tcl "/usr/include/tcl8.5"  

without the --with-tcl, it should find it automatically, if not you can try with it.

also sometimes the configure/make process screws up when there are errors, so as a last resort delete the tcloo directory and start from scratch.

best
Ray

Author

Commented:
It worked! Thank you!

But I don't understand... I had Tcl8.5 & Tcl8.5-dev installed. Why weren't these used?
Should you be charging more for IT Services?

Do you wonder if your IT business is truly profitable or if you should raise your prices? Learn how to calculate your overhead burden using our free interactive tool and use it to determine the right price for your IT services. Start calculating Now!

Author

Commented:

When I try  ./configure --wtih-tcl "/usr/include/tcl8.5"  

I get these errors all the time.

configure: WARNING: you should use --build, --host, --target
configure: WARNING: invalid host type: /usr/include/tcl8.5
checking for correct TEA configuration... ok (TEA 3.6)
checking for Tcl configuration... configure: error: yes directory doesn't contain tclConfig.sh


Commented:
depends on the version of debian or ubuntu which you have installed. on an recent lucid system the default TCL version is 8.4, so if you installed tcl-dev, the version for tcl8.4-dev gets installed.

Maybe there was a conflict in your system regarding the default package and the 8.5 package, it is difficult to say without having all the information ...

but, at least now it worked :-)

best and good luck with your project
Ray

Commented:
Are you really trying:
./configure --wtih-tcl "/usr/include/tcl8.5"  

or is this a typo (i mean "--wtih-tcl" instead of "--with-tcl")

best
Ray

Commented:
If this is not a type it could mean that "/usr/include/tcl8.5" get's misinterpreted.

Author

Commented:
"./configure --wtih-tcl "/usr/include/tcl8.5"  "
was just my typo here in EE.

I ensured I typed it correctly. If I did type that, it will return "error: unrecognized option --wtih-tcl"

Ok. I'm having issues making, so now to start up another question.

Thanks for your help.  

Author

Commented:
Excellent.

Do more with

Expert Office
Submit tech questions to Ask the Experts™ at any time to receive solutions, advice, and new ideas from leading industry professionals.

Start 7-Day Free Trial