SAP Business Objects reports stop

Kram80
Kram80 used Ask the Experts™
on
We are running SAP Business Objects to generate reporting.  On random days at a specific time each morning, reports will stop running and we will have to restart the business objects service.  I have ran performance monitoring and during that time CPU spikes to 100%, pages/sec increases to an avg of 11, with max being 1034( scale of 1), average disk seconds/write spikes to .015 (scale of 100) and average disk queue length also spikes during this time.  In performing baselines for the past few days before reporting stopped, this seems normal during this time period.  Available memory doesn't appear to be an issue, as it hovers around 1.3GB.

We are running Server 2008 (32-bit), 4GB RAM, Intel Xeon 2.27Ghz.  We are running the SQL database on a second server, but that doesn't appear to be an issue.  Once services are restarted on the Business Objects server, it appears to function correctly again.

I'm getting the following errors in the event log during this time frame:

Log Name:      Application
Source:        BusinessObjects_JobServer
Date:          10/18/2010 2:05:31 AM
Event ID:      45388
Task Category: Scheduling
Level:         Error
Keywords:      Classic
User:          N/A
Computer:      Server.domain.local
Description:
Subprocess (Job Server Child) could not be started. Reason: Couldn't get IJob interface or writing IAudit: Pipe exception. Reason: jobserverchild (procreport, 2, Could not send request to child [6716] (timeout = [60000]ms, request time span = [1124])

The above event happened about two and a half hours before reports stopped generating.

Log Name:      Application
Source:        BusinessObjects_CMS
Date:          10/18/2010 4:37:29 AM
Event ID:      50410
Task Category: (13)
Level:         Error
Keywords:      Classic
User:          N/A
Computer:      SERVER.domain.local
Description:
CMS Server Watcher: server named 'SERVER.CrystalReportsJobServer' is being marked as down because it is unresponsive

The above is the error that happens when reports stop processing.

I'm looking for any input on this.  I'm kind of at a loss at what to do next.  I thought it might be related to resources being taxed during that time, but that seems to be normal.  It doesn't stop responding every night.  I don't have any experience with Business Objects, I apologize for that.
Comment
Watch Question

Do more with

Expert Office
EXPERT OFFICE® is a registered trademark of EXPERTS EXCHANGE®
Commented:
Hi,

I had the same kind of troubles with my 2008 server as well (can't say if the error messages were the same, it's been a while). I had reports that were spiking the server cpu at 100% for a long period. I added a CPU to the server and the problems disappeared.

Hope this will help.
P.S. Be sure your kernel is not at 100% as well, in that case an additional CPU won't help.

Author

Commented:
Thanks Etdashou.  It's actually running on a VM and finally had some additional time to investigate more on Friday.  Found it was only running on 1 core and that we had 1 more core we could use.  So this morning I increased it to two cores and we'll see what happens.  Thanks for your help!  Appreciate it.

Author

Commented:
Thanks again.

Do more with

Expert Office
Submit tech questions to Ask the Experts™ at any time to receive solutions, advice, and new ideas from leading industry professionals.

Start 7-Day Free Trial