How do I allow my assistant to edit my calendar and contacts, but not see my inbox?

WeThePeople used Ask the Experts™
I want my assistant to be able to edit my outlook calendar, tasks and contacts.

I do not want my assistant to see my outlook inbox.

How do I give her access and permissions to do this.  We both use Exchange Server 2010 and Outlook 2010.

Thank you.
Watch Question

Do more with

Expert Office
EXPERT OFFICE® is a registered trademark of EXPERTS EXCHANGE®
You can set permissions on your calendar as well as your contacts and give your assistant the rights to edit both of them.  This will only allow access to those two items and not to any other mailbox items.
davealfordIt Support

By default, the 'default' setting on folders is 'no access'. So, if you go through the Outlook 'Share My Calendar', that's all they'll get access to.
davealfordIt Support

oh, and then edit the permissions on the taks and contacts that's it - they'll only get the access you give to them. They'l alos need to add your malbox to their Outlook view - right click at the top of their mailbox, select properties, click advanced button, sleect advanced tab, click add, type in your name, click OK, OK etc back to their Outlook view and your mailbox will be viewable ...... but, they'll only get access to those folders you've given them permission to.
Should you be charging more for IT Services?

Do you wonder if your IT business is truly profitable or if you should raise your prices? Learn how to calculate your overhead burden using our free interactive tool and use it to determine the right price for your IT services. Start calculating Now!

for 2007, maybe it will be similar for 2010

open outlook, right-click calendar / contacts, select change permissions, add assistant, give  permissions to assistant based on what the assistant should be able to do.

go to assistant's computer, open outlook, click file, open, other users folder, typed in your username for the  user, select calendar from the drop-down, click OK. repeat for contacts.

hope this helps


Is it possible to have my calendar and contacts appear in the left side window instead of having to open another user's calendar each time.
after following what I have posted, your calendar will be available from the assistants outlook view by clicking a checkbox under calendar in the outlook tree. should be same for contacts. The checkbox will be your name. you may also want to investigate davealford's post regarding view.


My assistant does see my name on the left side, but when she clicks on it, there is no folders, such as Calendar and Tasks, underneath my name.  

HOWEVER, if she clicks File -> Open -> Other users -> Me (and selects my calendar), she is able to see my calendar.

HOWEVER, if she clicks File -> Open -> Other users -> Me (and selects my contacts), she is able to see my contacts.

Both of those is a lot of steps to have to do continuously.  Why does my calendar and contacts not appear under my name on her computer?
When she is on her own calendar, there should be section named People's  Calendars under her My Calendar section (on the left-side outlook tree).  Is that there? If so, is your name there? It should be (or eventually  be) there. This is under her account, not yours.

You could try this:
 Click Calendar, and then click Open a  Shared Calendar.                                                                                              
 In the Open a Shared Calendar dialog box,  in the Name  box enter your name

Click OK.
check out section 1 here (and the other sections if you find them helpful)

also, just read that the most recently used list is no longer available in 2010, which forces the full steps you listed above. have you tried adding her as a delegate to see if your calendar / contacts show up? After she opens your calendar, it should remain available in her outlook tree.

In Outlook 2010, click the File tab and  click Account Settings > Delegate Access.  Click Add....Search using the last name of the person you  want to make your delegate.Add the person to the Add  box at the bottom of the window. Then click OK.Click  the Calendar drop-down menu to select a delegate type. If you select  Editor, the box labeled, Delegate receives copies of meeting-related  messages sent to me, is checked.  If  you do not want your  delegate to receive meeting emails sent to you, remove the check mark  from this box.If this box is checked, your delegate will be  able to easily accept or decline meeting requests on your behalf.   Click the Tasks drop-down menu and select None.To  allow your delegate to see your private calendar items, put a check mark  in the box labeled, Delegate can see my private items.Click  OK.Click Apply and then OK.

hope this helps


In Outlook on my computer,
I have set her as Publishing Editor on the root of my folders
I have set her as Publishing Editor on my contacts folder.
I have set her as Publishing Editor on my tasks folder.
I have set her as Publishing Editor on my calendar folder.

On my assistant's computer, when she clicks Folder view (to view the tree on the left), all the folder's appear there including my name.  There is a little tick mark (use to be the + sign) next to my name, but when she clicks on it, nothing appears below it.    

sorry this is not working out for you. we have several people set up this way at the firm on 2007 and they see the calendars / contacts as I have described. If I can think of anything else, I will post back.

however, what does she see when she clicks Calendars from the bottom of her Outlook tree? Does she see your name anywhere? If so, when she clicks it, does it show your calendar?


When she clicks on Calendar, she see's her calendar AND my calendar.
OK, "she see's her calendar AND my calendar" - so together in one calendar view (her calendar entries and yours on the same day), correct? Or is it a split-view with your calendar and hers separated? Is there anyway to de-select her calendar and view only yours? Also, doesn't this alleviate the need to go through the file>open ... steps? Even if both calendars are showing up. Sounds like a little progress in that at least she can see yours from this view. Try adjusting the views and see what happens.

what about contacts from the bottom of the outlook tree? does she see yours and hers? just hers? de-select her contacts option?

Do more with

Expert Office
Submit tech questions to Ask the Experts™ at any time to receive solutions, advice, and new ideas from leading industry professionals.

Start 7-Day Free Trial