Configuring two Cisco 3560G Switches with the SFP connector

ohmErnie
ohmErnie used Ask the Experts™
on
I have a second 3560G switch I would like to connect to my existing 3560G switch using a SFP connector.  What is the best way and commands to configure this?  Will I have to telnet into each switch to change a port setting or can I do so through one single IP?
Comment
Watch Question

Do more with

Expert Office
EXPERT OFFICE® is a registered trademark of EXPERTS EXCHANGE®
enable trunking....
trunk the port...use as uplink
You just need to define media type and trunk those ports...

Author

Commented:
I was looking for a more detailed solution with Commands.
Learn SQL Server Core 2016

This course will introduce you to SQL Server Core 2016, as well as teach you about SSMS, data tools, installation, server configuration, using Management Studio, and writing and executing queries.

You need to telnet indiidually into each switch and run the following commands on both switches (I have assumed your SFP ports are G0/1)

conf t
interface g0/1
switchport
switchport trunk encapsulation dot1q
switchport mode trunk
no spanning-tree portfast
no shut
exit
copy run start

You need to make sure both the speed and duplex settings are the same on both ends. In the above example, I have assumed they are default which is auto auto. To se them to a fixed speed and duplex, enter:

conf t
int g0/1
speed 1000
duplex full
exit
copy run start


On a trunk port, you should always hardcode the speed and duplex settings...you should never leave them default...
Agreed, I should have  included it as mandatory instead of optional.

Author

Commented:
The commands for speed and duplex are not recoginized.  If I do: speed /? I get nonegotiate Do not negotiate speed.  I read this is because I have a 1000mbps interface and not a 10/100/1000mbps.  Therefore, my port setting is Auto for both unless there is a different command.
You presumably have a fibre SFP installed? The nonegotiate command was added by Cisco to support fibre connectivity to legacy equipment that could not support negotiation - we have some old servers where we need to apply this command otherwsise the port would not come up as cisco would not recognise that a device was connected.

Although we stated above that you must fix speed and duplex for inter switch links, it does not actually apply in this case as the nonegotiate command is meant for ports connected to legacy end devices that must have it as described above. It is not required for interswitch links between cisco equipment.
conf t
interface g0/1
switchport
switchport trunk encapsulation dot1q
switchport mode trunk
switchport nonegotiate
no spanning-tree portfast
no shut
exit
copy run start
****************************************************************and********************

conf t
int g0/1
speed auto
duplex auto
exit
copy run start
As stated shove, as the original poster mentioned, they can not set speed and duplex as its a fibre sfp connection.  even if speed and duplex could be set to auto, this is not best practice for inter switch links.

Do more with

Expert Office
Submit tech questions to Ask the Experts™ at any time to receive solutions, advice, and new ideas from leading industry professionals.

Start 7-Day Free Trial