Remote Desktop is not working

Dan
Dan used Ask the Experts™
on
I am running windows xp, and windows server 2003 as my server, and I have no problems using RDP for my systems except 1 PC that I can't RDP into.  I made sure that the firewall settings are fine, so it's allowing RDP port 3389, remote assistance and I compared all the services with a PC that is working and all the services are fine.

I just get the generic error message:

"Remote Desktop can't connect to the remote computer for one of these reasons":
1. remote access to the server is turned off
2. the remote computer is turned off
3. the remote computer is not available on the network
Comment
Watch Question

Do more with

Expert Office
EXPERT OFFICE® is a registered trademark of EXPERTS EXCHANGE®
Commented:
I'm assuming you're trying to RDP to the XP machine from the server.
  1. Can you ping the XP computer from the server?
  2. If so, open a command prompt on the server and type in telnet computername 3389. What response do you get?
- Eric
Not sure whether you are talking this property as port "3389"

Just in case, if you want to verify

control Panel -> System -> Properties -> Remote Tab

[ ] Allow users to connect remotely to this computer

Use the name displayed below this check box under full computer name, while you connect.

thanks
John
DanNetwork Engineer

Author

Commented:
Actually, I'm using windows 7 pro, and I was able to RDP into it a few weeks ago, just not sure what happened.

I can ping both the name and the IP address.
When I did telnet computername 3389, the screen changes to a black screen with the prompt flashing.

I can't believe I forgot to check the permissions......  The check mark where it enables remote desktop was unchecked.  That's one of the first places I should have checked.   Thanks you guys!!
Introduction to Web Design

Develop a strong foundation and understanding of web design by learning HTML, CSS, and additional tools to help you develop your own website.

Commented:
The telnet test simply proved that you were able to communicate with the client over port 3389. The blinking curser was a successful connection.
Glad you got it solved.
- Eric

Commented:
BTW, I use a GPO to ensure RDP is working on all my clients. It enabled the connection and opens the firewall port but restricts it to only the vlans that I want to be able to RDP from.
- Eric
DanNetwork Engineer

Author

Commented:
Thanks, I don't know why the "allow usrees to connect remotely to this computer" was checked off, as it was on before.
DanNetwork Engineer

Author

Commented:
equack, so how did you setup your GPO to do that?  Do you mind sharing what the settings are?

Commented:
Computer Configuration/Administrative Templates/Windows Components/Terminal Services - Policy: Allow users to connect remotely using Terminal Services: Enabled
Computer Configuration/Administrative Templates/Network/Network Connections/Windows Firewall/Domain Profile - Policy: Windows Firewall: Allow Remote Desktop Exception: Enabled, Allow unsolicited incoming messsages from: x.x.x.x/24,x.x.x.x/24
- Eric
DanNetwork Engineer

Author

Commented:
So your above two policies allow anyone on the network to connect to any PC via RDPC, right?
Is that smart, as I wouldn't want everyone to be able to RDP into other PC's?  I see how it's convenient though.

Commented:
Yes, that allows any PC o connect to any other via RDP, but thay'd have to be members of the "Remote Desktop Users" localgroup on the PC to be able to use it.
My firewall policies only allow remote administration and file sharing from sub-subnet of a certain vlan. (/29)
DanNetwork Engineer

Author

Commented:
got it, I added my IP address domain, so I guess only someone on the local network can access it.

Commented:
yep. You could also use 'localsubnet'. I have several vlans, sot that wouldn't work for me. The reason I have it opened up to most of my vlans is so I can RDP into one user's machine from another user's machine if I'm not at my desk. You could also specify a single ip address or multiple individual IPs, separated by commas.

Do more with

Expert Office
Submit tech questions to Ask the Experts™ at any time to receive solutions, advice, and new ideas from leading industry professionals.

Start 7-Day Free Trial