Offline Address Book not synchronizing with the Global Address List in exchange 2010

I have a client that is running an exchange 2010 environment.  The users are still using outlook 2007.  We have the users run their outlook in cached exchange mode to reduce the work load on the server, so the Offline Address Book plays a pretty big role.

We have added three new users (two legit employees and one test account) since the migration, and none of the three are showing up in the OAB.  When I take a mailbox off of cached exchange mode the users show up just fine.  

I have updated the OAB in both the EMC and the EMS, and it shows that it updates with its schedule.

It seems like the two, OAB and GAL, just aren't connecting with each other.  

Any thoughts on why Outlook isn't getting an updated OAB?

Is there a way to view the OAB directly?  I ask because maybe the OAB isn't updating the same file that Outlook is pulling from.

Thanks, in advance, for your help.
Who is Participating?
I wear a lot of hats...

"The solutions and answers provided on Experts Exchange have been extremely helpful to me over the last few years. I wear a lot of hats - Developer, Database Administrator, Help Desk, etc., so I know a lot of things but not a lot about one thing. Experts Exchange gives me answers from people who do know a lot about one thing, in a easy to use platform." -Todd S.

Haev you Set the OfflineAddressBook for this user like this
 set-mailbox YourProblematicMailbox -OfflineAddressBook "Default Offline Address Book"

and then check it. Hopefully it will resolve ur issue.

hbrumfieldAuthor Commented:
Yes, I did.  It did not work.  Looking into it further, it seems like the OAB isn't even being populated.
Can u verify that u have at least one OAB in your exchange 2010 environment: plz run


if it doesnt show any OAB then you will have to create at least one OAB using the new-offlineAddressBook command.

Go to "Client Access Server\OAB" folder in Exchange installation folder which is normally

C:\Program Files\Microsoft\Exchange Server\ClientAccess\OAB

and check whether it has the folder with the GUID of  your oab, and als check oab.xml in this folder (folder with the name of guid of OAB).

If OAB is not generated then u will have to first generate it manually in three easy steps mentioned here Manual Generation of OAB in Exchange 2007/2010:
 1. Run Update-OfflineAddressbook “offline address book” in Exchange Management Shell. e.g
 Update-OfflineAddressbook “Default offline address book”
 2. Restart System Attendant Service on the OAB Generation Server (Mailbox Server). This service is responsible for generating the OAB by communicating with Active Directory infrastructure.
 3. Either run following command in EMS
 Update-FileDistributionService “CASServerName”
 or just restart File Distribution Service on CAS Server.
 File distribution service copies the OAB from the Mailbox Server, where System Attendant Service puts OAB in a shared folder “C:\Program Files\Microsoft\Exchange Server\ExchangeOAB”. Outlook clients
then download the OAB from CAS published OAB Virtual Directory.

And then check OAB download in outlook again.

Experts Exchange Solution brought to you by

Your issues matter to us.

Facing a tech roadblock? Get the help and guidance you need from experienced professionals who care. Ask your question anytime, anywhere, with no hassle.

Start your 7-day free trial
Microsoft Azure 2017

Azure has a changed a lot since it was originally introduce by adding new services and features. Do you know everything you need to about Azure? This course will teach you about the Azure App Service, monitoring and application insights, DevOps, and Team Services.


Second thought, can you  also check on your outlook client if there an error message in the Sync Issues folder?

If there is a Not downloading Offline address book files error, then may be this MS article apply to your situation:

Good luck.
Go to EMS -> type: Update-OfflineAddressBook "Name Of Your Offline Address Book"

Go TO Exchaneg Management Console and check that your oab has the following settings:
Properties of OAB
- General = Update schedule is set to run daily at 5:00 A.M
-Address Lists = Include the default Global Address List, Include the following address lists:
All Contacts
All Groups
All Rooms
All Users
Public Folders
-Distribution = Distribution Points: Enable web-based distribution (marked)
OAB (Default Web Site) needs to be added and Enable public folder distribution should be marked  
hbrumfieldAuthor Commented:

There is an offline address book.  

In the OAB folder, there are only two types of files.  The LZX files (content of the OAB?) and an XML file.  The last time these files, all of them, were updated was 9/9/2010 which would explain why the users are not getting an updated OAB.

When I tried those three steps, I received an error that the synchronization failed.  Looking into the server's even log for details.

Did you try the above that I meantioned? If you did and didnt see a difference, you should recreate the oab and set your active mailboxdatabase against your newly created OAB and set the settings of the new OAB to those that I meantioned in the previous post..

hbrumfieldAuthor Commented:
And the even log said that cmdlet succeeded, bu the command prompt said that it failed.
hbrumfieldAuthor Commented:

I did try what you recommended.  Unfortunately it did not work either.  I found two errors:

OABGen encountered error 80004005 (internal ID 50103b7) accessing the public folder database while generating the offline address list for address list '/'. - \ New OAB |


OABGen encountered error 80004005 while cleaning the offline address list public folders under /o=TRIEAGLEENERGY/cn=addrlists/cn=oabs/cn=New OAB.  Please make sure the public folder database is mounted and replicas exist of the offline address list folders.  No offline address lists have been generated.  Please check the event log for more information.
- \New OAB
hbrumfieldAuthor Commented:
To avoid confusion.....

Those errors were found while updating the OAB
hbrumfieldAuthor Commented:
I have narrowed it down.  The is looking at an incorrect GUID.  

I noticed that the new OAB that I created did not create a systems public folder
OAB does not create this by default.

At the moment isnt all the updates from your GAL synchronized against your OAB ?
hbrumfieldAuthor Commented:
No, they arent, Juuso.  Well, they are now because I did it manually.  

I ended up deleting all of my OABs and created a new one.  After doing this a few times they showed up in the Systems Public Folders.  I ran the update command that Juuso recommended and I followed the instructions that David recommended.  

The only thing left is to redirect the OAB virutal directory to a new GUID and I believe it will work.  

Thank you, to both of you guys.  I used both of your suggestions in getting this to work, so I would like the points split between you both.
Glad that you got it to work!

hbrumfieldAuthor Commented:
My OAB problem is fixed.  These guys gave some really good insight and helped push me a long.
It's more than this solution.Get answers and train to solve all your tech problems - anytime, anywhere.Try it for free Edge Out The Competitionfor your dream job with proven skills and certifications.Get started today Stand Outas the employee with proven skills.Start learning today for free Move Your Career Forwardwith certification training in the latest technologies.Start your trial today

From novice to tech pro — start learning today.