Remote Desktop(administration) not working on Server 2008r2 after uninstalling Remote Desktop Service

We have a development 2008 R2 that we were trying remote desktop services, we installed the gateway and web, but we decided to uninstall these as we have an active directory domain on this server.

After removing the service and role, we no longer have access to remote desktop for administration purposes.  Remote desktop is still enabled.  Is there something I'm missing?
Who is Participating?
I wear a lot of hats...

"The solutions and answers provided on Experts Exchange have been extremely helpful to me over the last few years. I wear a lot of hats - Developer, Database Administrator, Help Desk, etc., so I know a lot of things but not a lot about one thing. Experts Exchange gives me answers from people who do know a lot about one thing, in a easy to use platform." -Todd S.

you have likely stoped the terminal services service check your services and if it is stoped restart it and set it to automatic.
Also check your firewall to ensure that it allows remote desktop traffic to pass.
anderdw2Author Commented:
Remote desktop services is started and set to automatic.  I don't see terminal services listed.
I even tried disabling the firewall, but there is a INBOUND allow for remote desktop
Learn Ruby Fundamentals

This course will introduce you to Ruby, as well as teach you about classes, methods, variables, data structures, loops, enumerable methods, and finishing touches.

open up a MMC (microsoft managment Console) and add the terminal services configuration addin and tell me wether RDP-Tcp i there. if it is then right click it and click security and add the user or group your trying to remote desktop with.if it is not there then you will have to recreate the connection this can be done on the top right handside of the snapin
anderdw2Author Commented:
RDP-tcp is there.  The local admin account is there, that is what we used previously to remote desktop into this server.
Is there a way to reinstall terminal services only?
you could install terminal services how ever i believe this to just be a patch to your problem. all i can guess is that the terminal services service has been stoped.  if you arrange all your services in the services snapin you should be able to find it by pressing T on the keyboard.
anderdw2Author Commented:
here is my service list
anderdw2Author Commented:
Sorry for the poor image quality, basically terminal services is not there.
It seems like when I removed the role services, it removed even the basic terminal service
Does that make sense?
yes that does in that case you will have to install the terminal services service with 2 access licences that should then solve your problem.
anderdw2Author Commented:
Do you know off hand is that terminal services 6.0?  I'm trying to find a link on microsoft.
Sorry i dont know.
anderdw2Author Commented:
I think i found out why i couldn't access.   A rather simple solution, i'm afraid to admit.
I enabled remote desktop from the properties COMPUTER - REMOTE SETTINGS
I just noticed last night, that in SERVER MANAGER the Server Manager Remote Management was disabled, so i enabled it and everything seems ok.
However, I still don't see terminal service in the SERVICE menu.  
Thanks for the help!

Experts Exchange Solution brought to you by

Your issues matter to us.

Facing a tech roadblock? Get the help and guidance you need from experienced professionals who care. Ask your question anytime, anywhere, with no hassle.

Start your 7-day free trial
no problems its weird about the terminal service not being there thogh as all my servers have it
It's more than this solution.Get answers and train to solve all your tech problems - anytime, anywhere.Try it for free Edge Out The Competitionfor your dream job with proven skills and certifications.Get started today Stand Outas the employee with proven skills.Start learning today for free Move Your Career Forwardwith certification training in the latest technologies.Start your trial today
Windows Server 2008

From novice to tech pro — start learning today.