fighting exchange 2007 certificates

bhgewilson
bhgewilson used Ask the Experts™
on
I have been through this site several times but everytime I get in trouble with certificates and Exchange 2007 I come right back.  I have a documented process that has worked for close to three years on these certs.  Now in this case I installed a SBS 2008 server.  Ran all wizards.  Went through and got a third party san.  

Name was mail.domainx.com
Alternative names were  magred-svr, magred-svr.wahoo.local, remote.domainx.com, autodiscover.domainx.com

All of this and I get the cert back.  Go into IIS, import.  Go into ESM shell.  Import, get, enable and I keep getting the TLS message.  

So I tried several things to fix this and to no avail I did not fix it.  I tried changing certs in IIS, changing them in the certificate authourity.  I screwed up CAS like this so I have had to rebuild it from scratch.  Now when I go into mail.domainx.com\owa I get a message about call stacks and virtual directory errors.  I went in and stopped the sbs web applications, started the default website and all is working as it was before except the certificate.

I am lost, where should I import the cert.  What should I try.  Thanks!  And yes I am desperate!!!!!
Comment
Watch Question

Do more with

Expert Office
EXPERT OFFICE® is a registered trademark of EXPERTS EXCHANGE®
what is the error message?
What is the response in accessing the default .htm and images from the IIS with and without the SSL

Author

Commented:
There is a problem with this website's security certificate.
 
   
 The security certificate presented by this website was not issued by a trusted certificate authority.
The security certificate presented by this website was issued for a different website's address.

Security certificate problems may indicate an attempt to fool you or intercept any data you send to the server.  
  We recommend that you close this webpage and do not continue to this website.  
  Click here to close this webpage.  
  Continue to this website (not recommended).  
     More information

 
When I go through HTTP I get page not displayed.

So I guess I am trying to figure out how or where to get the cert added.  
try https://mail.domain.com/owa and check...

Author

Commented:
this is what I did above when I get the security certificate problem

HTTP gets page not displayed.
Ok I fixed this by allowing bindings on the default website, re-keying the certificate, importing again and it worked.  

Do more with

Expert Office
Submit tech questions to Ask the Experts™ at any time to receive solutions, advice, and new ideas from leading industry professionals.

Start 7-Day Free Trial