Always run as administrator

There is a terminal server(Win 2008) that the users log on to. The users start a program that is stored on a network share. The shortcut in the start menu to the application is stored on another network share.

To start the application corretly, users have to rightclick the shortcut in the start menu and choose "run as administrator." This is a bit clumsy I think, so I wanted to set this option by default.

I tried this via the shortcut, and setting the property: "run this program as an administrator" on the shortcut. But that is not possible since the shortcut is stored n a network location. I then tried to log on where the application executeable is stored, and tried to set this option there. The option is greyed out, since UAC is not turned on, on the application server(but it is on the terminal server). I then tried to log on to the server that hosts the startmenu items for the user, but UAC is turned off there too. I have no idea if a option in the shortcut would affect my user only or all users anyway.

So, then I am stuck. The users have to right click and choose "run as administrator" every time they start the application. Is there a way to go around this other then what I have done without doing to much environmental changes? I guess that might have a GPO for all this, was hoping to avoid that.

Turning off uac on the TS servers is preferably not an option.
LVL 2
itniflProgrammerAsked:
Who is Participating?
I wear a lot of hats...

"The solutions and answers provided on Experts Exchange have been extremely helpful to me over the last few years. I wear a lot of hats - Developer, Database Administrator, Help Desk, etc., so I know a lot of things but not a lot about one thing. Experts Exchange gives me answers from people who do know a lot about one thing, in a easy to use platform." -Todd S.

Krzysztof PytkoSenior Active Directory EngineerCommented:

Experts Exchange Solution brought to you by

Your issues matter to us.

Facing a tech roadblock? Get the help and guidance you need from experienced professionals who care. Ask your question anytime, anywhere, with no hassle.

Start your 7-day free trial
zeshanazizSystem AdministratorCommented:

let say ur application is located in \\10.10.1.20\share just add the user in (share folder) security group and give him full rights.
itniflProgrammerAuthor Commented:
iSiek and zeshanaziz:
Scenario 1: Request an application to run elevated one time - they are doing this one already.
Scenario 2: Configure an application to always run elevated - not possible, read the question again.
Compatibility tab is greyed out when the shortcut is placed on a network share, with the message: "Compatibility mode cannot be set permanently on this program because it is on a network drive." Nothing to do with rights. If so, other problems would occur(depending on the rights).
Scenario 3: Configure User Account Control - not wanted, as described in the question. The sam,e goes for the elevation prompt behavior.

I guess I will be ending up with doing something like Scenario 3 if I can't help it.
Python 3 Fundamentals

This course will teach participants about installing and configuring Python, syntax, importing, statements, types, strings, booleans, files, lists, tuples, comprehensions, functions, and classes.

SONightHawkCommented:
Option 1  
   1. Right-click the application, and then click Properties.
   2. Click the Compatibility tab.
   3. Select the Run this program as an administrator checkbox, and then click OK.

Option 2
If this doesn’t work (like, for a shortcut on the desktop example), you can modify the shortcut UAC settings instead.
UAC option
1. Click Start. Type Command. Right-click whatever shortcut (say a mapped drive on the desktop), and then click Properties.

2. On the Shortcut tab, click Advanced.

3. Select the Run as administrator checkbox

4. Click OK twice.

Now, when you launch the shortcut from the Start menu, UAC will no longer prompt you for administrative privileges.


click-run-as.png
itniflProgrammerAuthor Commented:
SONightHawk: I don't now what version of Windows you are using, but under Vista or Windows 7 you find what you are talking about under the Compatibility tab after right clicking and choosing properties.

The big mistake here is that people don't read the question properly, and they don't read the history of the answers. They don't pay attention to the details and the replies. When the same solutions come in again and agai, and I answer the same again and again, its getting pretty frustrating.

The compatibility tab is greyed out, and therefore I can't set the options you show.
If you wonder why, read read read.

I will choose the first answer as the solution, even though it is the same as all the rest. It is accurate and easy. I ended up with disabling UAC even though I didn't want to.
SONightHawkCommented:
Too bad that you felt the need to be so snide about your comment, that definitely won't get you much help in the future when you attempt to slam people trying to help.  

And this version was based off of both Vista and Windows 7 as this is and was our solution to something similar and didn't require us to disable the UAC in anyway, along with GPO restrictions set in place ontop of that.

But, good luck with that and wish you the best. Good day.
itniflProgrammerAuthor Commented:
I appreciate your comment SONightHawk. Thank you for taking time to help out.
It's more than this solution.Get answers and train to solve all your tech problems - anytime, anywhere.Try it for free Edge Out The Competitionfor your dream job with proven skills and certifications.Get started today Stand Outas the employee with proven skills.Start learning today for free Move Your Career Forwardwith certification training in the latest technologies.Start your trial today
OS Security

From novice to tech pro — start learning today.