Exchange Hot fix KB924334

We encountered an issue with access OWA via the our new citrix environment (Xenapp), whereby when composing an new email or replying to an email the body of the message would be greyed out and have red X next to it. Our support company recommended to install Exchange Hot fix KB924334 to resolve this issue which worked, as tested on our test environment.

However we had to test out the backup process to test the uninstalled process of the hotfix, which  removed fine. Then I re-installed hot fix again to keep it consistence with the rest of the Exchange servers, neverthless once the install was completed and rebooted the server, then I failed over the Exchange virtual server to that Exchange backend server which I had re-installed the hot fix and found out when I tried to access any mailboxes on that Virtual server it woud come up stating "trying to connect to the <name of the Exchange virtual server>" and just stays there, also tried to access the mailbox via OWA and it just hangs after entering your AD credentials and password.

However when I fail over the Exchange virtual server to another Exchange back end server which I haven't re-installed the hot fix on and it works fine!

Tried to reinstall the Exchange SP2 to see if that might resolve the problem but it fail during the setup process, as show in the attached screenshot.  

Error-screenshot.doc Error-screenshot.doc

Exchange Environment:-

4 Node Cluster environment (Active/Passive)
2 Exchange Front end.


Any ideas how to resolved this issue?

Regards

Aamir

LVL 1
Barnardos_2LSAsked:
Who is Participating?
I wear a lot of hats...

"The solutions and answers provided on Experts Exchange have been extremely helpful to me over the last few years. I wear a lot of hats - Developer, Database Administrator, Help Desk, etc., so I know a lot of things but not a lot about one thing. Experts Exchange gives me answers from people who do know a lot about one thing, in a easy to use platform." -Todd S.

Shreedhar EtteTechnical ManagerCommented:
Hi,

To Fix the error Refer the below article:
http://geekswithblogs.net/colinbo/archive/2006/01/27/67345.aspx

To Get the latest MSXML Refer this URL:
http://www.microsoft.com/downloads/en/details.aspx?FamilyID=28494391-052b-42ff-9674-f752bdca9582&displaylang=en

Note: Download msxml3.msi

After doing the above changes try to reintall the Exchange 2003 SP2.

Hope this helps,
Shree

Experts Exchange Solution brought to you by

Your issues matter to us.

Facing a tech roadblock? Get the help and guidance you need from experienced professionals who care. Ask your question anytime, anywhere, with no hassle.

Start your 7-day free trial
Barnardos_2LSAuthor Commented:
Thank you.
It's more than this solution.Get answers and train to solve all your tech problems - anytime, anywhere.Try it for free Edge Out The Competitionfor your dream job with proven skills and certifications.Get started today Stand Outas the employee with proven skills.Start learning today for free Move Your Career Forwardwith certification training in the latest technologies.Start your trial today
Exchange

From novice to tech pro — start learning today.