Windows Server 2008 Mapped GPo Drive

SirusComputers
SirusComputers used Ask the Experts™
on
Hey Everyone,

 On my active directory enviornment... I have users linked to a U drive which is there personal space to put documents and pics. Also i have folder redirection for my docs, pics, and desktop. One of the users was having issues with her my docs. Sometimes it would sync and other times it wouldnt. Anyways i decided to delete the folder and reconenct again. Now her U:\ drive says its disconnected. The U: Drive is mapped in GPO and is set to be configured to the folder of their user name. So i have a root folder users and then the subfolders are their user names. For some reason it wont connect. Im stumped. Thanks
Comment
Watch Question

Do more with

Expert Office
EXPERT OFFICE® is a registered trademark of EXPERTS EXCHANGE®

Commented:
Have you checked the permission on the folder?

Are you using Group Policy Preferences to Mapp the drive?
What are the settings on the policy? Update, Create, Delete.

Author

Commented:
The settings on the policy are update.

Author

Commented:
Ok for some reason now... When you log on her account. You can see the U:\ drive however, anything you save to the U drive isnt showing up in her folder on the server. It seems the two arent syncing and folder redirection for her account isnt working.
Learn Ruby Fundamentals

This course will introduce you to Ruby, as well as teach you about classes, methods, variables, data structures, loops, enumerable methods, and finishing touches.

Commented:
From a command prompt type "net use" and see where the U drive is mapping to. Verify the path is correct.

Author

Commented:
I dont think the mapping is the issue. All my other users on the network work fine. Where do i type net use... what pc?

Commented:
On the users pc that is having the problem.

Author

Commented:
ok i did it on her pc and everything is mapped correct. This has to be a security issue on her folder.

Author

Commented:
Im stumped. I have no idea what to do... On her folder... if i go to security... it allowes me to view it. Any other users folder i go to check... It will tell me you have to be an admin to view the the settings for this folder. (This is from the server) I hit continue and i can view everything. What is causing the difference between the two scenarios? It seems when folder redirection was first enables it changed the security on the folders so only that user can see their mydocuments which is fine however, the admin on the server cant view them either.

Commented:
Did you make sure the user had full control of the folder and all subfolders?

You could move the currect folder out of the share and have the user logon to have it recreated. Then move all the data back in to see if that fixes it.

Author

Commented:
I tried all of that... But it does not recreate the shared folder. Is that because the GPO for the mapped drive is set for update and not create?

Author

Commented:
In my GPO for folder redirection... This is how i have it set up for the target.

Settings: Basic Redirection
Target Folder Location: Create a folder for each user under the root path
Target: \\SKL-SERVER\SK NJ Users\

All the other users in my network are working fine with this folder redirection, however my one user is having an issue. Originally what happened was i deleted the folder in the root path. I recreated the folder and the user can see the folder on their Windows 7 client but nothings gets synced between the client and the server. So they aren't talking correctly. What am i doing wrong?

Author

Commented:
Now i have a mapped network drive for that folder.  For the U drive which is where the my documents are stored.   Here is the target path i have

Location: \\SKL-SERVER\SK NJ Users\%logonuser%
Reconnect: Checked off
Show this drive  is checked as well.

What am i doing wrong?

Commented:
Can the user access this path from explorer
replace %logonuser% with the users login name

\\SKL-SERVER\SK NJ Users\%logonuser%

Author

Commented:
After reading online ...What i did was originally was Server 2008 Grants the user exclusive rights to that particular folder. Now what i did was i took ownership of that folder as admin. After that happened thats when these issues started happening.. So for this reason... I deleted the folder and recreated the users folder in the root directory however,  how do i get the server to grant access to that new folder? I feel its locked on the old folder and it cant find it.

Author

Commented:
Any suggestions?

Commented:
When you took ownership did you set the NTFS permissions so the user had full control?
Does the user have full control now?
Is the folder redirect looking for a subfolder that does not exists?
How does the folder normally get created for a new user? Is there a setting on thier account for thier U drive or is it all done through GPO?

Author

Commented:
The folder gets created in there only if create it manual. Obviously i realize this isnt the best way to do it. How do i set this to automatic?

Author

Commented:
The folder only gets created in the root directory only if i create it manually. Obviously i realize this isn't the best way to do it. How do i set this to automatic?
Commented:
There are a few ways you can do this.
1. If you create users manually - in their user profile set the home drive to U: and the path to
\\server\share\%username%
When you use %username% it will automatically create and secure the users folder.
2. Use xcacls and mkdir to create and secure the users folder.

http://support.microsoft.com/kb/318754

Author

Commented:
so if i have that set on the user on their names...should i remove the U drive from the GPO policy?

Commented:
You can have it in both. But I would only use it in one or the other not both. It will be easier to troubleshoot if something is not working.

Author

Commented:
alright ...i will give that a shot.
Awarded 2009
Top Expert 2010

Commented:
This question has been classified as abandoned and is being closed as part of the Cleanup Program. See my comment at the end of the question for more details.

Do more with

Expert Office
Submit tech questions to Ask the Experts™ at any time to receive solutions, advice, and new ideas from leading industry professionals.

Start 7-Day Free Trial