Exchange 2007 - AutoDiscover Service not working and OOF

rha_mtl
rha_mtl used Ask the Experts™
on
I need help with Exchange AutoDiscover and my outr of office assistant

The primary issue is that when I open Out of Office assistant I get: "Your out of office settings cannot be displayed,because the server is unavailabe, try again later."...

When I test my autoconfiguration from outlook 2007, almost all the tests fail.. yet the url in the test appear to be correct.

Brief description of my setup..

1. Windows 2003 sp2 Exchange 2007 SP3 (all server roles on one server)
2. Windows assigned cert
3. All "services" are installed under the default web site
4. DNS entries for autodiscover setup for internal fqdn domain name
Any help would be very much appreciated.

I have read many blogs and posts and have not yet successfully resolved this issue& Please help :)

Thank you
Antonio
Comment
Watch Question

Do more with

Expert Office
EXPERT OFFICE® is a registered trademark of EXPERTS EXCHANGE®
On the Outlook Client Try the running the Test Email Auto Configuration by Unchecking the Use Guessmart & Sercure Guessmart Authentication.
Click on the Log Tab and provide the Error Code that you are getting. (or the Screen Shot for the Same - SCP Object)
 
On the Exchange Server open the Exchange Management Shell and run the following command.
Test-OutlookWebServices | fl
And provide the Output for the same.

Author

Commented:
Please see attached file for results of test email configuration


Below is the result for Test-OutlookWebServices | fl  

Id      : 1003
Type    : Information
Message : About to test AutoDiscover with the e-mail address Administrator@rha.ca.

Id      : 1007
Type    : Information
Message : Testing server rha-exchange1.rha-dc.mtl.rha.ca with the published name https://webmail.rha.ca/EWS/Exchange.asmx & https://webmail.rha.ca/EWS/Exchange.asmx.

Id      : 1019
Type    : Information
Message : Found a valid AutoDiscover service connection point. The AutoDiscover URL on this object is https://webmail.rha.ca/.

Id      : 1013
Type    : Error
Message : When contacting https://webmail.rha.ca/ received the error The remote server returned an error: (401) Unauthorized.

Id      : 1006
Type    : Error
Message : The Autodiscover service could not be contacted.
test-email.png
Introduction to R

R is considered the predominant language for data scientist and statisticians. Learn how to use R for your own data science projects.

the issue that we are experiencign is with the Autodiscover Virtual Directory fails to contact the SCP(Service Connection Point) Object, inturn the URL's for EWS is not retured to the Outlook
Check the Authentication on the Autodiscover Virtual Directory from IIS it has to be Basic + Windows Integrated (Right-click on Windows  Integrated  - Check Kernel Mode Authentication is disabled) - Make sure that there is "NO" HTTP Redirection is enabled - SSL has to be enabled with Ignore Client Certificate
Check with the Authentication on EWS Vdir - it has to be Windows Integrated only, then Right-click on Windows  Integrated  - Check Kernel Mode Authentication is disabled - Make sure that there is "NO" HTTP Redirection is enabled - SSL has to be enabled with Ignore Client Certificate
Then Recycle the Autodiscover AppPool and WebServices AppPool - from IIS-ApplicationPool
Then try executing the Test-Email Autoconfiguration from Outlook-2007
Take Back-up of IIS7
then Delete and Recreate the Autodiscover Virtual Directory using the following Commandlets
>>Get-Autodiscovervirtualdirectory |fl (Make a note of the identity)
>>Remove-Autodiscovervirtualdirectory -Identity <Identity of the Autodiscover Vdir>
>>New-Autodiscovervirtualdirectory
then Restart the IIS-Service
Then try executing the Test-Email Autoconfiguration from Outlook-2007 - if it contacts the SCP then its working fine
if not try following - http://support.microsoft.com/kb/896861
Thanks.

Author

Commented:
I did all the steps as you suggested and even followed the article on microsft and i still do not have it working.

Author

Commented:
What I did is the following
I added autodiscover to the DNS of our public ip on our internal dns server. So basically autodiscover.rha.ca and it seems to work although i get a certificate error saying that the name on the certificate is not the same. When I click yes I get the following in the test email configuration

This is the results

test-email-log.png
test-email-results.png
Please follow this article.
http://support.microsoft.com/kb/940726
 
In your certificate you need to have the following names:
mail.yourdomain.com
autodiscover.yourdomain.com
internalFQDNofYourExchangeServer

also run the following in EMS:

Set-AutodiscoverVirtualDirectory –Identity ‘ExchangeServerName\autoDiscover (Deafult Web Site)’ –ExternalUrl https://Autodiscover.domain.com/autodiscover/autodiscover.xml 
 
Set-AutodiscoverVirtualDirectory –Identity ‘ExchangeServerName\autoDiscover (Deafult Web Site)’ -internalurl https://autodiscover.domain.local/autodiscover/autodiscover.xml 

and for futuristic advice, when you do an iisreset in cmd that is considered a hard reset, in the future you should do iisreset /noforce,

cheers

Author

Commented:
The issue was I had to put in the fqdn name of the machine and it worked in the autodiscover filed and set the clien access server to that name.
didnt check your kbaste article properly AshwinRaj111, apologies for posting the same answer

Author

Commented:
Since I have done this change I have 1 ipaq and android phone taht will no longer sync. I see the following error message

Your account in Microsoft Exchange Server does not have permission to synchronize with your current settings, Contact your exchange server Administrator.

Should i open a new question for this issue?
rha_mtl,

if it is only for one user and no others the issue isnt most likely server related, could you try recreating the profile on the mobile devices and try again ?
For the same user see if you can create a profile in a Windows Mobile Device or Windows Emulator.
If it works then it is a Configuration problem in the Andriod or IPOD.

Do more with

Expert Office
Submit tech questions to Ask the Experts™ at any time to receive solutions, advice, and new ideas from leading industry professionals.

Start 7-Day Free Trial