Reporting Service

jaljahmi
jaljahmi used Ask the Experts™
on
I'm struggling setting up reporting service 2008 with sql server 2005 also installed. It appears that 2008 reporting service has changed to where it doesn't create virtual directories. I'm struggling to understand the difference between 2005 and 2008 and how to configure 2008. Right now when I try to deploy the report it goes to the virtual path of 2005. I would appreciate any help or if you can point me in the right direction.

Jamal
Comment
Watch Question

Do more with

Expert Office
EXPERT OFFICE® is a registered trademark of EXPERTS EXCHANGE®

Commented:
I think we need more information here.  If you install SSRS on SQL 2005, you only get 2005 Reporting services.  If you install SSRS on SQL 2008, you get 2008 reporting services.  The reporting services can talk to any version of SQL server or other data sources to get the information you are reporting on.  SSRS 2008 does not use IIS as a delivery mechanism (SSRS 2000 and SSRS 2005 do), so it does not create virtual directories and does not need an IIS installation on the server.

Commented:
If you need help on a SSRS 2008 install, you may want to review this video as a good starting place:

http://sql-articles.com/blogs/installing-sql-server-reporting-services-2008/

Author

Commented:
To clarify. I did install 2008 reporting services with sharepoint intergration. Now I'm working on creating reports. The report build fine and I'm able to view the data. The problem is when I deploy it fails. It has something do do with the way I'm pointing the target information in report property. In the past with SSRS 2005 install, I would point to the virtual directory in IIS and that would be fine but I'm missing something in SSRS 2008

Also, Thanks for the video link. I wish there is a similar video and report setup and deployment.

Jamal
Commented:
You should go to something like this:
http://servername/Reports/Pages/Folder.aspx

I don't have any sharepoint integration, but this is the url for my 2008 SSRS server.

Author

Commented:
The problem was caused by sharepoint integration I re-installed reporting service in native mode and was able to get it working. Thanks for your help.

Do more with

Expert Office
Submit tech questions to Ask the Experts™ at any time to receive solutions, advice, and new ideas from leading industry professionals.

Start 7-Day Free Trial