Adding QOS to Cisco 1720 Router for SIP traffic over Metro-Lan

leemae85
leemae85 used Ask the Experts™
on
Hello, basically we recently instituted a SIP telephony system.  Now we have not upgraded our phones yet so the phones are not working through IP but each phone system at the remote and main locations are working through SIP.

Basically at location A I have the main telephone system.  The telephone systems at B and C have their own external lines, or go through our Metro-Ethernet Circuit in order to extension dial from telephone system B to telephone system A.  The problem I am having is that calls are getting dropped because of shared internet traffic.

Is there a way that I can put in QOS statements on the routers at location B and C to prioritize all traffic coming from their respective telephone system and to their respective telephone system (From A) so that calls will not drop or lose voice signal.
Comment
Watch Question

Do more with

Expert Office
EXPERT OFFICE® is a registered trademark of EXPERTS EXCHANGE®
Jody LemoineNetwork Architect

Commented:
There are different things you can do QoS-wise with these routers, depending on your IOS version and feature set.  Can you post the output of a "show version" command from this router?  Based on this, I'm sure I can provide some recommendations.

Author

Commented:

Chesapeake>enable
Password:
Chesapeake#sh version
Cisco Internetwork Operating System Software
IOS (tm) C1700 Software (C1700-Y-M), Version 12.2(4)YA2, EARLY DEPLOYMENT RELEASE SOFTWARE (fc1)
Synched to technology version 12.2(5.4)T
TAC Support: http://www.cisco.com/tac
Copyright (c) 1986-2002 by cisco Systems, Inc.
Compiled Thu 11-Apr-02 21:54 by ealyon
Image text-base: 0x80008124, data-base: 0x807976DC

ROM: System Bootstrap, Version 12.2(7r)XM1, RELEASE SOFTWARE (fc1)
ROM: C1700 Software (C1700-Y-M), Version 12.2(4)YA2, EARLY DEPLOYMENT RELEASE SOFTWARE (fc1)

Chesapeake uptime is 2 weeks, 4 days, 4 hours, 56 minutes
System returned to ROM by power-on
System image file is "flash:c1700-y-mz.122-4.YA2.bin"

cisco 1721 (MPC860P) processor (revision 0x100) with 29492K/3276K bytes of memory.
Processor board ID FOC06220SPY (1452048963), with hardware revision 0000
MPC860P processor: part number 0, mask 32
Bridging software.
X.25 software, Version 3.0.0.
1 FastEthernet/IEEE 802.3 interface(s)
1 Serial network interface(s)
WIC T1-DSU
32K bytes of non-volatile configuration memory.
16384K bytes of processor board System flash (Read/Write)

Configuration register is 0x2102

Chesapeake#

Author

Commented:
Chesapeake#sh run
Building configuration...

Current configuration : 539 bytes
!
version 12.2
service timestamps debug uptime
service timestamps log uptime
no service password-encryption
!
hostname Chesapeake
!
enable password 83susej
!
ip subnet-zero
!
!
!
!
interface FastEthernet0
 ip address DDD.DDD.DDD.DDD 255.255.255.224
 speed auto
!
interface Serial0
 ip address CCC.CCC.C.C 255.255.255.252
!
ip classless
ip route 0.0.0.0 0.0.0.0 AAA.AAA.A.A
ip route BBB.BB.BBB.B 255.255.255.128 AAA.AAA.A.A
no ip http server
!
!
!
line con 0
 exec-timeout 0 0
line aux 0
line vty 0 4
 no login
!
no scheduler allocate
end
Should you be charging more for IT Services?

Do you wonder if your IT business is truly profitable or if you should raise your prices? Learn how to calculate your overhead burden using our free interactive tool and use it to determine the right price for your IT services. Start calculating Now!

Author

Commented:
All traffic going to 10.10.0.0 local network needs QOS because all of that traffic will be TCP telephony traffic.

Route for inter-office telephony calls

NEC SIP -> Cisco1720 -> MetroLAN -> Cisco ASA 3560 ->Cisco ASA 3560 -> NEC SIP (MAIN)
Network Architect
Commented:
The NEC SIP phones mark their traffic with DSCP values to indicate that their traffic should be prioritized, which makes things easy for the router.  They use DSCP value CS6 for their call signalling and DSCP value EF for the actual voice traffic.  We can configure the router to prioritize these above normal traffic as follows:

class-map match-any VoIP.Signal
 match ip dscp cs6
class-map match-any VoIP.RTP
 match ip dscp ef
!
policy-map VoIP
 class VoIP.Signal
    priority percent 5
 class VoIP.RTP
    priority percent 70
 class class-default
    fair-queue
     random-detect
!
interface FastEthernet1 (or whatever your MetroLAN-facing interface is)
 service-policy output VoIP
Qlemo"Batchelor", Developer and EE Topic Advisor
Top Expert 2015

Commented:
This question has been classified as abandoned and is being closed as part of the Cleanup Program.  See my comment at the end of the question for more details.

Do more with

Expert Office
Submit tech questions to Ask the Experts™ at any time to receive solutions, advice, and new ideas from leading industry professionals.

Start 7-Day Free Trial