Why is IAXmodem not registering

shawnz-1voice
shawnz-1voice used Ask the Experts™
on
I just installed IAXmodem on our Asterisk server and when I start the modem it will not register. I have included output and config information below.

# /usr/src/iaxmodem-1.2.0/iaxmodem ttyIAX0
[2010-10-19 11:43:23] Modem started
[2010-10-19 11:43:23] Setting device = '/dev/ttyIAX0'
[2010-10-19 11:43:23] Setting owner = 'uucp:uucp'
[2010-10-19 11:43:23] Setting mode = '660'
[2010-10-19 11:43:23] Setting port = 4570
[2010-10-19 11:43:23] Setting refresh = 300
[2010-10-19 11:43:23] Setting server = 'x.x.x.x'
[2010-10-19 11:43:23] Setting peername = '8603'
[2010-10-19 11:43:23] Setting secret = 'xxxxx'
[2010-10-19 11:43:23] Setting cidname = 'xxxxx'
[2010-10-19 11:43:23] Setting cidnumber = 'xxxxx'
[2010-10-19 11:43:23] Setting codec = ulaw
[2010-10-19 11:43:23] Opened pty, slave device: /dev/pts/3
[2010-10-19 11:43:23] Created /dev/ttyIAX0 symbolic link
[2010-10-19 11:43:23] Registration failed.

# cat /etc/asterisk/iax_additional.conf
[8603]
deny=0.0.0.0/0.0.0.0
secret=xxxxxx
transfer=no
context=from-internal
host=dynamic
type=friend
port=4570
qualify=yes
dial=IAX2/8603
mailbox=8603@device
permit=0.0.0.0/0.0.0.0
callerid=device <8603>
setvar=REALCALLERIDNUM=8603


# cat /etc/iaxmodem/ttyIAX0
device          /dev/ttyIAX0
owner           uucp:uucp
mode            660
port            4570
refresh         300
server          x.x.x.x
peername        8603
secret          xxxxxx
cidname         xxxxxx
cidnumber       xxxxxx
codec           ulaw


Can anyone help determine what the cause may be or where to start looking.

Thank you in advance.

DZ
Comment
Watch Question

Do more with

Expert Office
EXPERT OFFICE® is a registered trademark of EXPERTS EXCHANGE®
I wonder about the server ip address. It should be 127.0.0.1 which you really should not have had to hide which makes me wonder about it. However assuming that is correct, use "iax2 set debug" and then a "iax2 reload" and capture the messages. This should tell us where the problem is. Alternatively you could look at the /var/log/asterisk/full to see if you can see a error message when it tries to connect.

Author

Commented:
Thank you jfaubiontx for your response.

You're right, I didn't have to hide the server IP, although it wasn't set to local host, it was set to NIC's IP. I'm not sure if that makes a difference, but I did change it to local host.

Here is the capture from iax2 debug:

 == Parsing '/etc/asterisk/iax.conf':   == Found
  == Parsing '/etc/asterisk/iax_general_additional.conf':   == Found
  == Parsing '/etc/asterisk/iax_general_custom.conf':   == Found
  == Parsing '/etc/asterisk/iax_registrations_custom.conf':   == Found
  == Parsing '/etc/asterisk/iax_registrations.conf':   == Found
  == Parsing '/etc/asterisk/iax_custom.conf':   == Found
  == Parsing '/etc/asterisk/iax_additional.conf':   == Found
  == Parsing '/etc/asterisk/iax_custom_post.conf':   == Found

I did view the log file and found this entry:

chan_iax2.c: Call rejected, CallToken Support required. If unexpected, resolve by placing address 172.16.1.10 in the calltoken
optional list or setting user 8603 requirecalltoken=no

I disabled calltoken support for the user and now the iaxmodem registers successfully.

Thank you very much for your help!!

Do more with

Expert Office
Submit tech questions to Ask the Experts™ at any time to receive solutions, advice, and new ideas from leading industry professionals.

Start 7-Day Free Trial