Android/Blackberry issues SBS 2003

Primenet
Primenet used Ask the Experts™
on
Run a SBS2003 server as a virtual. Had an issue with the virtual C drive on that server. Ended up taking a copy of the VHD from a month prior and using that disk as the C drive. It allowed the server to start up fine. Course the other servers and workstations that were in the domain had be disjoined and rejoined to the domain because active directory was out of sync on the domain. (The SBS server is the only domain controller)
The user data on that server was stored in other virtual disk files. So the exchange databases, shared user data folders were not affected by the issues.
It worked pretty good and seemed to get the customer back up and running. We only had one issue, which is that Blackberry, Android and Iphones stopped working with activesync. Owa is still working fine. (They have a self signed cert)
Tested it with exchange connectivity test online and it gave me this.

 ExRCA is testing Exchange ActiveSync.  
  The Exchange ActiveSync test failed.
   Test Steps
   Attempting to resolve the host name mail.customer.us in DNS.
  Host successfully resolved
   Additional Details
  IP(s) returned: 65.219.xx.xx
 
 Testing TCP Port 443 on host mail.alphallc.us to ensure it is listening and open.
  The port was opened successfully.
 ExRCA is testing the SSL certificate to make sure it's valid.
  The certificate passed all validation requirements.
   Test Steps
   The certificate name is being validated.
  Successfully validated the certificate name
   Additional Details
  Found hostname mail.customer.us in Certificate Subject Common name
 
 The certificate date is being confirmed to ensure the certificate is valid.
  Date validation passed. The certificate hasn't expired.
   Additional Details
  Certificate is valid: NotBefore = 5/4/2008 3:49:34 AM, NotAfter = 5/4/2013 3:49:34 AM"
 
 
 The IIS configuration is being checked for client certificate authentication.
  Client certificate authentication wasn't detected.
   Additional Details
  Accept/Require Client Certificates not configured.
 
 Testing Http Authentication Methods for URL https://mail.customer.us/Microsoft-Server-Activesync/ 
  The HTTP authentication methods are correct.
   Additional Details
  Found all expected authentication methods and no disallowed methods. Methods Found: Basic
 
 An ActiveSync session is being attempted with the server.
  Errors were encountered while testing the ActiveSync session
   Test Steps
   ExRCA is attempting to send the OPTIONS command to the server.
  OPTIONS response was successfully received and is valid
   Additional Details
  Headers received: MicrosoftOfficeWebServer: 5.0_Pub
Pragma: no-cache
Public: OPTIONS, POST
Allow: OPTIONS, POST
MS-Server-ActiveSync: 6.5.7638.1
MS-ASProtocolVersions: 1.0,2.0,2.1,2.5
MS-ASProtocolCommands: Sync,SendMail,SmartForward,SmartReply,GetAttachment,GetHierarchy,CreateCollection,DeleteCollection,MoveCollection,FolderSync,FolderCreate,FolderDelete,FolderUpdate,MoveItems,GetItemEstimate,MeetingResponse,ResolveRecipients,ValidateCert,Provision,Search,Notify,Ping
Content-Length: 0
Date: Tue, 19 Oct 2010 17:01:55 GMT
Server: Microsoft-IIS/6.0
X-Powered-By: ASP.NET

  ExRCA is attempting the FolderSync command on the Exchange ActiveSync session.
  The test of the FolderSync command failed.
   Tell me more about this issue and how to resolve it
   Additional Details
   Exchange ActiveSync returned an HTTP 500 response.

The supported fix is the link below. But the exchange-oma virtual folder is already setup since it's SBS. But I did double check all of the settings they were correct. http://support.microsoft.com/?kbid=817379
Comment
Watch Question

Do more with

Expert Office
EXPERT OFFICE® is a registered trademark of EXPERTS EXCHANGE®
Co-Owner
Top Expert 2011
Commented:
KB883380 is the usual fox for HTTP error 500.  Method 2 usually works a treat : )
If that fails, please have a read of my Exchange 2003 / Activesync article and shout if you get stuck:
http://www.experts-exchange.com/Software/Server_Software/Email_Servers/Exchange/A_1798-Exchange-2003-Activesync-Connection-Problems-FAQ.html 
Awarded 2009
Top Expert 2010

Commented:
This question has been classified as abandoned and is being closed as part of the Cleanup Program. See my comment at the end of the question for more details.

Do more with

Expert Office
Submit tech questions to Ask the Experts™ at any time to receive solutions, advice, and new ideas from leading industry professionals.

Start 7-Day Free Trial