E-mail error within ACT on Citrix (virtal desktops)

mjburgard
mjburgard used Ask the Experts™
on
This is kind of a broad scale question and I'm not really sure if I'll be able to explain it enough to get an answer, but I'm trying everything I can right now.

Our company (mainly our sales people) use ACT by Sage.  ACT can be connected to Outlook so that within ACT you can attach documents to e-mail and so on.  Starting just a few days ago when people attempt to do this (any of the multiple ways it can be done) they get the following error: "Attempted to read or write protected memory. This is often an indication that other memory is corrupt."

I've talked to ACT tech support and after a few other things we tried the first item on this site ACT support.  Instead of the expected response I get the following: "DllRegister Server in redemption.dll failed.  Return code was: 0x80004005"

ACT support identified this as a permissions error and said there wasn't anything on there end they could do.  I started to look around our Citrix server and our database manager server.  There was nothing I change since the issue started so I was digging to see if I could find something else.

I didn't manage to find anything directly, but I have a event log monitor set up that emails me any of a set number of events when they happen on any of the servers.  I don't know if I have it set up to watch everything I want watched but that's besides the point right now.  Normally I don't get much except notifications of user account password changes or servers restarting.  However on Monday I got an e-mail with multiple events on our database manager server that I'm not really sure about, but that seem like they might be related to the issue.  There's about seven events with the ID 514 and four with the ID 518.

514   An authentication package has been loaded by the Local Security Authority. This authentication package will be used to authenticate logon attempts. Authentication Package Name: C:\WINDOWS\system32\LSASRV.dll : Negotiate

The file after system32 is different for each event but everything else is the same.

518 An notification package has been loaded by the Security Account Manager. This package will be notified of any account or password changes. Notification Package Name: KDCSVC

Again the package name is different for each event but everything else is the same.


These might not be related at all but its the only connection I can find between the time that the e-mail attach function worked and when it stopped.  I'll take any advice I can get on this would be great, even if it goes in a completely different direction then I have been going.  Thanks for the help.
Comment
Watch Question

Do more with

Expert Office
EXPERT OFFICE® is a registered trademark of EXPERTS EXCHANGE®
Hi,

Looks like the user is not able to register some outlook dll file. Sounds more like a permission issue. It would be better if you install both Outlook and act in a different drive say D:\Program files (not on C drive). Grant access to everyone on that drive. Many Applications dont work due to permission restrictions for users on C Drive.

-Sunil
On sec thought, Have you tried repairing/re-installing Outlook or MS Office ? The dll files might be corrupt.

-Sunil

Author

Commented:
Repairing outlook fixed the problem.  Took us awhile to get a chance to do it since we have so many different people logging onto the server which is why it took me this long to respond.  Thanks for the help.

Author

Commented:
Solved

Do more with

Expert Office
Submit tech questions to Ask the Experts™ at any time to receive solutions, advice, and new ideas from leading industry professionals.

Start 7-Day Free Trial