SharePoint 2010 - WebParts not showing up?

Greetings, all!

I haven't had much experience with end-user SharePoint 2010 training, but I did have a question.

When I create a new page, say a "Team Site", within SharePoint 2010...
And go to "Edit Page"...
And under "Editing Tools", I select "Insert"...
And then click "Web Part"...

The only category of web part that shows up is the "Lists and Libraries" web part, which only shows me the lists and libraries that are created on this site (announcements, calendar, links, shared documents, etc).

I am trying to find out how to add a Content Editor Web Part, or some form of Rich Text web part (which in 2007 was part of what the CEWP had the capability to do).  

The problems stemmed from when I created an Enterprise Wiki site collection, and added an sub site as an Enterprise wiki.  The sub site has only one area to modify, which allows the typing of rich text and the inserting of web parts (which again, only come from the "Lists and Libraries" category).  

However, If i change the layout of the site to include more than one web part zone (using Edit Page > Page tab > Page Layout > Blank Web Part Page), there is no place to type text...the web part zones have "Add A Web Part", yet the only web parts that show up are the ones within the "Lists and Libraries" category.

Anyone know what's going on here?
LVL 6
ThatSharepointGuyAsked:
Who is Participating?
I wear a lot of hats...

"The solutions and answers provided on Experts Exchange have been extremely helpful to me over the last few years. I wear a lot of hats - Developer, Database Administrator, Help Desk, etc., so I know a lot of things but not a lot about one thing. Experts Exchange gives me answers from people who do know a lot about one thing, in a easy to use platform." -Todd S.

ramuar1981Commented:
content editor webpart in sharepoint 2010

media and content -> content editor.
ThatSharepointGuyAuthor Commented:
Thank you for your response.

However, this is not what I'm looking for.  I do not have the "Media and Content" category!

I've added a screenshot so that you can see what I'm talking about.
Only the "Lists and Libraries" category is available...nothing else.

This is on an Enterprise Wiki site collection and subsites.  Does the Enterprise Wiki not allow the user of other categories of web parts, even on blank web part pages?



help.jpg
Angular Fundamentals

Learn the fundamentals of Angular 2, a JavaScript framework for developing dynamic single page applications.

ThatSharepointGuyAuthor Commented:
Got it.  Needed to go to the Site Collection, and the site, and enable the SharePoint Server Enterprise/Standard Site Features.  That then gave a list of categories for web parts other than "Lists and Libraries".

Why this was off by default on the site, I have no idea!  But it works now!

Experts Exchange Solution brought to you by

Your issues matter to us.

Facing a tech roadblock? Get the help and guidance you need from experienced professionals who care. Ask your question anytime, anywhere, with no hassle.

Start your 7-day free trial
dwpmartinCommented:
This is not correct.  I am experiencing the same problem but when I look the features mentioned are enabled.
ThatSharepointGuyAuthor Commented:
dwpmartin...

Just because something does not work for you does not mean that it is not correct.  

This worked for me at the time that I posted my question.

I have however, a few weeks ago, encountered the issue again.  And in this case, both features were enabled and running on that site collection, yet "Lists and Libraries" was the only available option choice for Web Parts.

If I were you, I'd open up a question, referencing this one, stating that this does not work for you and request further troubleshooting ideas.

Cheers,
TSG
dwpmartinCommented:
If you give the user account the abilitly at the site collection level then the webparts show up in the site.  
ThatSharepointGuyAuthor Commented:
Can you elaborate?  Give the user account (I guess in my case, the SP administrator account) what ability at the site collection?  "Site Collection Administrator"?  "Owner"?  Set "Full Control" on the site for just the specific user account?

None of that worked for me, which was why I originally created this Question.
dwpmartinCommented:
No.  If you have a user (jdoe) and you have given him owner rights to the site he cannot add all the webparts until he is an owner at the parent (site collection) .  I was able to reproduce this.
ThatSharepointGuyAuthor Commented:
That's interesting, because I was unable to get it to work that way.  I was signed in to my account, which is a Site Collection Administrator in Central Administration for that Site Collection, and the sub site was inheriting permissions from the site collection.  After it didn't work, I also went in and broke permissions so that the sub site had it's own unique permissions, with my account in the owner's group, and still didn't have a workaround.

It's interesting because I WAS able to reproduce the issue with the features.
dwpmartinCommented:
I would say this is a bug and the security is not working as one would expect.  I would personally like to see security around web parts (granular) so that I can control what users create.
It's more than this solution.Get answers and train to solve all your tech problems - anytime, anywhere.Try it for free Edge Out The Competitionfor your dream job with proven skills and certifications.Get started today Stand Outas the employee with proven skills.Start learning today for free Move Your Career Forwardwith certification training in the latest technologies.Start your trial today
Microsoft SharePoint

From novice to tech pro — start learning today.