New Exchange 2010 server - error receiving emails

Hi guys,

I just set up a new Exchange Server 2010 on a new Windows Server 2008 box that I am getting ready for deployment. I've finished setting up the MX record for @seemysetup.com, and set up the port forwarding on the router, and my SMTP test checked out properly.

But upon trying to send an email to the main user, "Administrator@seemysetup.com" via my hotmail account, I get an error. The log is shown below:

OK, connected to kleincs.dyndns.org...
< 220 Venom.kleincs.local Microsoft ESMTP MAIL Service ready at Tue, 19 Oct 2010 15:49:11 -0400
> HELO edit.dnsvr.com
< 250 Venom.kleincs.local Hello [64.85.73.124]
> MAIL FROM:<frosty555_@hotmail.com>
< 530 5.7.1 Client was not authenticated

I went into the receive connector and saw that I have two records in there:

"Client VENOM"
"Default VENOM"
(venom is the name of the server)

Inside both receive connectors, the "Anonymous Users" permission group is NOT checked, so anonymous users can't connect.

So my question is: Should I enable this? Will that solve the problem?

And how does this affect the security of my Exchange Server? Why was it disabled by default in the first place? It makes sense that emails from anonymous sources should be allowed in to the exchange server. So if I enable it is my exchange server still safe or is it now open as a conduit for anonymous users to send spam via it?

Lastly, should I enable the "Anonymous Users" permission group for "Client VENOM", or "Default VENOM", or both? What's the difference between the two?
LVL 31
Frosty555Asked:
Who is Participating?
I wear a lot of hats...

"The solutions and answers provided on Experts Exchange have been extremely helpful to me over the last few years. I wear a lot of hats - Developer, Database Administrator, Help Desk, etc., so I know a lot of things but not a lot about one thing. Experts Exchange gives me answers from people who do know a lot about one thing, in a easy to use platform." -Todd S.

Rick FeeMessaging Engineer - Disaster Recovery EngineerCommented:
Yes you are required to enable anonymous on the Default Connector....no need to modify the Client.   This will allow internet users to send to your server
Rick FeeMessaging Engineer - Disaster Recovery EngineerCommented:
Client Servername   This Receive connector accepts SMTP connections from all non-MAPI clients, such as POP and IMAP.

Default Servername   This Receive connector accepts connections from other Hub Transport servers and any Edge Transport servers you have.

Experts Exchange Solution brought to you by

Your issues matter to us.

Facing a tech roadblock? Get the help and guidance you need from experienced professionals who care. Ask your question anytime, anywhere, with no hassle.

Start your 7-day free trial
Rick FeeMessaging Engineer - Disaster Recovery EngineerCommented:
Well the only real way to stop or slow down spam to your users is to put a spam solution in place.    But spammers will not be able to relay off you if that is another question if you set the default connector to anonymous.    
Frosty555Author Commented:
>>But spammers will not be able to relay off you

That's what I was trying to figure out. Awesome thank you for your help
It's more than this solution.Get answers and train to solve all your tech problems - anytime, anywhere.Try it for free Edge Out The Competitionfor your dream job with proven skills and certifications.Get started today Stand Outas the employee with proven skills.Start learning today for free Move Your Career Forwardwith certification training in the latest technologies.Start your trial today
Email Protocols

From novice to tech pro — start learning today.