SBS 2003 RWW - Win 7 Pro workstation

ohioholiday
ohioholiday used Ask the Experts™
on
I have a Windows 7 Professional laptop I'm trying to give access to our RWW application server but it won't work externally.  

*  All XP stations work fine
*  This station can use internal ip or internal computer name via RWW or RDP and it works fine
*  This station can connect via vpn
*  I enabled  RDP port 3389 in Win 7 firewall for all:  Domain/home/any
*  I tried to log into another client's RWW and it worked fine (but they don't have ISA they have basic SBS 2003)
*  User can log into RWW and access everything except the "Company Application Server"

The errror is the common:

---------------------------
Remote Desktop Connection
---------------------------
Remote Desktop can’t connect to the remote computer for one of these reasons:
 
1) Remote access to the server is not enabled
2) The remote computer is turned off
3) The remote computer is not available on the network
 
Make sure the remote computer is turned on and connected to the network, and that remote access is enabled.

Or we get the one about too many connections, or check your firewall settings

We've tried this station at several wireless sites, internally, and on a sprint card - the only way it works is internally with internal ip/name instead of normal rww site.

Comment
Watch Question

Do more with

Expert Office
EXPERT OFFICE® is a registered trademark of EXPERTS EXCHANGE®
Shreedhar EtteTechnical Manager
Top Expert 2010

Commented:
Firmin FrederickSenior IT Consultant

Commented:
I read that article Shreedhar sounds promising and for good measure I'm throwing in:

have you set a NAT rule that points 3389 to the server IP address in your firewall/router?  Same for ISA server really, create a rule that points port 3389 to the server for all inbound traffic and verify that 3389 & remote desktop/terminal services are all enabled on the server i the firewall settings.

Let us know how you get on :)

Author

Commented:
I've had this setup for a few years - all running fine - it's only Windows 7 stations that don't work (pro or ultimate)

Win7 stations can vpn then rdp fine

So the sbs server itself is setup fine - what is specific to win7 that prevents rww/application server?

The error reads "the remote computer disconnected the session due to licensing protocol....."  I've tried multiple win7 stations.
Angular Fundamentals

Learn the fundamentals of Angular 2, a JavaScript framework for developing dynamic single page applications.

Firmin FrederickSenior IT Consultant

Commented:
ah ok glad you said that cuz that's a whole different ball game and Microsoft have lots to say about it lol!


http://technet.microsoft.com/en-us/library/cc756826%28WS.10%29.aspx

Firmin FrederickSenior IT Consultant

Commented:
now i've not had this issue before and I don't have this set up on my server so please, if you attempt the Microsoft fixes I would really appreciate your feedback on how it all went!

Author

Commented:
I have tried all those things already in the Microsoft link.  So no help.  I thought it was because our application server was windows 2000, but win7 can rdp into it.  Also, I tried connecting to client computers via rww with a win7 station and still get the same thing - so it's not a licensing issue - it's something on the win7 stations themselves.  I've tried adding the site to "intranet sites" and also to "trusted sites" - still nothing.
Firmin FrederickSenior IT Consultant

Commented:
http://www.computing.net/answers/windows-2003/sbs2003-remote-web-workplace/3350.htmlhttp://www.computing.net/answers/windows-2003/sbs2003-remote-web-workplace/3350.html

which corroborates my suspicions in that the sbs licensing architecture for rww does not take into account a win7 and i wonder if there is a patch or update available for this?!  Are you using SBS 2003 R2?
Found my own solution:  have to start ie in win7 with "run as administrator" - then it works.
Firmin FrederickSenior IT Consultant

Commented:
dammit I had lots of stuff written prior to that link but the link overwrote it all grrr.

Basically I was targeting SBS 2003 licensing and cals and implying that it may not be win7 compliant, keep in mind that win7 architecture has more stringent and different cal and licensing requirements.

In any event, my offering was that you either put a 2008 server to mimic the application server (indows 2000 server you say?), trying connecting to it first off the domain and then on the domain.  And or try a similar approach with an XP machine off the network or one that was never on the network.

I've not got RWW or Terminal Server set up on my 2008 server so I cannot tell you 100% this will work as the licensing is dictated by your SBS 2003 and that's very dictatorish. But from that link it does show that RWW on SBS 2003 is governed by the sbs architecture
Firmin FrederickSenior IT Consultant

Commented:
ah that simple huh?  never even occured to me that you were using win7 in a non-admin capacity ok well good on you :)

Author

Commented:
Users are admin of their own computer but IE does not run in admin mode by default in win7
Firmin FrederickSenior IT Consultant

Commented:
Ah that's fair enough I always disable UAC so that's probably why I've never noticed IE needing to run in elevation, thanks I'll bear that in mind

Do more with

Expert Office
Submit tech questions to Ask the Experts™ at any time to receive solutions, advice, and new ideas from leading industry professionals.

Start 7-Day Free Trial