Screen size in Ubuntu

Iekos
Iekos used Ask the Experts™
on
Hi guys.

I'm trying Linux for the first time.  Installed Ubuntu and all went well but the screen resolution on my new 1080 Sony Vaio laptop (1920x10180).

The screen res looks very crispy but the right and bottom of the page is out of screen.  When I change the res under system to 1920x1080, it looks very wrong and still the screen on the right and bottom is not visible.

its as if the system thinks my screen is alot bigger then it is?

Is there a way to tell Ubuntu the boders of the screen or something?
Comment
Watch Question

Do more with

Expert Office
EXPERT OFFICE® is a registered trademark of EXPERTS EXCHANGE®
Have you tried downloading Ubuntu 10.10 and run the LiveCD to see if it's the same problem there?
You can set the screen resolution in the menu "System / Settings / Screen".

If you have a nVidia card and driver you can set the resolution and "panning" under "System / Settings / NVIDIA X Server Settings".
JavaScript Best Practices

Save hours in development time and avoid common mistakes by learning the best practices to use for JavaScript.

Author

Commented:
Hi guys, thanks for the comments.

I will try what's is suggested but, Ubuntu wants me to update a device driver for Nvidia and recommends it.  I do this and restart but now it doest show me the desktop at all.

Reinstalled and tried the update again but no luck.

In recovery mode, I can get in via low graphics mode.  Now what?
Have you downloaded the driver from nVidia? Or did you just use the driver that came with Ubuntu? What version of Ubuntu are you using?

Author

Commented:
Ubuntu 10.10

Tried both drivers that Ubuntu wanted to download and new drivers from Nvidia but both cause to display once installed.
You can fix your driver by downloading the latest nVidia driver from nVidias website (you can do this in low graphics mode). Ref: http://www.nvidia.co.uk/

Then enter a command prompt by pressing CTRL+ALT+F1 and login.

Enter your Download directory (or where you downloaded the nVidia driver):

$ cd Downloads

Make the driver executable:

$ chmod +x NVIDIA-Linux-x86-260.19.12.run

Stop X:

$ sudo service gdm stop

Install driver:

$ sudo ./NVIDIA-Linux-x86-260.19.12.run

Follow the instructions to install the driver. You might get some warning messages.

Start X:

$ sudo service gdm start

Switch to X with CTRL+ALT+F7 (this shouldn't be neccesary though!)

Regards, Tobias
Aha. So you always ends up with "low graphics mode"? What type of nVidia card do you have? 32 or 64 bits? Which driver did you download?

Regards, Tobias

Author

Commented:
Hey again,

TobiasHolm, everything you wrote i've done dude.  I dont think youve read everything I'm writing.

I'm on 64bit and the right drivers for a Geforce GT 330 M was downloaded and installed but still, after a reboot, I just get a blank screen.

Again, I get back into the OS only in recovery mode which is low graphics.
I posted ID: 33949931 before I read your post ID: 33949931 (see the time, one minute apart).

I can't see you've mentioned you are using 64 bit OS or GT 330 M in this discussion?

I got the same sympthoms you did (with low graphics mode) and the steps I described above worked for my system (although I use 32 bits OS and nVidia 8800GTS graphics).


Found this thread: http://ubuntuforums.org/showthread.php?t=1561105

"Here's what's required to get Ubuntu 64-bit to run with all systems "go" on my Toshiba A505-S6040, NVIDIA GeForce GT 330M, Intel Core i7, 6GB memory laptop:

- Turn on.
- Hit [C] in GRUB to get a command line.
- Type 'reboot' [ENTER].
- Hit [E] when GRUB returns to edit the default linux command.
- Add 'acpi=off' at the end of the line ending in 'quiet splash'.
- Hit [Ctrl][X] to boot."

Author

Commented:
Hey TobiasHolm,

I'm sorry for getting ratty but I'm now getting frustrated and about to give up :(

Still no luck.  After the driver upgrade to Nvidia either from Ubuntu or from Nvidia, I have a blank screen after grub.

I've been back in low graphics mode and ran Nvidia X Server Settings and I get the following message:

'You do not appear to be using the Nvidia X driver. Please edit your X configuration file (just run 'nvidia-xconfig' as root), and restart X server.'

I did that, restarted but again blank screen :(
Did you try the acpi=off option in Grub?

Nvidia X Server Settings requires that the nVidia driver is loaded correct, that's why you get that message.

Did you get any error/warning messages when installing the nVidia driver? And which driver did you download?
Commented:
UPDATE:

After days and nights, I eventually followed the link provided and the display is now perfect.

Look at comment #77 on this link:
https://bugs.launchpad.net/ubuntu/+source/nvidia-graphics-drivers/+bug/655078

Its a known problem with Nvidia drivers and Ubuntu.  Many Many people are having the same issues.

Thanks for all your guidance.
Top Expert 2015

Commented:
Please attach /etc/X11/xorg.conf and /var/log/Xorg.0.log and dmesg
Some driver tweaking might be needed.

Author

Commented:
After hours and hours of research, I've found the answer on a forum.  Its the drivers by Nvidia that simply dont work.  A script someone created installs some old Nvidia drivers that makes it work.

Do more with

Expert Office
Submit tech questions to Ask the Experts™ at any time to receive solutions, advice, and new ideas from leading industry professionals.

Start 7-Day Free Trial