Remove SMTP address from Exchange 2007 and create new Distribution Group

Telstar-Networks
Telstar-Networks used Ask the Experts™
on
I am running Exchange 2007 on a 2003 box.  At one point I was asked to simply add a few email addresses to existing users, so I went into user properties > email addresses > add and put in the new email.  

Everything worked fine, but then it was decided that a number of these needed to be changed to distribution groups.  I went in, removed the address from the user, then created a new distribution group with the same alias.  This worked on all but 1 of them.  

My problem account has been removed from the user account, mails to that address bounce back as recipient not found, but when I go in to create the alias as a distribution group, I get errors that it already exists.  It doesn't matter what OU I try to create it in, the wizard always gives me the error that this specific object already exists in AD.

I've tried a few commandlets both for get and remove using the alias as the identity and power shell returns that the object couldn't be found on the DC.  

I've run through ADSI Edit and not been able to find any trace of this account.

Any ideas?
Comment
Watch Question

Do more with

Expert Office
EXPERT OFFICE® is a registered trademark of EXPERTS EXCHANGE®

Commented:
Try these two cmdlests to see if they find anything

GROUPNAME is the name of the distro group you are trying to create.
get-user "GROUPNAME"
get-group "GROUPNAME"

and see if they return anything.

Author

Commented:
Nothing, I'm afraid.

Commented:
The error you are getting is it the object already exists or the email address already exists?
C++ 11 Fundamentals

This course will introduce you to C++ 11 and teach you about syntax fundamentals.

Author

Commented:
This is the error.  No matter what OU I try to put it in, I still get it, the only difference is that the directory location changes to wherever I'm trying to create it.  "Service" is the email addy I removed that I'm now trying to add as a distribution group.

-------------------------------
Summary: 1 item(s). 0 succeeded, 1 failed.
Elapsed time: 00:00:00


service
Failed

Error:
Active Directory operation failed on mydomain.domain. The object 'CN=service,CN=Users,DC=mydomain,DC=domain' already exists.

The object exists.

Exchange Management Shell command attempted:
new-DistributionGroup -Name 'service' -Type 'Distribution' -OrganizationalUnit 'mydomain.domain/Users' -SamAccountName 'service' -Alias 'service'

Elapsed Time: 00:00:00

-----------------------------


Shreedhar EtteTechnical Manager
Top Expert 2010

Commented:
Hi,

Refer this article:
http://www.msexchange.org/articles/Finding-Duplicate-SMTP-Addresses.html

Hope this helps,
Shree

Commented:
Try this

Open ADUC
Go into saved queries
Create a new query
Name it whatever you want.
Selcect custum search
In the advanced tab typ (samaccountname=service)
click OK to save
then refresh and see if it find anything

Author

Commented:
Tried Ctrl K, the gui search, and ldifde and nothing found at all.

Author

Commented:
The GUI search from ADUC doesn't come up with anything using either proxyaddresses or samaccountname.

Author

Commented:
Oh, I tried the ADFind tool as well, nothing there either.

Author

Commented:
Just to test (as I can't have this email address down for very long at a time,) I went back and readded the smtp address to the user and it worked fine.  The searches (I assume all, but only tested with proxyaddresses in the ADUC gui) now come up showing the address attributed to the user again.
Hello,

You can't create an object in AD called "service" because it is a built-in object in AD.

JJ
Commented:
jjmck, is correct. I was not paying attention to the name being used, and overlooked that piece.  Thanks for pointing this out.


http://support.microsoft.com/?kbid=266633

Author

Commented:
Ahh, that explains it.  So there's no way to use it as a distribution group then, I take it?
You can't name the group Service but you can change the display name to Service.

JJ

Commented:
you can create a distro group and assign that email address (service@company.com) to the dirsto group but you can not create one with the anme service

Do more with

Expert Office
Submit tech questions to Ask the Experts™ at any time to receive solutions, advice, and new ideas from leading industry professionals.

Start 7-Day Free Trial