Why is the RemoteApp connection via RD Gateway so slow?

PDSWSS
PDSWSS used Ask the Experts™
on
I have set up RemoteApp (MS Access2007) to run via RDWeb via RD Gateway. Clients have connected with XP SP3.  
However, the connection from the remoteApp via RD Gateway takes 2 - 3 minutes even on a cable connection. I need to  make this connection much faster so users are happy. The connection to the RemoteApp page (port 443) moves quickly. The connection from RemoteApp page (port 3389) until the program opens is the problem. The RD Gateway Server and the RD Server are on the same server.   Any idea why this connection would move so slowly? Thanks
Comment
Watch Question

Do more with

Expert Office
EXPERT OFFICE® is a registered trademark of EXPERTS EXCHANGE®
senior developer
Top Expert 2005
Commented:
One possible solution:

1) Open up RemoteApp Manager on the terminal server
2) Click on the Change link next to TS Gateway Settings
3) Uncheck the option "Bypass TS Gateway server for local addresses"

Author

Commented:
jrb1:

Thank you very much. That sped up the Internet connection quite a bit.

However it slowed down the RemoteApp connection off a shortcut (.msi program installed) from the desktop.

Would you be able to explain how this works - not clear to me.  

Author

Commented:
Excellent answer. Thanks again.
C++ 11 Fundamentals

This course will introduce you to C++ 11 and teach you about syntax fundamentals.

jrb1senior developer
Top Expert 2005

Commented:
My other thought was to make sure that port 3389 was exposed along with 443.  I believe the initial delay was due to multiple attempts to connect to port 3389 that all failed.  If you are able to get 3389 opened up, that and setting the gateway back to the original setting may be the best for both of your performance issues.

Author

Commented:
Port 3389 is open and can be connected to by straight forward RDP by users who are given the correct permissions.

Is there a connection between 443 and 3389 that needs to be opened in the Firewall,
some type of port to port connection?  Thanks
jrb1senior developer
Top Expert 2005

Commented:
No, I don't think so.

Here is what some people noticed in there traces:

http://social.technet.microsoft.com/Forums/en-US/winserverTS/thread/a63da211-3e4c-4fb7-b51f-8e61657234a2

Author

Commented:
Port 3389 is open. Do you mean the Port should be open to the server's IP so it can connect to itself?

Thanks
jrb1senior developer
Top Expert 2005

Commented:
From what I can tell, it was not connecting to itself.  Possibly logging network connections might give you more insight on where the actualy delay is coming from and why (in both situations).

Author

Commented:

Thanks. Just posted another question regarding RDWeb and security - Perhaps you could take a look -

http://www.experts-exchange.com/Software/Internet_Email/Web_Browsers/Q_26564335.html
If the MSI installed apps are still slow over the Internet you may have to recreate the MSI and install the update on the clients. Or manually edit the rdp file associated.

Do more with

Expert Office
Submit tech questions to Ask the Experts™ at any time to receive solutions, advice, and new ideas from leading industry professionals.

Start 7-Day Free Trial