Dotnet web service on IIS 7 not working when called remotely

We are trying to upgrade our Windows 2003 Web Server to Windows 2008 Web Server R2 64bit.
I have moved the web sites across to the new server and they all work correctly BUT....
One of the web sites has couple of web services written in Visual Studio 2005 that use WSE 3.0 for basic username and password authentication in the soap header. The service queries data on an SQL server database using SQL authentication.
I have installed WSE 3.0 on the 2008 Web Server.

The web service is consumed by a VS 2005 winforms application (it works on the 2003 web server) When I change the service url to the windows 2008 web server I get the following error when posting
Server was unable to process request. ---> Object reference not set to an instance of an object.

The 2008 web server (webserver) is not public at the moment while I get this sorted out and I have installed one of the webservices in the default website to test

When on the Windows 2008 Web Server
I can browse to http://webserver/MACService/Service.asmx
I can test a service call http://webserver/MACService/Service.asmx?op=GetTransactions, enter the parameters and get data returned. All OK

When on a domain computer
I can browse to http://webserver/MACService/Service.asmx
I cannot test as the test page is not availble unless on the host

When I run my winforms client to communicate with the service using the url http://webserver/MACService/Service.asmx
 I get the error
"Server was unable to process request. ---> Object reference not set to an instance of an object."
Please note, I did test this when the WebServer was public and got the same error.

I am rather lost in IIS 7, I can't seem t find anything anymore. I hope I am missing a simple setting.
bruce_PTSAsked:
Who is Participating?
I wear a lot of hats...

"The solutions and answers provided on Experts Exchange have been extremely helpful to me over the last few years. I wear a lot of hats - Developer, Database Administrator, Help Desk, etc., so I know a lot of things but not a lot about one thing. Experts Exchange gives me answers from people who do know a lot about one thing, in a easy to use platform." -Todd S.

bruce_PTSAuthor Commented:
Further investigation:
It appears that the issue may be WSE 3.0 running on IIS7. This would explain why the sevice works on the host and returns data because the soap header authentication is being bypassed. When the soap authentication is passed in the soap header ie from a remote call, WSE on the server is failing. Does this seem logical? Does anyone know hw to test? Upgrading all the services to WCF is not an option at the moment.

Experts Exchange Solution brought to you by

Your issues matter to us.

Facing a tech roadblock? Get the help and guidance you need from experienced professionals who care. Ask your question anytime, anywhere, with no hassle.

Start your 7-day free trial
SameerJagdaleCommented:
this could even be a timeout issue. Make sure you have set the pool identity and authentication details correctly in IIS 7 against the webservices.
check out this post - http://support.sourcegear.com/viewtopic.php?f=44&t=11665
bruce_PTSAuthor Commented:
Never resolved the issue
It's more than this solution.Get answers and train to solve all your tech problems - anytime, anywhere.Try it for free Edge Out The Competitionfor your dream job with proven skills and certifications.Get started today Stand Outas the employee with proven skills.Start learning today for free Move Your Career Forwardwith certification training in the latest technologies.Start your trial today
.NET Programming

From novice to tech pro — start learning today.