Backup Exec 11d Unable to restore emails to Exchange 2007

generait
generait used Ask the Experts™
on
Dear experts,
I just encounter a problem and need your kindly help.
In my working environment, we use Symantec Backup Exec 11d to backup our users' inbox in Exchange Server 2007. Of course we have  backup exec remote agent installed.
The backup is working fine, however today I try to restore a user's email, I encounter an error:

"The job failed with the following error: To support individual mailbox message and folder restores from Information Store backups, you must download and install the Microsoft Exchange Server MAPI Client and Collaboration Data Objects package version 06.05.7888 or later on the Exchange 2007 server. This package can be found on the Microsoft web site."

From Microsoft, I downloaded "ExchangeMapiCdo.MSI" then installed on Exchange server.
However, it does not work at all. I still got the same job failed message.

If anyone has suggestion, please let me know.

Comment
Watch Question

Do more with

Expert Office
EXPERT OFFICE® is a registered trademark of EXPERTS EXCHANGE®

Commented:
Try to grant the service account the right: Organizational Exchange Administrator in addition of the Server Administrator (with exchange admin tools).
Rodney BarnhardtServer Administrator

Commented:
I would verify all of the prerequisites listed on this other EE solution are met.
 http://www.experts-exchange.com/Software/Server_Software/Email_Servers/Exchange/Q_22839564.html
Saviturb goes into great detail on what needs to be done.

Author

Commented:
The restore service account should be good. From the restore job setting, I have tested the credentials and results are successful.

I have no problem backup users' email but restore.
I checked and the 2 prerequisites are met. I have Exchange management tool installed on Backup Exec media server. Also on Exchange server I have MAPI 1.2.1 installed.

However, I found one thing insteresting that from "Add/Remove Programs", I can see the "MAPI and Collaboration Data Objects 1.2.1" version is 6.5.7974.0. But from my system32 folder, the "mapi32.dll" version is 1.0.2536.0.
Not sure this is correct or something wrong of the MAPI installation. Any idea?
I don't know
Should you be charging more for IT Services?

Do you wonder if your IT business is truly profitable or if you should raise your prices? Learn how to calculate your overhead burden using our free interactive tool and use it to determine the right price for your IT services. Start calculating Now!

Rodney BarnhardtServer Administrator

Commented:
By chance, do you also have Outlook installed on the Exchange server?

Author

Commented:
No outlook installed on email server. Shold I install? But what's the difference?

Thanks for advice.
Rodney BarnhardtServer Administrator

Commented:
No. Just asking in terms of the MAPI versions. What OS is the Exchange server running?
Server Administrator
Commented:
There seems to be a lot of issues where Symantec suggest uninstalling and reinstalling MAPI and CDO for issues. I did locate this:
http://www.symantec.com/docs/TECH57472

Author

Commented:
Hi rbarnhardt,
My Exchange server OS: Windows Server 2003 Standard x64 Edition
We also have Symantec Mail Security installed.

I read the link and double check the registry on Exchange server. The value of "ProgramFilesDir" and "ProgramFilesDir (x86)" is "C:\Program Files" & "C:\Program Files(x86)". I believe we did not midify it at all.

I also think about uninstall current MAPI then reinstall. But do you know if I uninstall it, will that cause any problem to our current users access email via Outlook?
Rodney BarnhardtServer Administrator

Commented:
The best thing to do is to schedule a "maintenance window" and perform everything at once. This way, if there would be any interruption, the users would know there was maintenance going on. This is an uninstall\re-install

Author

Commented:
Since the problem is still existing, I have to call Symantec support for this issue. Thanks you guys suggestion.

Author

Commented:
The problem is still existing. Need to contact Symantec support for futher support.

Do more with

Expert Office
Submit tech questions to Ask the Experts™ at any time to receive solutions, advice, and new ideas from leading industry professionals.

Start 7-Day Free Trial