Save issue with Windows 7 and Office 2007

simpsonj2
simpsonj2 used Ask the Experts™
on
First some background, each student's My Documents is redirected to their home path, which is set to an individual hidden share on the network, so Joe Bloggs is redirected to \\server\bloggsj$, and this is mapped to the Z:\ drive as well. Students can't see the C: drive, and have access to an M: (Common) Y: (Homework) and Z: (Documents) drives. They all use a mandatory profile, and if there are using hard wired desktops, problems are kept to a minimum.

However, we have one ICT room that is using an old switch, and a fair few laptop trolleys, and this is where the problems start.

Problem #1 Students seem to be getting other students My Doc redirected to them. bloogsj get cobaink my Documents, but bloggsj mapped on the Z: drive. This is an obvious concern!

Problem #2 Students create a file in an Office 2007 program, and try to save and, and get either "Z:\Doc1.docx is currently in use. Try again later." Or "Word cannot complete the save due to a file permission error." and then offers to create a Rescue.asd, which it does, on the Z: drive

Students have complete access to the Z: drive, they can save the work onto a flash drive and copy it into their My Documents, they can create other types of file and save them just fine, it is purely that Office 2007, when connected on a slow network, will, occasionally, completely refuse to save onto a network drive. This is happening to 2-3 students every time laptops or the older ICT suite is used.

Things I have tried:

1, I've made the Web Client service run at start up automatically

2, Turned off the Windows Search service, thusly disabling indexing of Network drives

3, Added My Documents to the Trusted Locations in Word and Excel

4, Turned off On Access scanning on the server (not too happy about that)

None of the above has had an effect, as today we had the exact same issue. If anyone has any ideas on how to solve this problem, I would be really grateful!
Comment
Watch Question

Do more with

Expert Office
EXPERT OFFICE® is a registered trademark of EXPERTS EXCHANGE®
sounds like due to the slow network the user profile is not loading fully.

when joe bloggs gets someone else's z: drive it might be the user who last was able to login properly.

take some workstation to another lab where there is not a network speed issue or bottle neck and confirm user profiles, network drives etc work properly.

Author

Commented:
Just to clarify, the Z: drive itself mapped perfectly, bloggj had the right Z: drive, but the My Documents link pointed to \\server\cobaink$, so in effect, bloggsj had two My documents, theirs on the Z drive, cobaink on the My Documents link. Which obviously caused some confusion.

As far as I'm aware, the workstations in other labs where the connection is 100mbs connected back via Fibre cable, everything is working as it should, profiles, network drives and My documents all redirect and work as they should.
Ok so it does sound like due to the slow network the user profile is not loading fully which is why the My Docs folder is incorrect.

I would try, change your GP so My Docs is re-directed to Z:

The Office default save location is My Docs. so the file save issue may go if you can change the above.
Should you be charging more for IT Services?

Do you wonder if your IT business is truly profitable or if you should raise your prices? Learn how to calculate your overhead burden using our free interactive tool and use it to determine the right price for your IT services. Start calculating Now!

Author

Commented:
I've changed the Word and Excel default save to be Z: which sadly hasn't made any difference.

Tbh, I'm more concerned about Office not saving despite the user having all the right permissions for their directory. No issues with Open Office, Notepad, Adobe CS4, just Office 2007 which is the suite of choice here!

However, I think changing the My Documents redirect to be Z: should force the right My Documents, so thank you for that suggestion.

Commented:
I'm wondering why don't you just replace the old switch since that is what's causing the problem to manifest? That way you'll know for sure if is just a slow network, or something else.

Author

Commented:
We will be replacing the switch in due course, however it will still be an issue for laptops, and it occassionally rears its head with those on a fast 100 connection as well.

However, I'm almost certain the problem lies with the C:\Users folder and sub folders, as on further testing, no Adobe products will open when the login is like this, and only "basic" software programs such as notepad will save onto the network drive.

This begs the question, when office tries to save onto a network, does it try to access the local roaming profile, but not when trying to save locally?

Also for the record, I've changed the My Documents redirection to be Z:, which I think has solved the first issue, and I've created a new mandatory profile so that users don't have C:\Users\Public attached in anyway to their library. However, neither of these have solved the main office saving issue, but thank you for all suggestions so far.

Commented:
What are your "Word Options > Save" set to on each laptop?
i.e. AutoRecover file location and Default file location?

Author

Commented:
I think I've found the solution, and its slightly embarrassing.

We had an issue earlier this year with users saving work onto the desktop, which would then be lost because the desktop would be mapped to C:\users\%USERNAME%\ desktop rather than a network location, which led to work being lost. We also had issues with My Documents not being redirected, and so work was being saved onto the local drive, and then being lost. In order to try and prevent this, I set a GPO that prevented users being able to write to C:\Users. this was, in hindsight, a disaster, and so I repealed the GPO, and set another one that enable users to write to C:\Users. However, the second GPO was flawed in that it still had deny permissions for users to Delete, take ownerhip and see permissions on anything in C:\Users. Once I fixed the second GPO, things appear to have sorted themselves.

If that is the case, then thats fine, but I still find it weird that it only affected those with a slow network connection. I would have thought it would have affected everyone, or no one.

Regardless, I think the issue is resolved, and if I don't come across the problem tomorrow, I'll close this question down. Thank you both for your time!

Author

Commented:
Oh, and in answer to your question, both the default save location and autorecover file location is set to Z:\
Commented:
Question PAQ'd and stored in the solution database.

Do more with

Expert Office
Submit tech questions to Ask the Experts™ at any time to receive solutions, advice, and new ideas from leading industry professionals.

Start 7-Day Free Trial